Verify NVIDIA-bumblebee installation

HI,

I’m a new opensuse user and linux newbie and I would like to know how to verify the correct functioning of bumblebee and Nvidia proprietary driver I installed on my system. This is my current gear:

linux-3e27:~ # lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: NVIDIA Corporation GF119M [GeForce GT 520MX] (rev ff)
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 100
04:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)

my laptop model is an ASUS X53S

I followed the instructions on this wiki page:

https://en.opensuse.org/SDB:NVIDIA_Bumblebee

At first I installed bumblebee through the terminal using these commands:

zypper ar -f http://download.opensuse.org/repositories/X11:/Bumblebee/openSUSE_13.2/X11:Bumblebee.repo
zypper in bumblebee
usermod -G bumblebee myusername
systemctl enable bumblebeed

modified manually modprobe.d/50-blacklist.conf with blacklist nouveau

mkinitrd

and rebooted the system and all seemed to work fine.

Then I decided to install the Nvidia proprietary driver:

zypper in nvidia-bumblebee
systemctl enable dkms
zypper in nvidia-bumblebee-32bit

then probably I made something wrong. Reading the message bumblebbe displayed from the previous installation

Message from package bumblebee:

INFO: Please ensure that users using bublebee/video card are in following group(s):
INFO:     gpasswd -a <USER> bumblebee
INFO:   If going to use nvidia binary driver:
INFO:     gpasswd -a <USER> video
INFO: Also ensure the nouveau module is blacklisted (even if you plan to use it):
INFO:     echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf
INFO:     mkinitrd

I entered this command

usermod -G video myusername

and then

mkinitrd

After a reboot I tried to verify the installation as root from the terminal:

optirun --status
Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.

optirun glxspheres
Polygons in scene: 62464 (61 spheres * 1024 polys/spheres)
Visual ID of window: 0x20
Context is Direct
OpenGL Renderer: GeForce GT 520MX/PCIe/SSE2
175.447127 frames/sec - 155.333868 Mpixels/sec
171.864944 frames/sec - 152.162347 Mpixels/sec
171.589610 frames/sec - 151.918577 Mpixels/sec
187.211949 frames/sec - 165.749971 Mpixels/sec
198.129939 frames/sec - 175.416322 Mpixels/sec
199.485137 frames/sec - 176.616161 Mpixels/sec
198.877927 frames/sec - 176.078561 Mpixels/sec
199.248108 frames/sec - 176.406305 Mpixels/sec
196.714915 frames/sec - 174.163517 Mpixels/sec
186.154326 frames/sec - 164.813594 Mpixels/sec
173.697646 frames/sec - 153.784947 Mpixels/sec
152.746642 frames/sec - 135.235767 Mpixels/sec
160.482227 frames/sec - 142.084545 Mpixels/sec

according to the wiki page it looks the Nvidia card is working.

When I went into the Kickoff application laucher I found the NVIDIA X server settings but everytime I click it nothing happens. I can’t figure out if something went wrong during the installation. Where do I have to see if I’m actually using the proprietary driver?.

You did it all right, and the result looks fine.
But, I see that you don’t completely understand how this would work.

To use the NVIDIA card ( which f.e. the NVIDIA-settings would need ) you need to run it through optirun or primusrun. Let’s take Firefox as an example

Open a terminal window, we’re starting Firefox from a command line

Run Firefox using the Intel

firefox

Run Firefox using the NVIDIA

optirun firefox

Now, I don’t know what desktop environment you’re running, but what needs to be done is changing the menu entry from running nvidia-settings to running “optirun nvidia-settings”.

If you really want to know, try:

bruno@localhost:~> glxinfo
name of display: :1
display: :1  screen: 0
...
OpenGL vendor string: **Intel** Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Mobile 
OpenGL core profile version string: 3.3 (Core Profile) Mesa 11.0.0
...

for Intel
and:

bruno@localhost:~> optirun glxinfo
name of display: :1
display: :1  screen: 0
...
OpenGL vendor string: **NVIDIA** Corporation
OpenGL renderer string: GeForce GTX 960M/PCIe/SSE2
OpenGL core profile version string: 4.4.0 NVIDIA 352.41
OpenGL core profile shading language version string: 4.40 NVIDIA via Cg compiler
...

for NVIDIA.

I’m using KDE. I noticed that optirun commands run only in root mode otherwise i get this message:

geeko@linux-14s3:~> optirun glxspheres
  318.766245] [ERROR]You've no permission to communicate with the Bumblebee daemon. Try adding yourself to the 'bumblebee' group
  318.766362] [ERROR]Could not connect to bumblebee daemon - is it running?

I tried as root to run optirun nvidia-settings and this is what I got:

linux-14s3:~ # optirun nvidia-settings

ERROR: nvidia-settings could not find the registry key file. This file should
       have been installed along with this driver at
       /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be
       preopulated or validated, and will not be listed in the help text. Please
       see the README for possible values and descriptions.

Gtk-Message: GtkDialog mapped without a transient parent. This is discouraged.

The Nvidia X Server settings window pops up and it says:
*
You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.*

After I close this message the gui window doesn’t respond anymore and I’m forced to close it with the KSysGuard. This is what I get if I run as root nvidia-xconfig:

linux-14s3:~ # optirun nvidia-xconfig

WARNING: Unable to locate/open X configuration file.

Package xorg-server was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-server.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xorg-server' found
New X configuration file written to '/etc/X11/xorg.conf'
linux-14s3:~ # nvidia-xconfig

Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

I’ve just rebooted the pc after the nvidia-xconfig command and the X server stopped working. Here are some pics (sorry for the bad quality):

](http://postimg.org/image/l6ja8gf3x/)http://s30.postimg.org/l6ja8gf3x/WP_20151007_003.jpg](http://postimg.org/image/85gsssy4f/)http://s27.postimg.org/85gsssy4f/WP_20151007_004.jpg](http://postimg.org/image/skh1qfpyp/)http://s8.postimg.org/skh1qfpyp/WP_20151007_005.jpg](http://postimg.org/image/9qzenr5nj/)http://s3.postimg.org/9qzenr5nj/WP_20151007_006.jpg

What do I have to do?

I booted in fail safe mode and looked for Xorg logs. Here they are:

xorg.conf

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 352.41  (buildmeister@swio-display-x64-rhel04-11)  Sat Aug 22 00:01:10 PDT 2015


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from data in "/etc/sysconfig/mouse"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "IMPS/2"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "yes"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection


Xorg.0.log

    29.100] 
X.Org X Server 1.16.1
Release Date: 2014-09-21
    29.100] X Protocol Version 11, Revision 0
    29.100] Build Operating System: openSUSE SUSE LINUX
    29.100] Current Operating System: Linux linux-14s3.site  3.16.7-24-desktop #1 SMP PREEMPT Mon Aug 3 14:37:06 UTC 2015 (ec183cc)  x86_64
    29.100] Kernel command line:  BOOT_IMAGE=/boot/vmlinuz-3.16.7-24-desktop  root=UUID=a45f2675-6c98-4f70-8b22-20ba303c2018 showopts apm=off noresume  edd=off powersaved=off nohz=off highres=off processor.max_cstate=1  nomodeset x11failsafe
    29.100] Build Date: 12 June 2015  07:55:09PM
    29.100]  
    29.100] Current version of pixman: 0.32.6
    29.100]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
    29.100] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    29.100] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct  7 20:24:21 2015
    29.100] (==) Using config file: "/etc/X11/xorg.conf.install"
    29.100] (==) Using config directory: "/etc/X11/xorg.conf.d"
    29.100] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    29.114] (==) ServerLayout "Layout"
    29.114] (**) |-->Screen "vboxvideo" (0)
    29.114] (**) |   |-->Monitor "<default monitor>"
    29.114] (**) |   |-->Device "vboxvideo"
    29.114] (==) No monitor specified for screen "vboxvideo".
    Using a default monitor configuration.
    29.114] (**) |-->Screen "vmware" (1)
    29.114] (**) |   |-->Monitor "<default monitor>"
    29.114] (**) |   |-->Device "vmware"
    29.114] (==) No monitor specified for screen "vmware".
    Using a default monitor configuration.
    29.114] (**) |-->Screen "modesetting" (2)
    29.114] (**) |   |-->Monitor "<default monitor>"
    29.114] (**) |   |-->Device "modesetting"
    29.114] (==) No monitor specified for screen "modesetting".
    Using a default monitor configuration.
    29.114] (**) |-->Screen "fbdev" (3)
    29.114] (**) |   |-->Monitor "<default monitor>"
    29.115] (**) |   |-->Device "fbdev"
    29.115] (==) No monitor specified for screen "fbdev".
    Using a default monitor configuration.
    29.115] (**) |-->Screen "vesa" (4)
    29.115] (**) |   |-->Monitor "<default monitor>"
    29.115] (**) |   |-->Device "vesa"
    29.115] (==) No monitor specified for screen "vesa".
    Using a default monitor configuration.
    29.115] (==) Automatically adding devices
    29.115] (==) Automatically enabling devices
    29.115] (==) Automatically adding GPU devices
    29.281] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    29.281]     Entry deleted from font path.
    29.288] (==) FontPath set to:
    /usr/share/fonts/misc:unscaled,
    /usr/share/fonts/Type1/,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/ghostscript/,
    /usr/share/fonts/cyrillic:unscaled,
    /usr/share/fonts/truetype/,
    built-ins
    29.288] (==) ModulePath set to "/usr/lib64/xorg/modules"
    29.288] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
    29.288] (II) Loader magic: 0x80ec80
    29.288] (II) Module ABI versions:
    29.288]     X.Org ANSI C Emulation: 0.4
    29.288]     X.Org Video Driver: 18.0
    29.288]     X.Org XInput driver : 21.0
    29.288]     X.Org Server Extension : 8.0
    29.291] (--) PCI:*(0:0:2:0) 8086:0116:1043:1682 rev 9, Mem @ 0xdc400000/4194304, 0xb0000000/268435456, I/O @ 0x0000e000/64
    29.291] (II) LoadModule: "glx"
    29.318] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
    29.321] (II) Module glx: vendor="X.Org Foundation"
    29.321]     compiled for 1.16.1, module version = 1.0.0
    29.321]     ABI class: X.Org Server Extension, version 8.0
    29.321] (==) AIGLX enabled
    29.321] (II) LoadModule: "vboxvideo"
    29.371] (WW) Warning, couldn't open module vboxvideo
    29.371] (II) UnloadModule: "vboxvideo"
    29.371] (II) Unloading vboxvideo
    29.371] (EE) Failed to load module "vboxvideo" (module does not exist, 0)
    29.371] (II) LoadModule: "vmware"
    29.371] (WW) Warning, couldn't open module vmware
    29.371] (II) UnloadModule: "vmware"
    29.371] (II) Unloading vmware
    29.371] (EE) Failed to load module "vmware" (module does not exist, 0)
    29.371] (II) LoadModule: "modesetting"
    29.372] (II) Loading /usr/lib64/xorg/modules/drivers/modesetting_drv.so
    29.396] (II) Module modesetting: vendor="X.Org Foundation"
    29.396]     compiled for 1.16.1, module version = 0.9.0
    29.396]     Module class: X.Org Video Driver
    29.396]     ABI class: X.Org Video Driver, version 18.0
    29.396] (II) LoadModule: "fbdev"
    29.397] (II) Loading /usr/lib64/xorg/modules/drivers/fbdev_drv.so
    29.400] (II) Module fbdev: vendor="X.Org Foundation"
    29.400]     compiled for 1.16.1, module version = 0.4.4
    29.400]     Module class: X.Org Video Driver
    29.400]     ABI class: X.Org Video Driver, version 18.0
    29.400] (II) LoadModule: "vesa"
    29.400] (II) Loading /usr/lib64/xorg/modules/drivers/vesa_drv.so
    29.401] (II) Module vesa: vendor="X.Org Foundation"
    29.401]     compiled for 1.16.1, module version = 2.3.3
    29.401]     Module class: X.Org Video Driver
    29.401]     ABI class: X.Org Video Driver, version 18.0
    29.401] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    29.401] (II) FBDEV: driver for framebuffer: fbdev
    29.401] (II) VESA: driver for VESA chipsets: vesa
    29.401] (++) using VT number 7

    29.401] (EE) open /dev/dri/card0: No such file or directory
    29.401] (WW) Falling back to old probe method for modesetting
    29.401] (EE) open /dev/dri/card0: No such file or directory
    29.401] (II) Loading sub module "fbdevhw"
    29.401] (II) LoadModule: "fbdevhw"
    29.402] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
    29.411] (II) Module fbdevhw: vendor="X.Org Foundation"
    29.411]     compiled for 1.16.1, module version = 0.0.2
    29.411]     ABI class: X.Org Video Driver, version 18.0
    29.411] (**) FBDEV(1): claimed PCI slot 0@0:2:0
    29.411] (II) FBDEV(1): using default device
    29.411] (WW) Falling back to old probe method for vesa
    29.411] (EE) Screen 0 deleted because of no matching config section.
    29.411] (II) UnloadModule: "modesetting"
    29.411] (II) FBDEV(0): Creating default Display subsection in Screen section
    "fbdev" for depth/fbbpp 24/32
    29.411] (==) FBDEV(0): Depth 24, (==) framebuffer bpp 32
    29.411] (==) FBDEV(0): RGB weight 888
    29.411] (==) FBDEV(0): Default visual is TrueColor
    29.411] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
    29.411] (II) FBDEV(0): hardware: VESA VGA (video memory: 3072kB)
    29.411] (II) FBDEV(0): checking modes against framebuffer device...
    29.411] (II) FBDEV(0): checking modes against monitor...
    29.411] (--) FBDEV(0): Virtual size is 1024x768 (pitch 1024)
    29.411] (**) FBDEV(0):  Built-in mode "current": 78.7 MHz, 59.9 kHz, 75.7 Hz
    29.411] (II) FBDEV(0): Modeline "current"x0.0   78.65  1024 1056  1184 1312  768 772 776 792 -hsync -vsync -csync (59.9 kHz b)
    29.411] (==) FBDEV(0): DPI set to (96, 96)
    29.411] (II) Loading sub module "fb"
    29.411] (II) LoadModule: "fb"
    29.411] (II) Loading /usr/lib64/xorg/modules/libfb.so
    29.413] (II) Module fb: vendor="X.Org Foundation"
    29.413]     compiled for 1.16.1, module version = 1.0.0
    29.413]     ABI class: X.Org ANSI C Emulation, version 0.4
    29.413] (**) FBDEV(0): using shadow framebuffer
    29.413] (II) Loading sub module "shadow"
    29.413] (II) LoadModule: "shadow"
    29.413] (II) Loading /usr/lib64/xorg/modules/libshadow.so
    29.437] (II) Module shadow: vendor="X.Org Foundation"
    29.437]     compiled for 1.16.1, module version = 1.1.0
    29.437]     ABI class: X.Org ANSI C Emulation, version 0.4
    29.437] (II) UnloadModule: "vesa"
    29.437] (II) Unloading vesa
    29.437] (==) Depth 24 pixmap format is 32 bpp
    29.437] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
    29.437] (==) FBDEV(0): Backing store enabled
    29.437] (==) FBDEV(0): DPMS enabled
    29.437] (==) RandR enabled
    29.444] (II) AIGLX: Screen 0 is not DRI2 capable
    29.444] (EE) AIGLX: reverting to software rendering
    30.542] (II) AIGLX: Loaded and initialized swrast
    30.543] (II) GLX: Initialized DRISWRAST GL provider for screen 0
    30.922] (II) config/udev: Adding input device Power Button (/dev/input/event6)
    30.922] (**) Power Button: Applying InputClass "evdev keyboard catchall"
    30.922] (**) Power Button: Applying InputClass "system-keyboard"
    30.922] (**) Power Button: Applying InputClass "evdev keyboard catchall"
    30.922] (II) LoadModule: "evdev"
    30.923] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
    30.957] (II) Module evdev: vendor="X.Org Foundation"
    30.957]     compiled for 1.16.1, module version = 2.9.0
    30.957]     Module class: X.Org XInput Driver
    30.957]     ABI class: X.Org XInput driver, version 21.0
    30.957] (II) Using input driver 'evdev' for 'Power Button'
    30.957] (**) Power Button: always reports core events
    30.957] (**) evdev: Power Button: Device: "/dev/input/event6"
    30.958] (--) evdev: Power Button: Vendor 0 Product 0x1
    30.958] (--) evdev: Power Button: Found keys
    30.958] (II) evdev: Power Button: Configuring as keyboard
    30.958] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input13/event6"
    30.958] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
    30.958] (**) Option "xkb_rules" "evdev"
    30.958] (**) Option "xkb_model" "pc105"
    30.958] (**) Option "xkb_layout" "it"
    30.958] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    31.017] (II) config/udev: Adding input device Lid Switch (/dev/input/event4)
    31.017] (II) No input driver specified, ignoring this device.
    31.017] (II) This device may have been added with another device file.
    31.018] (II) config/udev: Adding input device Sleep Button (/dev/input/event5)
    31.018] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
    31.018] (**) Sleep Button: Applying InputClass "system-keyboard"
    31.018] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
    31.018] (II) Using input driver 'evdev' for 'Sleep Button'
    31.018] (**) Sleep Button: always reports core events
    31.018] (**) evdev: Sleep Button: Device: "/dev/input/event5"
    31.018] (--) evdev: Sleep Button: Vendor 0 Product 0x3
    31.018] (--) evdev: Sleep Button: Found keys
    31.018] (II) evdev: Sleep Button: Configuring as keyboard
    31.018] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input12/event5"
    31.018] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 7)
    31.018] (**) Option "xkb_rules" "evdev"
    31.018] (**) Option "xkb_model" "pc105"
    31.018] (**) Option "xkb_layout" "it"
    31.018] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    31.019] (II) config/udev: Adding input device USB 2.0 UVC VGA WebCam (/dev/input/event8)
    31.019] (**) USB 2.0 UVC VGA WebCam: Applying InputClass "evdev keyboard catchall"
    31.019] (**) USB 2.0 UVC VGA WebCam: Applying InputClass "system-keyboard"
    31.019] (**) USB 2.0 UVC VGA WebCam: Applying InputClass "evdev keyboard catchall"
    31.020] (II) Using input driver 'evdev' for 'USB 2.0 UVC VGA WebCam'
    31.020] (**) USB 2.0 UVC VGA WebCam: always reports core events
    31.020] (**) evdev: USB 2.0 UVC VGA WebCam: Device: "/dev/input/event8"
    31.020] (--) evdev: USB 2.0 UVC VGA WebCam: Vendor 0x13d3 Product 0x5710
    31.020] (--) evdev: USB 2.0 UVC VGA WebCam: Found keys
    31.020] (II) evdev: USB 2.0 UVC VGA WebCam: Configuring as keyboard
    31.020] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/input/input15/event8"
    31.020] (II) XINPUT: Adding extended input device "USB 2.0 UVC VGA WebCam" (type: KEYBOARD, id 8)
    31.020] (**) Option "xkb_rules" "evdev"
    31.020] (**) Option "xkb_model" "pc105"
    31.020] (**) Option "xkb_layout" "it"
    31.020] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"


    31.021] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event10)
    31.021] (II) No input driver specified, ignoring this device.
    31.021] (II) This device may have been added with another device file.
    31.021] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event11)
    31.021] (II) No input driver specified, ignoring this device.
    31.021] (II) This device may have been added with another device file.
    31.022] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=3 (/dev/input/event12)
    31.022] (II) No input driver specified, ignoring this device.
    31.022] (II) This device may have been added with another device file.
    31.022] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event1)
    31.022] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
    31.023] (**) Logitech USB Receiver: Applying InputClass "system-keyboard"
    31.023] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
    31.023] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
    31.023] (**) Logitech USB Receiver: always reports core events
    31.023] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event1"
    31.023] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52e
    31.023] (--) evdev: Logitech USB Receiver: Found keys
    31.023] (II) evdev: Logitech USB Receiver: Configuring as keyboard
    31.023] (**) Option "config_info"   "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/0003:046D:C52E.0001/input/input9/event1"
    31.023] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 9)
    31.023] (**) Option "xkb_rules" "evdev"
    31.023] (**) Option "xkb_model" "pc105"
    31.023] (**) Option "xkb_layout" "it"
    31.023] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    31.024] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event2)
    31.024] (**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall"
    31.024] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
    31.024] (**) Logitech USB Receiver: Applying InputClass "system-keyboard"
    31.024] (**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall"
    31.024] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"
    31.024] (II) Using input driver 'evdev' for 'Logitech USB Receiver'
    31.024] (**) Logitech USB Receiver: always reports core events
    31.024] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event2"
    31.024] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52e
    31.024] (--) evdev: Logitech USB Receiver: Found 20 mouse buttons
    31.024] (--) evdev: Logitech USB Receiver: Found scroll wheel(s)
    31.024] (--) evdev: Logitech USB Receiver: Found relative axes
    31.024] (--) evdev: Logitech USB Receiver: Found x and y relative axes
    31.024] (--) evdev: Logitech USB Receiver: Found absolute axes
    31.024] (II) evdev: Logitech USB Receiver: Forcing absolute x/y axes to exist.
    31.024] (--) evdev: Logitech USB Receiver: Found keys
    31.024] (II) evdev: Logitech USB Receiver: Configuring as mouse
    31.024] (II) evdev: Logitech USB Receiver: Configuring as keyboard
    31.024] (II) evdev: Logitech USB Receiver: Adding scrollwheel support
    31.024] (**) evdev: Logitech USB Receiver: YAxisMapping: buttons 4 and 5
    31.024] (**) evdev: Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    31.024] (**) Option "config_info"   "udev:/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.1/0003:046D:C52E.0002/input/input10/event2"
    31.024] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 10)
    31.024] (**) Option "xkb_rules" "evdev"
    31.025] (**) Option "xkb_model" "pc105"
    31.025] (**) Option "xkb_layout" "it"
    31.025] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    31.025] (II) evdev: Logitech USB Receiver: initialized for relative axes.
    31.025] (WW) evdev: Logitech USB Receiver: ignoring absolute axes.
    31.025] (**) Logitech USB Receiver: (accel) keeping acceleration scheme 1
    31.025] (**) Logitech USB Receiver: (accel) acceleration profile 0
    31.025] (**) Logitech USB Receiver: (accel) acceleration factor: 2.000
    31.025] (**) Logitech USB Receiver: (accel) acceleration threshold: 4
    31.026] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/mouse0)
    31.026] (**) Logitech USB Receiver: Applying InputClass "system-keyboard"
    31.026] (II) No input driver specified, ignoring this device.
    31.026] (II) This device may have been added with another device file.
    31.026] (II) config/udev: Adding input device Asus WMI hotkeys (/dev/input/event9)
    31.027] (**) Asus WMI hotkeys: Applying InputClass "evdev keyboard catchall"
    31.027] (**) Asus WMI hotkeys: Applying InputClass "system-keyboard"
    31.027] (**) Asus WMI hotkeys: Applying InputClass "evdev keyboard catchall"
    31.027] (II) Using input driver 'evdev' for 'Asus WMI hotkeys'
    31.027] (**) Asus WMI hotkeys: always reports core events
    31.027] (**) evdev: Asus WMI hotkeys: Device: "/dev/input/event9"
    31.027] (--) evdev: Asus WMI hotkeys: Vendor 0 Product 0
    31.027] (--) evdev: Asus WMI hotkeys: Found keys
    31.027] (II) evdev: Asus WMI hotkeys: Configuring as keyboard
    31.027] (**) Option "config_info" "udev:/sys/devices/platform/asus-nb-wmi/input/input16/event9"
    31.027] (II) XINPUT: Adding extended input device "Asus WMI hotkeys" (type: KEYBOARD, id 11)
    31.027] (**) Option "xkb_rules" "evdev"
    31.027] (**) Option "xkb_model" "pc105"
    31.027] (**) Option "xkb_layout" "it"
    31.027] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    31.028] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
    31.028] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
    31.028] (**) AT Translated Set 2 keyboard: Applying InputClass "system-keyboard"
    31.028] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
    31.028] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
    31.028] (**) AT Translated Set 2 keyboard: always reports core events
    31.028] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
    31.028] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
    31.028] (--) evdev: AT Translated Set 2 keyboard: Found keys
    31.028] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
    31.028] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
    31.028] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 12)
    31.028] (**) Option "xkb_rules" "evdev"
    31.028] (**) Option "xkb_model" "pc105"
    31.028] (**) Option "xkb_layout" "it"
    31.028] (**) Option "xkb_options" "terminate:ctrl_alt_bksp"
    31.029] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event3)
    31.029] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
    31.029] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
    31.029] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
    31.029] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "Default clickpad buttons"
    31.029] (II) LoadModule: "synaptics"
    31.029] (II) Loading /usr/lib64/xorg/modules/input/synaptics_drv.so
    31.038] (II) Module synaptics: vendor="X.Org Foundation"
    31.038]     compiled for 1.16.1, module version = 1.8.1
    31.039]     Module class: X.Org XInput Driver
    31.039]     ABI class: X.Org XInput driver, version 21.0
    31.039] (II) Using input driver 'synaptics' for 'SynPS/2 Synaptics TouchPad'
    31.039] (**) SynPS/2 Synaptics TouchPad: always reports core events
    31.039] (**) Option "Device" "/dev/input/event3"
    31.049] (II) synaptics: SynPS/2 Synaptics TouchPad: ignoring touch events for semi-multitouch device
    31.049] (--) synaptics: SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5762 (res 52)
    31.049] (--) synaptics: SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4902 (res 83)
    31.049] (--) synaptics: SynPS/2 Synaptics TouchPad: pressure range 0 - 255
    31.049] (--) synaptics: SynPS/2 Synaptics TouchPad: finger width range 0 - 15
    31.049] (--) synaptics: SynPS/2 Synaptics TouchPad: buttons: left right double triple
    31.049] (--) synaptics: SynPS/2 Synaptics TouchPad: Vendor 0x2 Product 0x7
    31.049] (**) Option "HorizEdgeScroll" "off"
    31.049] (**) Option "TapButton1" "1"
    31.049] (**) Option "TapButton2" "3"
    31.049] (**) Option "TapButton3" "2"
    31.049] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
    31.049] (**) SynPS/2 Synaptics TouchPad: always reports core events
    31.057] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/input/input8/event3"
    31.057] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 13)
    31.057] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MinSpeed is now constant deceleration 2.5
    31.057] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) MaxSpeed is now 1.75
    31.057] (**) synaptics: SynPS/2 Synaptics TouchPad: (accel) AccelFactor is now 0.036
    31.057] (**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
    31.057] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration profile 1
    31.057] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
    31.057] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
    31.058] (--) synaptics: SynPS/2 Synaptics TouchPad: touchpad found
    31.058] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse1)
    31.058] (**) SynPS/2 Synaptics TouchPad: Ignoring device from InputClass "touchpad ignore duplicates"
    31.058] (II) config/udev: Adding input device PC Speaker (/dev/input/event7)
    31.059] (II) No input driver specified, ignoring this device.
    31.059] (II) This device may have been added with another device file.
    31.067] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
    45.800] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)
    45.862] (II) FBDEV(0): FBIOBLANK: Invalid argument (Screen blanking not supported by vesafb of Linux Kernel)

Did you add your self to the bumblebee group??

You can see what groups you belong and change them in Yast -user and group management

This log is for the failsafe session, you should have looked into the Xorg.0log.old. But anyway delete the file /etc/X11/xorg.conf you created with nvidia-xconfig, you shouldn’t have one.

In user and group management I see this:

Login:geeko
Name:geeko
User ID:1000
Groups:video,bumblebee,users

I suppose I added myself correctly. Anyway now I can’t boot into the desktop. This problem began when I ran the nvidia-xconfig command. Reading some documentation on the bumblebee site in the troubleshooting section (https://github.com/Bumblebee-Project/Bumblebee/wiki/Troubleshooting) it says to check /var/log/Xorg.8.log:

geeko@linux-14s3:~> grep -Fn '(EE' /var/log/Xorg.8.log
15:     (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
100:   473.968] (EE) [drm] KMS not enabled
101:   473.968] (EE) No devices detected.
102:   473.968] (EE) 
104:   473.968] (EE) no screens found(EE) 
105:   473.968] (EE) 
109:   473.968] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
110:   473.968] (EE) 
geeko@linux-14s3:~> 

I don’t know if this applies also to opensuse but in the debian wiki page about bumblebee (https://wiki.debian.org/Bumblebee) i found this line:

Warning: If you choose to install bumblebee-nvidia and the dependent nvidia driver packages, during postinst, you will see a debconf prompt warning you that you need to create a xorg.conf file in order to use the proprietary nvidia driver. This prompt only applies to non-Optimus users, i.e. single Nvidia GPU systems. Do NOT allow debconf to create a xorg.conf file, and do NOT run nvidia-xconfig! (This prompt always appears when you install nvidia packages through the repositories, and it currently does not detect Optimus/bumblebee users. See 735049 for a brief explanation.)

Actually I ran the nvidia-xconfig command and the Xserver stopped working. This command if I’m not mistaken changed the /etc/X11/xorg.conf file and so the X server refuses to work when I boot the pc.

Ok, thx. I’ve just deleted the file and the X starts again. In the directory there’s also a xorg.conf.nvidia-xconfig-original file: do I have to delete that?

Ty for help. If I run these commands it ends up like this:

geeko@linux-14s3:~> glxinfo
If 'glxinfo' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf glxinfo
geeko@linux-14s3:~> sudo glxinfo
root's password:
sudo: glxinfo: comando non trovato
geeko@linux-14s3:~> optirun glxinfo
/usr/bin/vglrun: line 246: exec: glxinfo: not found
geeko@linux-14s3:~> 

You don’t have to, Xorg won’t use it, but delete it anyway as it’s just confusing.

Now if I try to check bumblebee, it goes like this:

geeko@linux-14s3:~> sudo optirun --status
root's password:
Bumblebee status: Error (3.2.1): [XORG] (EE) Server terminated successfully (0). Closing log file.

geeko@linux-14s3:~>

Something is not going well with your bumblebee; a normal output would be like:


bruno@LT_B:~> optirun --status
Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is likely on.

no need for “sudo”, if the current user is a member of “video” and “bumblebee” groups, as it should be normally.

BTW, “glxinfo” is in the “Mesa-demo-x” package, I thought that it was installed with bumblebee by default.

So,

after a reboot I tried to run as root optirun --status and optirun glxspheres and according to the opensuse wiki bumblebee is working. If I close the terminal window and then I decide to open another one I got the same error of the previous post:

geeko@linux-14s3:~> sudo optirun --status
root's password:
Bumblebee status: Error (3.2.1): [XORG] (EE) Server terminated successfully (0). Closing log file.

geeko@linux-14s3:~>

Do I have to worry? Anyway, is someone else able to run the nvidia-settings after installing nvidia-bumblebee? Is this problem only related to my hardware? Does someone run the nvidia-xconfig command without compromising Xorg?

One more thing. Now every time I turn on the pc, before Xorg starts and I get into the desktop environment I read something like this:

[FAILED] Failed to start Load Kernel Modules.
See “systemctl status systemd-modules-load.service” for details.
2.878897] systemd[1]:Failed to start Load Kernel Modules.

What does


systemctl status bumblebeed.service 

give

And, run

optirun --status

as your user

I still don’t understand why you have to use “sudo”: if you are not in the “bumblebee” group you cannot have access to the “hidden” X anyway…
And I did no nvidia-xconfig, it is not needed with Optimus-bumblebee, IMHO it is just for those desktops that only have an NVIDIA video card.
And maybe nvidia-settings is the same, I don’t really know.

One more thing. Now every time I turn on the pc, before Xorg starts and I get into the desktop environment I read something like this:

[FAILED] Failed to start Load Kernel Modules.
See “systemctl status systemd-modules-load.service” for details.
2.878897] systemd[1]:Failed to start Load Kernel Modules.

I see the same here and everything is working like charm…

Here it goes:

geeko@linux-14s3:~> systemctl status bumblebeed.service
bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled)
   Active: active (running) since gio 2015-10-08 15:32:26 CEST; 1h 13min ago
 Main PID: 1207 (bumblebeed)
   CGroup: /system.slice/bumblebeed.service
           └─1207 /usr/sbin/bumblebeed

geeko@linux-14s3:~> optirun --status
Bumblebee status: Error (3.2.1): [XORG] (EE) Server terminated successfully (0). Closing log file.

geeko@linux-14s3:~>