Ver 12.3: Rescue Install doesn't work, Graphics update problem, Drive mount problem

Installing 12.3 on a separate drive. Computer (AMD XT,Gibabyte 970A/DS3, Radeon 6450) works ok on windows XP (different drive). Several previous attempts to load earlier SUSE and other Penguins all showed severe video problems after installing the above 64-bit system. Big vertical bars of color, behind which active text was visible but not intelligible: various helpers diagnosed driver. I got new driver from mfr. for video card. New openSUSE12.3 announced, with all those wonderful instructions! I’M READY TO GO!

Downloaded iso, burned to DVD-RW, verified disk, booted from DVD, selected Rescue System, F3 Text Mode, F6 Driver Yes. Started Rescue mode, lots of text flew by, and I was back in garbled video. Text Only didn’t work, didn’t pause for me to insert driver. Same for many varied attempts, anything I could come up with.

Also, this drive (both my spare drives) had Windows crashes, and both showed “NTLDR is missing”. I was told that meant the Windows header was deleted, I had to install to another header on the drive. I’m hoping 12.3 will try to load on that other header, but so far I still see “NTLDR is missing.” I hope that’s just because 12.3 hasn’t attemped to load yet.


ntldr is the boot loader for windows should have nothing to so with Linux. OpenSUSE uses grub as a boot loader and normally you don’t us the Windows one.

Very confused at what you did.

  1. after boot ing the DVD did you see a menu?
  2. did you select f3 and set nokms before doing anything else?
  3. you do not use rescue mode until after you do the install.

First, the most common cause of “NTLDR is missing” is simply that the Windows bootloader can’t find NTLDR. Usually that is because the disk arcpath has changed, ie the disk and partition paths in your machine have changed. The most common way I avoid spontaneously changing paths is to not install into Primary partitions, instead installing into logical drives in an Extended partition so that there is only one Primary partition on the boot disk. On a temporary basis if you can remember the exact physical configuration of your disks when you installed Windows, you can restore that and Windows should work (although everything else might not).

As for installing a replacement video driver, you might find it better to boot into text or Emergency mode, then install your new driver. Oftentimes Emergency mode will work giving you a graphical desktop because it’ll be in VESA 640x480 VGA mode instead of using your problem video driver.


I’m still in boot from DVD mode. Emergency mode doesn’t seem to be an option. Thanks for the reply.

I thought NTLDR was a Windows issue, but other Linux downloads seemed to hang on it.

First you must install to get by the video problems select f3-nokms if that does not work try text mode.

Once installed you can get the driver for your card installed,

  1. I don’t know if I ever finished booting the DVD. I couldn’t tell what was happening because of the graphics problem.
    2} I selected F3 Text Only to prevent it going into graphics mode, but it did anyway. Should I leave it running, hoping it would clear up later?
  2. OK. I’ll try letting it complete boot, then try to rescue if necessary.


I tried to let it install completely, but it kept putting up screens that wanted replies, and I couldn’t read enough of them because of the graphics problems. I managed to put my name and passwords in, but then got a screen with a list of options (I think), and I couldn’t read enough, especially on extra screens that popped up. I accidentally cancelled the installation.

This problem has 20 vertical bars across the screen, in alternating colors, and a lot of visual noise. Sometimes I can’t read anything, sometimes enough to barely make it out, popups are worse.

Isn’t there any way to do the installation in text? That’s what I thought F3 was for.

F3 then select nokms or text

Just pressing F3 does nothing.

Remeber we can’t see over your shoulder you have to say exactly what you did.

I did a complete install by following the screen views in the manual, guessing where there weren’t views if I couldn’t make out the text at all. Didn’t get out of the bad screens until the install was complete, and it shut down immediatly. When I restart with boot to hard drive, I get “Error loading operating system.” I never got a chance to install the driver, unless it was in an unreadable screen.

I selected Text Mode every time, but it never worked. “Rescue” from the DVD didn’t seem to work, either.

Rescue Install (from CD) is now working, but when it asks for the driver, on a palm drive, it fails to recognize it. File is amd-driver-installer-catalyst-13.1-linux-x86.x86_64.

SUSE is not yet loaded into partition. If I try to run it without CD, I get the same NTLDR is missing message, but it seems to have partitioned all my drives, including the palm drive!

I also tried installing the driver through XP, but it didn’t recognize it either. Didn’t really expect it to, but I’m trying anything.