VBox stopped working after update today


Failed to start the virtual machine Win10.

Failed to load unit 'vga' (VERR_SSM_DATA_UNIT_FORMAT_CHANGED).

Result Code:NS_ERROR_FAILURE (0X80004005)
Interface:IConsole {6ac83d89-6ee7-4e33-8ae6-b257b2e81be8}

@gogalthorp discard the vm saved state and try starting again…

Tried to start but Windows 10 would not start gives cryptic Windows error trys to repair and fails Tried full power off but it failed also. Think I’ll try dropping back a version

Often the Message NS_ERROR_FAILURE (0X80004005) means that you have the wrong Ext Pack version installed. Make sure that your extension pack version matches the VB version…

thanks will do but dropping back a version worked Windows VM now working

Hmmm how to check pack when Windows VM not running? Does not seem to be in the VB console just the VM menu

OK see guest tools in repos now is that new you used to have to download from web But you still have to import to the VM

I have no issues starting Windows 10 and Windows 11 guests in VirtualBox 7.0.4.
You no longer need the Oracle VirtualBox Extensions to do USB in Windows guests.

You cannot restart a saved version from 6.1.xx in 7.0.4. so you need to Discard them to get 7.0.4 to run you Windows VM. If you guest additions are too old in your Windows VM - it may not start - 6.1.38 or newer works 6.1.20 does not too many API changes. Windows VM’s starts fine (except for 3D video which is broken in 7.0.4).

1 Like

A Windows 10 VM without UEFI was booting OK.
A Windows 10 VM with UEFI failed to boot with the following error:

00:00:01.342947 Opening the UEFI variable store '/home01/User-VMs/xxx/Windows-10_EFI/Windows 10.nvram' failed with VERR_VFS_UNSUPPORTED_FORMAT
00:00:01.342993 VMSetError: /home/abuild/rpmbuild/BUILD/VirtualBox-7.0.4/src/VBox/Main/src-all/NvramStoreImpl.cpp(1584) static int NvramStore::i_drvConstruct(PPDMDRVINS, PCFGMNODE, uint32_t); rc=VERR_VFS_UNSUPPORTED_FORMAT
00:00:01.342994 VMSetError: Failed to load the NVRAM store from the file

Moved the “Windows 10.nvram” over to another directory and, now it’s booting but, with lots of restarts, network activity, CPU usage and, disk activity:

You can see what version of Guest Additions by holding down the right ctrl and N key on the virtual machine - it will be on the runtime tab.

If the nvram gets corrupt - it will work fine if you remove it and virtualbox will make a new one.

Be warned that if you use bitlocker - it may make your disk unusable if you did not save the key.

Mine did not boot. I dropped back to previous version and removed the Guest Additions then reinstalled the new that worked. The new version did not like the older Guest stuff.