VBOX OpenSuse Guest Will No Longer Boot

I have/had a working OpenSuse(13.1) VBOX(4.3.8) guest running in a 32-bit Windows 7 host. It will not longer boot.

I had been cloning it successfully, and using the clone as my working machine and keeping the original as a backup.

Today, I shut down the working machine and made a clone as usual.

Neither the clone nor the working machine would start completely. They showed the exact same symptoms, so it appears the problem occurred in the working machine during shutdown.

A previous clone, from two weeks ago boots up without issues.

The symptoms seem related to the display. During bootup, we eventually see a black/green chameleon desktop, but then the display enlarges and goes black. An “X” cursor appears, and that is it… That is were the bootup process hangs. In a normal bootup process, after the chameleon desktop appears, the next viewable step would be for hardrive icons and others to up near the center of the screen. This does not happen.

I have tried changing the display settings (from two displays to one, and video memory allocation, but that does not help.)

Any idea what is causing this, how to troubleshoot it and how to fix it?


Have you tried booting to Recovery Mode?
If you are able to do that, it would further suggest a display issue related to the installed display driver.
You could then try
Re-installing VBox Guest extensions.
Removing VBox Guest extensions.


Thanks for your suggestion. Under advanced, I do not see “Recovery Mode”. What I do see is a list with 4 entries – all the same: “OpenSUSE 13.1 with Linux 3.11”.

Is there another way to get into recovery mode?

I can get into “Rescue” mode from the CD, but I that does not get me access to the file system, it seems.


Slight progress: I was able to mount the file system in Recovery mode accessed by booting the DVD iso.
(I changed the boot order in Vbox, Settings).

I used these commands to mount the file system:
fdisk -l
mount /dev/sda2 /mnt ← i knew from my notes this was the root partition
mount /dev/sda3 /mnt/ home <— likewise.

At this point I am trying to do some damage control to move some non-backed-up files from
the VM to my host file system.

The guest additions are not working so I am stuck at the moment with that.

I would like some help in diagnosing and fixing the boot problem.


Here is an update for anyone else having similar problems.

I was able to boot my suse guest in text mode. I still have not solved the X display problem.

The guest utils are working, and I was able to mount my shared windows directories.

So now I can at least copy the files I had not yet backed up from the suse guest to the windows 7 host.

Next I need to find out why the X display failed…

For what it is worth, to start the suse guest in text mode, I did this:

  1. As soon as the machine starts booting, type “esc e”.That will get you into the grub loader “mode”.

  2. If you are in the grub loader mode you should see a text box containing a boot script.

Scroll down almost to the bottom of the script, to the line starting “linux /boot/vmlinuz-…”.

Immediately after this kernel name, add “3”, for run level three. It will look something like this “linux /boot/vmlinuz-3.11.10-7-default 3 root=UUID…” you can also remove the words “quiet” and “silent” from the end of the line. “F10” to boot. That should get you to a login prompt it level 3 (text mode).

I still need some help troubleshooting the X-display blackout that occurs right before the KDE icons usually appear.

I wish I could edit my previous post(s), but this forum won’t allow it.

And so, when in text mode (3) (as described above) I am able to execute “sudo startx”,
and the display is working.

What I need now is to figure out why the bootup does not continue past
a blacked-out screen, and yet the display seems to work.

Can anyone help me with that?

Answering various questions (BTW - all your issues appear to be not likely related to Virtualization)

  • The current default openSUSE Grub graphic isn’t wide enough to display the entire line for each kernel entry. IMO is a faulty decision favoring style over functionality. You can fix with the script I created which includes a revised graphic, but will likely be overwritten with every update to Plymouth. So, just keep the package on your system where you can re-run the script as needed. Although my graphic is 12.3, it can be modified in GIMP to display 13.1.
    Hmmmm… Maybe I’ll create a graphic and modify the script so the right graphic is installed for the OS.

When you can’t see the entire Grub entry, a good guess is that every second entry is the Recovery Mode for the kernel immediately preceding.

  • A starting point troubleshooting display issues is to see what is behind the graphic by pressing ESC. You should do this immediately when the graphic first appears, when the system eventually reaches a STOP, the ESC key won’t work. You should note what the last few lines indicate before no longer proceeding.

  • Recommend you clone your existing system and just run your DVD “repair” mode. Or, if you have a command line in the Guest, run a “zypper dup” (assuming you haven’t touched your repositories). Either method will force a re-install of your OS from whatever sources are configured. IMO either should fix any damage in your system if the cause was an improper shutdown. If you suspect the cause might have been some update, then the DVD will return your system to the packages released when openSUSE 13.1 was first released (assume that would be working). Then follow that up with updating (or patching if you want to be very conservative). Since the openSUSE 13.1 VBox Guests I’m running seem to be OK, I doubt it’s a widespread issue caused by something like an update.


Thanks Tsu, I have tried your suggestions and am still stuck.

From the text (level 3) prompt, I successfully ran ‘sudo zypper dup’, and then rebooted. I am now on a different kernel. Rebooting hangs on a black screen – this time without an “X” prompt.

From the text prompt, though, I can still run “sudo startx” and get to a KDE destktop.

If i reboot again, and break into the GNU GRUB menu (by typing “e” right away after a reset), I can modify the "linux /boot/vmlinz… " line by removing “quiet silent” from the end of the line. Then I can see the console messages stream past rather than the graphic.

The last thing I can clearly see on this ‘normal’ reboot is “Started LSB X Display Manager” before the screen blacks out.

I probably should have asked earlier,
Pls post the repos you have configured

zypper lr

It could be why you experienced your problems in the first place and why “zypper dup” didn’t fix your system. Also, “startx” should not have started KDE successfully.


Guest additions copy/paste is not functional when I bring up the KDE desktop using startx.
So I can not copy/paste the output of “zyppr lr”.

So here goes:

Name, Enabled, Refresh
google-chrome, yes, yes
openSuse-13.1-1.10 yes, no
openSuse-13.1-Debug, no, yes
openSuse-13.1-1-Update-Debug, yes, yes
openSuse-13.1-1-Update-Debug-Non_Oss, no, yes
openSuse-13.1-1-Non-Oss, yes, yes
openSuse-13.1-1-Source, No, Yes
openSuse-13.1-1-Update, Yes, Yes
openSuse-13.1-1-Update-Non-Oss, Yes, Yes


Using startx, I have a functioning KDE. While not ideal, I could almost live with this… boot to black screen, enter “ctrl-alt-f1”, enter “startx”.

Unfortunately, however, the copy/paste (bidirectional) guest addition is not working anymore and I can’t get by without that feature. Some guest additions are working though: Mouse control and Shared Folders. I am on the latest version of Vbox (4.3.8).

Any ideas on how to fix copy/paste?

Update for you in case you are also stuck: I got copy/paste to work by noticing a dialog box in the lower right corner of the KDE-Plasma desktop (the chameleon) when it first loads which mentioned something about vbox guest additions. Clicking it led me to a login panel required to mount the guest additions ISO. Entered my root password and now copy/paste works. I was mislead as other supposed 'guest box additions were working already (mouse support/shared folders) – without requiring the ISO mount.

At this point I even with a black screen at boot, I can still use startx to get a fully functional KDE.

I would like to fix whatever is causing the black screen. Any suggestions?

I have spent 3 days on this so far. Only one person has responded with a few sentences during this time… Thank you Tsu.

You should look at /var/log/Xorg.0.log and /var/log/kdm.log to see why KDM (or whatever login manager you’re using) isn’t being launched - most likely it’s a permission/lock/temporary file issue - that’s why you’re getting the X.

And the reason why people don’t reply is because many of the old folks have either left (banned, got tired of some of the aspects of this forum which I won’t delve into - let’s just say the admins here follow the “We are right, if you don’t agree go **** yourself” Modus Operandi) and other issues.

Thanks Miuku – I looked at both logs but found no errors “(EE)” other than this:

(EE) AIGLX error: vboxvideo does not support required DRI extension    
(EE) AIGLX: reverting to software rendering

,which also appears when running “startx” from text mode which gets the KDE-plasma

I am continuing to look at logfiles and permissions.

The copy/paste guest box addition has now stopped working again.

Note on the copy/paste issue: a “normal” boot now gets a black screen with an x prompt. Then ctrl-alt-f1 to gets level 3 text mode prompt. startx then gets a KDE-plasma desktop. On the lower right there is a message about mount Vbox addtions, which I click on. to see a dialog box asking for the root pw, which I enter. Then the guest ISO mounts. At this point copy/paste does NOT work. Screen resize does NOT work. Sigh.

However I do not see these two issues if I boot to level 3 (by editing /boot/grub2.cfg and adding a “3” on the “linuz” line after the kernel name). Then, I do the same as above and copy/paste screen resize works.

At least doing this I can get into a fully functioning KDE with all guest box additions working. It is annoying to have to take extras steps to login. I would like to fix this. But I can’t afford to spend any more time on this. If I eventually find out what is causing this I will update this thread.


I am focusing on the fact that “startx” is not supposed to work. Nowadays, that should result in an error saying it cannot connect to an X server. The command which is supposed to work is “startkde”

That suggests to me that somewhere the KDE install was seriously mangled, as though you might have experimented with another Desktop, maybe a non-default window manager.

Do you have a DVD or image? I’d suggest trying a re-install/repair with it.

Your repo list looks ok although I’d disable them all when you do a DVD repair.


i tried “startx” on an earlier clone that boots to KDE. “startx” works there too, from level 3.

The command which is supposed to work is “startkde”

I tried “startkde” from the earlier clone: “$DISPLAY is not set or cannot connect to the X server”.

Do you have a DVD or image? I’d suggest trying a re-install/repair with it.

i do. I will try to find the ‘repair’ again. It seemed a few days ago when I looked at doing that from the CD that there was no ‘repair’, just an install. Maybe I didn’t go far enough with it to see a ‘repair’ option if I continued doing an install… I was also looking for a way to reinstall just KDE using Yast but encountered massive dependency errors when attempting to select the ‘pattern’. Thanks -steve

You can not “repair” from any you may do an upgrade ie version 13.1->13.1 and it should keep programs and configs. It is functionally equivalent to zypper dup. This is NOT supported from any of the live DVD images you must use the full install image

You have a serious configuration problem since startx should not work for a user out of the box.

If you do a zypoer dup you may need to reinstall the VM’s helper programs to deal with video audio and such…


Thanks. I will try this though I already tried zypper dup.

This is NOT supported from any of the live DVD images you must use the full install image

I will use the full DVD ISO, if that is what you mean.

You have a serious configuration problem since startx should not work for a user out of the box.

Startx does not work out-of-the-box for a non-root user. On an “ancestor” clone without configuration issues, to get startx to work as a non-root user from text-mode level 3, this worked and would work on any generic 13.1 system, I would guess.

 chmod 4711 /usr/bin/Xorg 

Thanks for your help. -steve

Yes that will work put you have just changed a default permission. You doing this any place else? It really is not recommended and may have side effects