Vasco DP905v1.1 kaartlezer

Mijn kaartlezer Vasco DP905v1.1 wordt door mijn PC (OpenSUSE 13.2) herkend.
Voor installatie de betreffende openSuse “RPM” file van fedict site geplukt en geïnstalleerd echter zonder succes. (Ongekende Key)
Dan maar de “Tar” file geplukt en geïnstalleerd echter ook zonder succes vermits er bepaalde files in het systeem ontbraken.
Alle hulp wordt in dank aanvaard of moet ik terug naar KUBUNTU?.

Lastig om iets over te zeggen, je info is daarvoor veel te summier. Waar gaat die “Ongekende sleutel” bijv. over? Wat we willen zien, zijn exacte meldingen, liefst van het systeem zelf, en dan tussen CODE tags.

Toevoegend: lastig hieraan is ook dat in Nederland die kaartlezers amper gebruikt worden in combinatie met PC/laptop, men heeft hier voor andere, zelfstandige authenticatie apparatuur gekozen. Maar, wat onder Kubuntu werkt hoort onder openSUSE ook gewoon te werken. Geloof vooral niets van de babbels dat iets op de ene distro wel zou kunnen werken en op de andere niet. Onder de motorkap hebben ze allemaal de linux kernel, en KDE wordt gemaakt door KDE, niet door Kubuntu of openSUSE, die verpakken alleen maar. Ik denk dat je 't moet zoeken in meldingen over missende files. Wat zou betekenen dat de rpm niet goed gemaakt is, anders zouden die files via afhankelijkheden ook geïnstalleerd moeten worden.

Dank voor het snelle antwoord. Als ik de Suse RPM file van de fedict site probeer te plukken krijg ik als antwoord: “Your current backend goes not support installung files”. Een tweede maal op ‘enter’ geef (na heel lang wachten) de melding dat de file geïnstalleerd is. Dan de nodige Eid files geïnstalleerd. Resultaat? Noppens. In Mageia werkt de kaartlezer prima. Daar steken de nodige files (Eid) in de Mageia repositories

Ah, er begint me een lichtje te branden. Bedoel je dit: http://software.opensuse.org/package/eid-mw ?

Daarmee is het probleem niet opgelost. De RPM is niet door OpenSuse goedgekeurd.

Wat bedoel je daarmee? Dat de repo een home:… is?
Dat klopt op zich wel, maar er is hier iets anders aan de hand. Vergelijkbaar met de pakketten voor de nederlandse belastingaangifte software die Richard Bos maakt. Die komen nooit in de officiele repos omdat ze veel te gebiedsspecifiek zijn en niet algemeen getest kunnen worden. Wat dit soort pakketten doen, is zorgen dat de bestanden, mappen, certificaten en wat dies meer zij onder openSUSE op de juiste plekken terecht komen. Dat zijn in de regel dezelfde bestanden als die die jij gedownload hebt.
En dan nog iets: als 't niet werkt, kun je het pakket eenvoudig deïnstalleren. Voor ellende hoef je niet bang te zijn, de eerste versies zijn gemaakt door Pascal Bleser, voormalig openSUSE opperhoofd.

Moet ik daaruit afleiden dat ik een kruis moet maken over het gebruik Van OpenSuse? Spijtig want deze distro beviel mij zeer.

Mijn kaartlezer Vasco DP905v1.1 wordt door mijn PC (OpenSUSE 13.2) herkend.
Voor installatie de betreffende openSuse “RPM” file van fedict site geplukt en geïnstalleerd echter zonder succes. (Ongekende Key)
Dan maar de “Tar” file geplukt en geïnstalleerd echter ook zonder succes.

Het resultaat van de “Tar” file geplukt van fedict site

Uitplooien: Tar -xzvf eid-mw.tar.gz (TGZ, 4.13 MB) gelukt en geeft: eid-mw-4.0.6 folder
pcsc-lite geïnstalleerd en installatie gtk2 = ok

“./configure” in eid-mw-4.0.6 folder loopt prima tot:




checking user-specified GTK installation… no
checking for GTK… no
no
configure: error: you must have GTK+ 2.10.0 or newer development headers
installed.
configure: error: ./configure failed for dialogs
linux-2wkl:/home/leo/Downloads/eid-mw-4.0.6 #

Yast2 (zoeken) geeft voor GTK+ het volgende:

[Keep] at-spi2-atk-common | Assistive Technology Service Provider… | 2.14.1-1.1 | 425 B
[Keep] at-spi2-atk-gtk2 | Assistive Technology Service Provider… | 2.14.1-1.1 | 33.2 KiB
[Keep] gtk2-branding-SLED | The GTK+ toolkit library (version 2) … | 13.2-4.3 | 2.0 KiB
[Keep] gtk2-data | The GTK+ toolkit library (version 2) … | 2.24.25-4.4.1 | 3.9 KiB
[Keep] gtk2-immodule-amharic | The GTK+ toolkit library (version 2) … | 2.24.25-4.4.1 | 18.4 KiB
[Keep] gtk2-immodule-inuktitut | The GTK+ toolkit library (version 2) … | 2.24.25-4.4.1 | 7.4 KiB
[Keep] gtk2-immodule-thai | The GTK+ toolkit library (version 2) … | 2.24.25-4.4.1 | 13.4 KiB
[Keep] gtk2-immodule-vietnamese | The GTK+ toolkit library (version 2) … | 2.24.25-4.4.1 | 7.3 KiB
[Keep] gtk2-metatheme-adwaita | Adwaita GNOME Theme – GTK+ 2 Support | 3.14.0-1.1 | 180.4 KiB
[Keep] gtk2-theming-engine-adwaita | Adwaita GTK+ Theming Engine | 3.14.0-1.1 | 9.5 KiB
[Keep] gtk2-tools | The GTK+ toolkit library (version 2) … | 2.24.25-4.4.1 | 37.8 KiB
[Keep] gtk3-branding-SLED | The GTK+ toolkit library (version 3) … | 13.2-3.1 | 2.0 KiB
[Keep] gtk3-data | The GTK+ toolkit library (version 3) … | 3.14.4-4.1 | 10.4 KiB
[Keep] gtk3-immodule-amharic | The GTK+ toolkit library (version 3) … | 3.14.4-4.1 | 18.4 KiB
[Keep] gtk3-immodule-inuktitut | The GTK+ toolkit library (version 3) … | 3.14.4-4.1 | 7.4 KiB
[Keep] gtk3-immodule-thai | The GTK+ toolkit library (version 3) … | 3.14.4-4.1 | 13.4 KiB
[Keep] gtk3-immodule-vietnamese | The GTK+ toolkit library (version 3) … | 3.14.4-4.1 | 7.3 KiB
[Keep] gtk3-metatheme-adwaita | Adwaita GNOME Theme – GTK+ 3 Support | 3.14.0-1.1 | 68 B
[Keep] gtk3-tools | The GTK+ toolkit library (version 3) … | 3.14.4-4.1 | 228.6 KiB
[Keep] libcanberra-gtk-module-common | Portable sound event library – Commo… | 0.30-8.1.4 | 369 B
[Keep] libcanberra-gtk0 | Portable sound event library – GTK+ … | 0.30-8.1.4 | 17.6 KiB
[Keep] libcanberra-gtk2-module | Portable sound event library – GTK+ … | 0.30-8.1.4 | 21.7 KiB
[Keep] libcanberra-gtk3-0 | Portable sound event library – GTK+ … | 0.30-8.1.4 | 17.6 KiB
[Keep] libcanberra-gtk3-module | Portable sound event library – GTK+ … | 0.30-8.1.4 | 21.7 KiB
[Keep] libgtk-2_0-0 | The GTK+ toolkit library (version 2) | 2.24.25-4.4.1 | 7.7 MiB
[Keep] libgtk-3-0 | The GTK+ toolkit library (version 3) | 3.14.4-4.1 | 8.3 MiB
[Keep] libjavascriptcoregtk-1_0-0 | JavaScript Core Engine, GTK+ Port | 2.4.6-1.4 | 6.9 MiB
[Keep] libjavascriptcoregtk-3_0-0 | JavaScript Core Engine, GTK+ Port | 2.4.6-1.4 | 6.9 MiB
[Keep] libwebkitgtk-1_0-0 | Library for rendering web content, GT… | 2.4.6-1.4 | 28.6 MiB
[Keep] libwebkitgtk-3_0-0 | Library for rendering web content, GT… | 2.4.6-1.4 | 28.6 MiB
[Keep] python-gtk | Python bindings for the GTK+ widget set | 2.24.0-14.1.4 | 3.2 MiB
[Keep] typelib-1_0-Gtk-3_0 | The GTK+ toolkit library (version 3) … | 3.14.4-4.1 | 851.9 KiB
[Do Not Install] almanah | GTK+ application to allow you to keep… | (0.11.1-1.6) | 552.5 KiB
[Do Not Install] avahi-utils-gtk | GTK+ Utilities for D-BUS Service for … | (0.6.31-23.1.4) | 28.4 KiB
[Do Not Install] *************************



Ik hoop hiermee mijn probleem te verduidelijken?
Zou het kunnen zijn dat de nodige GTK+ files op een andere plaats dan verwacht geïnstalleerd zijn?

Waarom ga je nou toch die tarball compileren. De one-click-install hierboven zou jou probleem op moeten lossen, en ik zie niet dat je die geïnstalleerd hebt. In de spec file van de rpm zie ik dat de sources komen van http://eid.belgium.be/en/using_your_eid/installing_the_eid_software/linux/ . Ik geloof dat er in de engelstalige forums wel posts zijn waarmee dit werkend gekregen werd.

En, niemand zegt dat je openSUSE móet gebruiken, je praat hier ook niet tegen de ontwikkelaars, maar tegen mensen die proberen je te helpen.

Waarom makkelijk doen als het ook moeilijk kan :wink:

ik denk dat @Deken wordt afgeschrikt door de melding die men krijgt als je probeert software te installeren dat niet door openSUSE wordt gecontroleerd.
@Deken er zijn natuurlijk heel veel programma’s die geen onderdeel zijn van de “orginele” openSUSE installatie.
Dat betekend niet dat ze niet geschikt zijn, ze zijn alleen niet getest door openSUSE
Je kunt het beste de “one-click” gebruiken die Knurpht voorstelde

@deken:
Ik heb nog 's even gekeken op deze http://eid.belgium.be/nl/je_eid_gebruiken/de_eid-middleware_installeren/linux/ site. De grap is dat het pakket waar ik naar verwijs precies waar jij naar zoekt, d.w.z. wat jij nu zelf probeert te compileren ( lukt niet omdat je de ontwikkel-versies, …-devel, niet geïnstalleerd hebt), heeft iemand anders al gecompileerd en wel verpakt in een rpm. Dat zou jou de ellende van moeten compileren, en daarvoor eerst een hele ontwikkelomgeving te moeten installeren.

Daar de RPM file, geplukt van fedict, niet werkt heb ik geprobeerd de tarball, ook geplukt van fedict, te compileren. Echter zonder succes.
Grasduinend op de anderstalige fora heb ik gevonden dat deze bug(?) aan openSuse reeds gemeld is in 2012. Een oplossing heb ik daar echter nog niet gevonden.


Lees je de reacties hier ook ? Je laat in ieder geval nergens zien of weten wat je ermee gedaan hebt. Ik heb je al laten weten dat wat jij nu zelf probeert te compileren, door belgische gebruiker “koenraad” al gecompileerd is en netjes in een rpm verpakt, die jij kunt installeren om je bankzaken werkend te krijgen. De informate die je zelf aanlevert is uiterst summier, zonder verwijzingen. Van mij mag je 't allemaal anders doen, maar dan begrijp ik de reden om hier te posten niet. Ik van mijn kant ga geen hele lapppen instructies schrijven over missende -devel pakketten etc. als de oplossing kant en klaar in de repos staat. Sterkte ermee

Lees deze hele draadje nog eens rustig na…

Je kent het fenomeen "One-Click) van openSUSE?

Dit is de reactie als ik de “One-Click van openSuse” toepas.

**"The following package has bad signature:
/home/leo/Downloads/eid-mw-4.0.4+1253-3.1.i586.rpm: Invalid signature (NOT OK (no key): /home/leo/Downloads/eid-mw-4.0.4+1253-3.1.i586.rpm: Header V3 DSA/SHA1 Signature, key ID 2edd9cd4: NOKEY)

Do you want to continue installation ?"
**
Als ik ‘yes’ antwoord verloopt de installatie normaal en sluit af met de melding dat de installatie succesvol verlopen is.
De kaartlezer blijft echter zo dood als een pier.

Knurpht, Ik heb het ganse verhaal hier meerdere malen helemaal gelezen. Heb jij dat ook gedaan?

Jazeker. En, hoewel ik 't altijd liever voorkom om dingen zelf te moeten compileren, ook daar kunnen we nog wel 't naar kijken.

configure: error: you must have GTK+ 2.10.0 or newer development headers 

dat betekent dat het pakket gtk2-devel geïnstalleerd moet zijn. Kun je dat doen, daarna ./configure weer uitvoeren. Het kan heel goed zijn, dat er een volgende foutmelding komt waar configure op stuk loopt, maar ook die zal weer wijzen op een ontbrekend …-devel pakket. Compileren kun je pas als ./configure zelf meldt dat alles goed verlopen is. Post de output evt. hier als je bepaalde pakketten niet kunt vinden.

Het grootste probleem voor mij, en voor de meesten hier, blijft dat ik niets anders kan doen dan reageren op jouw in- en output.

Heb uw voorstel, wel met enige vertraging, gevolgd en het resultaat is een perfect verloop van ./configure, make en make install zonder ook maar een foutje. Kaartlezer aansluiten geeft geen resultaat. Bij het opstarten van de pc licht het groene lichtje van de kaartlezer voor ongeveer 6 seconden op en gaat dan uit nog voor het einde van de opstart cyclus. Resultaat geen kaartlezer.
Het volledig verloop van de installatie zou ik u kunnen doorsturen maar ik weet niet hoe ik dat moet doen.

Kun je 's de kaartlezer loskoppelen, dan weer aansluiten, meteen een terminal openen, en dan de output van onderstaande posten?

dmesg -T | tail -30

Hier het resultaat.
22.119635] NET: Registered protocol family 17
22.429163] No iBFT detected.
22.499498] skge 0000:02:09.0 enp2s9: enabling interface
22.503019] IPv6: ADDRCONF(NETDEV_UP): enp2s9: link is not ready
25.562716] skge 0000:02:09.0 enp2s9: Link is up at 100 Mbps, full duplex, flow control both
25.562812] IPv6: ADDRCONF(NETDEV_CHANGE): enp2s9: link becomes ready
45.850987] SFW2-INext-DROP-DEFLT IN=enp2s9 OUT= MAC= SRC=fe80:0000:0000:0000:020d:61ff:fe9c:63a5 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44
48.487044] Bluetooth: Core ver 2.19
48.487081] NET: Registered protocol family 31
48.487084] Bluetooth: HCI device and connection manager initialized
48.487096] Bluetooth: HCI socket layer initialized
48.487101] Bluetooth: L2CAP socket layer initialized
48.487118] Bluetooth: SCO socket layer initialized
48.507677] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
48.507683] Bluetooth: BNEP filters: protocol multicast
48.507695] Bluetooth: BNEP socket layer initialized
53.635493] SFW2-INext-DROP-DEFLT IN=enp2s9 OUT= MAC= SRC=fe80:0000:0000:0000:020d:61ff:fe9c:63a5 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44
58.270569] fuse init (API version 7.23)
69.638667] SFW2-INext-DROP-DEFLT IN=enp2s9 OUT= MAC= SRC=fe80:0000:0000:0000:020d:61ff:fe9c:63a5 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44
101.661625] SFW2-INext-DROP-DEFLT IN=enp2s9 OUT= MAC= SRC=fe80:0000:0000:0000:020d:61ff:fe9c:63a5 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44
165.682847] SFW2-INext-DROP-DEFLT IN=enp2s9 OUT= MAC= SRC=fe80:0000:0000:0000:020d:61ff:fe9c:63a5 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44
293.696641] SFW2-INext-DROP-DEFLT IN=enp2s9 OUT= MAC= SRC=fe80:0000:0000:0000:020d:61ff:fe9c:63a5 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44
** 479.304151] usb 2-1: USB disconnect, device number 2
479.311388] pcscd[1951]: segfault at b779a172 ip b779a172 sp b708c260 error 4
499.344041] usb 2-1: new full-speed USB device number 3 using uhci_hcd
499.541982] usb 2-1: New USB device found, idVendor=1a44, idProduct=0001
499.541989] usb 2-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
499.541993] usb 2-1: Product: DP905v1.1
499.541996] usb 2-1: Manufacturer: VASCO**
549.701373] SFW2-INext-DROP-DEFLT IN=enp2s9 OUT= MAC= SRC=fe80:0000:0000:0000:020d:61ff:fe9c:63a5 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44

Ter info, het groene lampje op de kaartlezer gaat even aan en dan weer uit.