Vanish FF Plugin doesn't work..

I found this rather neat bit here Vanish: Enhancing the Privacy of the Web with Self-Destructing Data now having installed it on another distro I can’t get it to work on Suse.

Now just being java based it shouldn’t matter what the distro is. Now specifically I get this error Vanish FAQ I know it isn’t the first 1 as one I’ve dropped the firewall and I don’t have any latencies to cause this, then it also happens immediately. So that leads to 2 I can’t get the daemon to start at all, what I have noticed is that daemons user is created wrong it has the wrong groups and the group isn’t created. I’ve tried manually setting/adding the correct group but it makes no difference.

So does any one have any idea what I have to do to get it to work on Suse?

OK this is still annoying me anyone want to tell me the why?

I’m out of ideas I’ve matched java, FF nothing is helping is this the golden cage syndrome?

java is java regardless of OS… well should be.

NM solved it for some reason using the init.d/rc.d system doesn’t work but by backgrounding the *.sh files it works fine.