V12.3 64, How do you play an MP3 file?

OpenSuse V12.3 64

What program can play an MP3 file?

Is it necessary to compile downloaded source to build a library?

Many! :wink:
And no, you don’t need to compile anything.

Just install gstreamer-fluendo-mp3 (and gstreamer-0_10-fluendo-mp3) using YaST->Software Management, and you should be able to play mp3 files by just clicking on them.

If you want to be able to view/play more multimedia formats like mpeg or avi, please have a look here:
Restricted formats - openSUSE Community Wiki

Restricted format guide
https://forums.opensuse.org/blogs/caf4926/opensuse-12-3-multi-media-restricted-format-installation-guide-126/

I use rhythmbox, also you can use VLC media player, just try “Package search” on openSUSE download page.
Regards

rih,

Definitely use the link placed there by vazhavandan. It’ll save you much trouble in the future & you’ll be able to play any format once you’ve done that.

Which option?


Problem: ffmpeg-1.0.6-1.1.x86_64 requires libpostproc52 = 1.0.6, but this requirement cannot be provided
Problem: vlc-codecs-2.0.6-115.3.x86_64 requires libavformat.so.54()(64bit), but this requirement cannot be provided
Problem: x264-0.129svn20130224-3.1.x86_64 requires libavformat.so.54()(64bit), but this requirement cannot be provided
Problem: gstreamer-plugins-bad-orig-addon-1.0.6-3.5.x86_64 requires gstreamer-plugins-bad >= 1.0.6, but this requirement cannot be provided
Problem: gstreamer-plugins-good-extra-1.0.6-2.5.x86_64 requires gstreamer-plugins-good = 1.0.6, but this requirement cannot be provided
Problem: libxine2-codecs-1.2.2-83.2.x86_64 requires libavcodec.so.54()(64bit), but this requirement cannot be provided
Problem: gstreamer-0_10-plugins-bad-orig-addon-0.10.23-19.23.x86_64 requires libmpeg2encpp-2.0.so.0()(64bit), but this requirement cannot be provided

Problem: ffmpeg-1.0.6-1.1.x86_64 requires libpostproc52 = 1.0.6, but this requirement cannot be provided
  uninstallable providers: libpostproc52-1.0.6-1.1.i586[Packman Repository]
                   libpostproc52-1.0.6-1.1.x86_64[Packman Repository]
                   libpostproc52-1.0.6-1.1.i586[packman]
                   libpostproc52-1.0.6-1.1.x86_64[packman]
 Solution 1: downgrade of libpostproc52-1.1-2.2.x86_64 to libpostproc52-1.0.6-1.1.x86_64
 Solution 2: do not install ffmpeg-1.0.6-1.1.x86_64
 Solution 3: do not install ffmpeg-1.0.6-1.1.x86_64
 Solution 4: break ffmpeg-1.0.6-1.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/3/4/s/r/c] (c): 


I am not seeing “libpostproc52-1.1-2.2.x86_64” anywhere in my repos. You should maybe re-evaluate which repos you have.

Given those choices, I would probably go with 1. But a review of your configured repos might be more appropriate.

Had you placed your question in the correct forum category (Multimedia) you would (probably) have noticed that the very first sticky would answer your question.

libpostproc52-1.1 (ffmpeg-1.1 to be exact) was part of Packman for a while (in January I think). But then they dropped it and downgraded to 1.0.1, because it caused VLC and others to not be able to play wma files anymore…

Given those choices, I would probably go with 1.

Yes, I would also strongly recommend to choose solution 1.

Okay, I selected 1 every time as recommended, I’m all set (JOY) thank you.
In the past, I’ve really messed up a machine hesitant to mess with