V12.2 Flash?

Towards the end of using V11.4, a flash upgrade stopped utube videos from playing.
At the time, the solution was to roll back the version of flash, if I remember correctly, from 11. to 10.

I recently fresh installed from V11.4 to V12.2, and the same thing has happened, but I can’t roll back flash to 10. because it’s not there for V12.2

The machine is V12,2 Mantis (32-bit), Kernel Linux 3.4.6-2.10-default, GNOME 3.4.2, 1003.7 MiB, AMD Athlon™ XP 2800+

My smolt lists NV 31 [GeForce FX 5600],

rpm -qa | grep flash

What do I do?

Thank you.

I find I am able to play YouTube videos just fine. I have the following java packages installed:

java-1_7_0-openjdk- -> openSUSE
java-ca-certificates-1-19.1.1-noarch -> openSUSE

I have an nVIDIA 560 installed and use the open source driver. So, I suggest your multimedia might not be configured properly. I suggest you visit or revisit the following article on the subject here:


You can use the following bash script to confirm your multimedia is setup properly:

MMCHECK - Version 2.45 - Check Your Multimedia in 16 Steps - Bash Script File - Blogs - openSUSE Forums

Please check out these posts and get back with your results.

Thank You,

I might be stating the obvious, but have you tried using a different browser for Flash? I’ve had some tweaky full screen playback from Youtube on Chrome, but it’s fine on Firefox.

On 11/17/2012 11:16 PM, rih5342 wrote:
> What do I do?

-go to a flash video site

-right click on the spot where the video should play

-select “Settings”

-in the just opened Adobe setting dialog, uncheck the box next to
“Enable hardware acceleration”

-report success or failure back to this thread…

and, if still having problems, tell us what video driver you are using,
and how you installed it…

dd http://tinyurl.com/DD-Caveat

Still no joy.

I did everything listed here


and here


followed by mmcheck

  1. all packages updated
  2. 12 repositories

| Alias | Name | Enabled | Refresh

1 | Packman Repository | Packman Repository | Yes | Yes
2 | libdvdcss | libdvdcss | Yes | Yes
3 | packman | Packman repository (openSUSE_12.2) | Yes | No
4 | repo-debug | openSUSE-12.2-Debug | No | Yes
5 | repo-debug-update | openSUSE-12.2-Update-Debug | No | Yes
6 | repo-debug-update-non-oss | openSUSE-12.2-Update-Debug-Non-Oss | No | Yes
7 | repo-non-oss | openSUSE-12.2-Non-Oss | Yes | Yes
8 | repo-oss | openSUSE-12.2-Oss | Yes | Yes
9 | repo-source | openSUSE-12.2-Source | No | Yes
10 | repo-update | openSUSE-12.2-Update | Yes | Yes
11 | repo-update-non-oss | openSUSE-12.2-Update-Non-Oss | Yes | Yes
12 | security:netfilter | security:netfilter | Yes | Yes

  1. libdvdcss2 -> VideoLAN Project (VideoLAN - VLC: Official site - Free multimedia solutions for all OS!) is installed

  2. looks okay

  3. looks okay

  4. only 2 out of 3 mplayer files installed, can’t find a third to install

  5. looks okay

  6. looks okay

  7. looks okay
    10 looks okay
    11 looks okay
    12 looks okay
    13 looks okay
    14, 3 java files installed
    15, is a little confusing, there’s a green background area, then a black background are with this

    5 – MD5 checksum
    S – File size
    L – Symbolic link
    T – File modification time
    D – Device
    U – User
    G – Group
    M – Mode (includes permissions and file type)
    ? – Unreadable file

16 output is the same as 15

And last, within Firefox/ edit/ preferences/ use hardware acceleration when browing is UNSELECTED.

In youtube, the press to play triangle doesn’t appear.

What now?

Why not show us your plugsins in Firefox?


I posted my screen capture at: SUSE Paste, so lets see how yours is different.

Thank You,

As in Firefox new tab, with URL about:plugins ?


In Firefox, its Tools / Add-ons / Plugins then a Print Screen, send to a Graphic app and save it as a png file. Then in suse paste, you can select image and upload the png file there and copy the download URL and post it here. I am trying to determine if you have installed Totem who is the main program you use online to view videos. As you look at my post, you will see that most video things are handled by Totem and I disable mplayer or anything else in Firefox that try’s to over take Totem. In my case Totem handles Quicktime, VLC & Windows Media Files. I can see you have the right version of Totem mentioned, but the add-on display is clearer on what is going on. And in particular, for these three files groups, nothing else (Like mplayer or VLC) should be playing these type files, only Totem. On more than one occasion, I have had to disable a plugin that was not working with online videos not belonging to Totem.

Thank You,

==>Can you disable all firefox addons and check whether it is a addon issue?
==>Can you backup profile. Delete old profile and allow firefox to create a new profile and check whether it is a profile issue ?

My flash packages on GNOME 3.4.2

$:~>  rpm -qa | grep flash

Youtube works for me

you may try getting rpm from here and install it

As requested,

the output from ==> Firefox ools\add-ons

DivX Webplayer version

Gnome shell integration

IcedTea-Web Plugin (using IcedTea-Web 1.3.1 ( suse 1.9.1-i386))


QuickTime Plug-in 7.6.6

Shockwave Flash 11.2 r202

VLC Multimedia Plugin (compatible Totem 3.4.3)

Windows Media Player Plug-in 10 (compatible; Totem)

When I go to the adobe website to check the version of flash, Firefox doesn’t display my version, even though it is installed.
I tried reinstalling adobe flash player, but no joy.

When I go to firefox/tools/addons/get-add-ons learn more, a cartoon movie plays just fine.

What next?

My Quicktime also shows Totem as the provider. Is that true for your add-ons? Can you give us a link to a video that everyone is allowed to view that is not working and something that does work for you, if any.

Thank You,

Quicktime Plug-in 7.6.6
The Totem 3.4.3 Plugin handles video and audio streams

This plays ==> Mike Chang’s Six Pack Shortcuts - YouTube
and apparently does not need flash.

This does not play ==> Star Trek Into Darkness - Official Teaser (HD) - YouTube
and apparently needs flash.

Thank you.

So both play for me and the one you say works seems to come up as HTML5 for me and the other is using Flash. If I open up a terminal session and run this command to see what for flash is loaded, here is what I get:

rpm --query --all --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} -> %{VENDOR}
' '*flash*'

flash-player-gnome- -> openSUSE
flash-player-kde4- -> openSUSE
flash-player- -> openSUSE
pullin-flash-player-12.1-6.5.1-x86_64 -> openSUSE

Forgive me if I have asked for this before, but it looks to be the issue is flash for you so help refresh my memory of what you have installed. To determine what video card you have installed, lets see this in terminal:

/sbin/lspci -v | grep "VGA"

01:00.0 VGA compatible controller: NVIDIA Corporation GF114 [GeForce GTX 560] (rev a1) (prog-if 00 [VGA controller])

You can also run this program to determine your 3D support speed:


This was my best time (5126 frames in 5.0 seconds = 1025.134 FPS) as the gears in the window turns and I had all sorts of things open at the time which would slow you down. Let me see these requests and then we will continue to go forth.

Thank You,

Thank You,

Here you go…

rpm --query --all --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} → %{VENDOR}
’ ‘flash
flash-player- → openSUSE
pullin-flash-player-12.1-6.5.1-i586 → openSUSE
flash-player-gnome- → openSUSE

/sbin/lspci -v | grep “VGA”
03:00.0 VGA compatible controller: NVIDIA Corporation NV31 [GeForce FX 5600] (rev a1) (prog-if 00 [VGA controller])

nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 30
nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 30
nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 55
nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 56
nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 59
nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 58
nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP 30
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
1900 frames in 5.0 seconds = 379.946 FPS
2215 frames in 5.0 seconds = 442.951 FPS
2212 frames in 5.0 seconds = 441.906 FPS
2216 frames in 5.0 seconds = 443.129 FPS
2226 frames in 5.0 seconds = 444.928 FPS
2208 frames in 5.0 seconds = 441.566 FPS
2253 frames in 5.0 seconds = 450.141 FPS

Thank you.

So the issues I see from the list is:

  1. You do not have: flash-player-kde4- installed.
  2. Your video card, a FX 5600 is too old to use the latest video driver. For the proprietary one, you must use version[size=2] 173.14.36 and for 64 bit use this: NVIDIA - Download Drivers
  3. [/size]The error message of “nvfx_screen_get_param:95 - Warning: unknown PIPE_CAP” is considered an incompatibility on some level with the default open source driver nouveau.

So, what can you do? Well, I think its some kind of issue with the nouveau driver and your video card. You could try loading the flash-player-kde file first. You could consider loading the proprietary video driver:

Installing the nVIDIA Video Driver the Hard Way: https://forums.opensuse.org/blogs/jdmcdaniel3/installing-nvidia-video-driver-hard-way-29/


LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.46: https://forums.opensuse.org/blogs/jdmcdaniel3/lnvhw-load-nvidia-driver-hard-way-runlevel-3-version-1-10-32/

Be for warned that reverting back to the open source nouveau driver may be hard to do and require a reinstall. And of course, it might be time to consider buying a new video card, if this is a desktop. New cards can be as little as $50, but they require a PCIe slot and most can not be found for the AGP bus and none of this make any difference if you have a laptop computer.

But in the end, it looks like a video issue to me that seems to only effect the Flash player. I see people all of the time suggest you disable hardware acceleration in flash (Adobe Community: How do I disable or enable hardware acceleration?).

Thank You,

Yah, I’m running some old stuff, probably time to retire it.

Thanks for your impressive effort!

So you are very welcome for the help. I am just sorry we could not find a simple fix. But hey, I got to see the Movie Trailer for the Next Start Trek (INTO Darkness) movie set for a May 17 release of 2013. If we can assume we make it past the Maya calender end (was that 12-12-12 or 12-21-12?), I am going to see that movie when it comes out next year and thanks for giving me the right link to see it.

Thank You,