v11.1, desktop effects / window picker is unstable

After installing 11.1 from DVD, I installed via the 1-click installer the NVIDIA driver, and then I was able to enable desktop effects. All seems fine, except one thing:

By default going to the upper right corner of the screen kicks in the window picker (set on by default in the Edges tab in desktop effects) which 70% of the time displays the available windows and lets you select one, but 30% of the time it displays the windows but then freezes the desktop and nothing sort of ssh-ing to the box from another machine and killing the X server has worked.

I am running with an eVGA NVIDIA GeForce 8600GT. I have disabled this ‘Edge’ action for now. Everything else works great. :wink:

If you have an NVIDIA card, can you please enable desktop effects and see if putting your mouse off the right top of the desktop lets you reliably use the window picker.


Desperate times call for desperate measures.

I re-installed my NVIDIA driver then re-installed Compiz Fusion from Compiz Fusion - openSUSE.

Now everything seems to be stable. So if anyone stumbles on this thread with compiz problems, you can at least try the above - worked for me.

After doing the above, the compiz icon on the panel was broken. So I followed the advice at Compiz Troubleshooting - openSUSE but only partially.

I uninstalled everything related to compiz, and then reinstalled all the compiz packages, from the base 11.1 repository instead of the one click installer (almost same thing?)

The icon now works, and compiz works as well. I don’t understand why the DVD install has a flaky compiz but reinstalling fixes it. Weird, but now compiz works smoothly like a baby’s bottom :slight_smile:

I’m having this same issue, although it’s on a laptop with an ATI Radeon Express “card”. Admittedly, I’m a newbie, could you point to some step by step instructions on how to do this?