UVCVideo ?Corruption? Problems...

I am running Suse 11.0 on my eee pc, I would run 11.1 but it is unstable and has HORRIBLE Hardware support…

uvcvideo-kmp-default didn’t work from the SUSE repos so to get the latest version I installed it myself…

I compiled uvcvideo from source, installed with checkinstall not make, and it worked fine. An automated installer decided that I did not have uvcvideo installed because my package was listed as uvcvideo instead of uvcvideo-kmp-default. So it installed uvcvideo from the suse repos without my knowledge (I found out when I checked later on) This caused two uvcvideos to be installed on my system… I removed the custom compiled app because it didn’t fix the problems I was originally having, know uvcvideo won’t load and SUSE claims it is installed in two different places…

zypper se uvc
luvcview installed
uvcvideo installed (srcpackage)
uvcvideo-kmp-bigsmp installed (Don’t recall installing this)
uvcvideo-kmp-default installed

(uvcvideo and uvcvideo-kmp-default are the same packages)

dmesg reports:
uvcvideo: disagrees about version of symbol…
uvcvideo: Unknown symbol…


v4l_compat_translate_ioctl
video_devdata
video_unregister_device
video_device_alloc
video_register_device
video_usercopy
video_device_release

(sorry I wrote this on my desktop, it gives the top two complaints for each library…)

How should I go about fixing this

rpm -qa doesn’t list uvcvideo…
I have tried removing and reinstalling uvcvideo-kmp-default

Thanks for the help, John

EDIT:

I just thought I’d add this…

When it was working only luvcview -w would give the webcam’s output… (-w disables SDL)

any other app will just give a blank blue screen, including luvcview (WITHOUT -w)

I recompiled it from source and copied uvcvideo.ko into the modules directory of my kernel where the previous one is and now it works, I still get a blue screen though any ideas… if I type luvcview -w it works but luvcview is the only app I can get my camera to work with.