ut2003 for linux not working

I have just installed ut2003 for linux and i am getting the following error from the konsole

"…
[19] ./ut2003-bin [0x805520e]
[20] ./ut2003-bin(main+0x296e) [0x805820e]
[21] /lib/libc.so.6(__libc_start_main+0xe5) [0xb72ce5f5]
[22] ./ut2003-bin(GetFullName__C7UObjectPw+0x7d) [0x80512d1]
Signal: SIGIOT [iot trap]
Aborting.
ut2003-bin: xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req) - (dpy->request)) >= 0)’ failed.
dexter:/home/andromeda # "

I have the proprietary ati drivers installed with an Ati 9550 installed. Does anyone got any idea on what the problem might be?. Other linux games like gl-117 work fine, and the fgl_glxgears test gives me at the very least 400 fps.

Have you applied all the updates to UT2003?
Have you installed any custom mods or maps?

Personally, I have only tried UT2004 under linux on a NV6200 512mb card - worked first time (albeit with some weird artifacts etc).

it’s the latest demo version actually.i’ve had this one before and it worked ok under suse 10.3 with the standard radeon driver. Now i am using the ati proprietary driver. I think it’s something related to that…but i don’t know what…

i’m downloading the full version from mininova now. hope that will do…

i’ll pretend i didn’t read the mininova comment :wink:
oh well, good luck although it does sound like the only difference between then and now is the driver.

would be worth trying with the other driver if you can’t get the full version to work :slight_smile:

good luck and happy fragging!

i can’t. in suse 11 the radeon driver shipped with it is broken and doesn’t work… Appreciate your help anyway.

oh noes, thats a bummer :confused:
so how come you’re playing 2k3 anyways?
have you played 2k4?
or even ut3?

i must say i’ve not played 2k4 for ages and still waiting for a linux client of ut3 …

Tried the loki installer ? that’s what i use loki installers for linux gamers works a treat

Andy

Yup i’ve played 2k4. I have the cd images but they’re in nrg format, and i’m too lasy to burn them :P. The same with ut2k3. deltaflyer, would installing the game via loki change anything?

Dunno about nrg files,i use the bought discs & use loki installers to install. works first time every time for me. Sound,graphics,action all run smoothly

Andy

There’s this one great tool in the repos called “AcetoneISO2” and it can convert a nrg to an iso.

There’s also nrg2iso in the Packman repo too.

On Tue, 2008-09-16 at 09:36 +0000, deathstar 666 wrote:
> I have just installed ut2003 for linux and i am getting the following
> error from the konsole
>
> "…
> [19] ./ut2003-bin [0x805520e]
> [20] ./ut2003-bin(main+0x296e) [0x805820e]
> [21] /lib/libc.so.6(__libc_start_main+0xe5) [0xb72ce5f5]
> [22] ./ut2003-bin(GetFullName__C7UObjectPw+0x7d) [0x80512d1]
> Signal: SIGIOT [iot trap]
> Aborting.
> ut2003-bin: xcb_lock.c:77: _XGetXCBBuffer: Assertion `((int) ((xcb_req)
> - (dpy->request)) >= 0)’ failed.
> dexter:/home/andromeda # "
>
>
> I have the proprietary ati drivers installed with an Ati 9550
> installed. Does anyone got any idea on what the problem might be?. Other
> linux games like gl-117 work fine, and the fgl_glxgears test gives me at
> the very least 400 fps.

ut2004 is pretty much a fix for the grotesqueness of ut2003. You can
usually purchase it for less than $10 USB nowadays. I highly recommend
it. Also, afterwards, you’ll want the patches for it as it fixes
many more issues and gives you extra levels. DO NOT buy the Orange
box DVD plus expansion edition… it’s the new release of ut2004 without
Linux support. You’ll want the blue box DVD edition (IMHO) or the CD
edition.

try this:

LIBXCB_ALLOW_SLOPPY_LOCK=1 ./ut2003-bin

the ‘./ut2003-bin’ might be something else - replace it with whatever you use to launch the program. I haven’t played 2003 before, only 2004.

g