USR5410 will not connect

Hello all,
I thought I had my wireless card working, but it does not.

It is a U.S. Robotics USR5410 Turbo Wireless PCMCIA card. Here is a little bit of info.

Linux-Laptop:~ # dmesg | grep wlan
wlan0: ethernet device 00:c0:49:db:34:05 using NDIS driver: usr11g, version: 0x40000, NDIS version: 0x501, vendor: ‘U.S. Robotics 802.11g Wireless Turbo Adapter’, 104C:9066.5.conf
wlan0: encryption modes supported: none
I tried to post this all at once, but it told me I had too many flags, so I broke it up into several replies.

Linux-Laptop:~ # ndiswrapper -l
usr11g : driver installed
device (104C:9066) present

Linux-Laptop:~ # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 IEEE 802.11b ESSID:“Clay”
Mode:Managed Frequency:2.437 GHz Access Point: 00:12:0E:A4:2A:25
Bit Rate=54 Mb/s Tx-Power:0 dBm Sensitivity=0/3
RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:87/100 Signal level:-40 dBm Noise level:-96 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Linux-Laptop:~ # iwlist scan
lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:12:0E:A4:2A:25
ESSID:“Clay”
Protocol:IEEE 802.11FH
Mode:Managed
Frequency:2.437 GHz (Channel 6)
Quality:100/100 Signal level:118/154 Noise level:160/154
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
Extra:bcn_int=200
Extra:atim=0

I have tried it with security off, security on, added MAC address to filter, even though MAC filter was off. I tried with MAC address filter on, all to no avail. I believe all firewalls are off, I can see network, it just stops at 28% saying Activation stage: Configuring device. I tried DHCP static addressing, any other things to try would be great.

Well, I uninstalled the ndiswrapper driver and hunted up the firmware for acx111 cards. Now I can configure the essid with iwconfig, and the green light will blink trying to connect. When I do a dmesg | tail I get

Linux-Laptop:~ # dmesg | tail
acx_set_status(2):WAIT_AUTH
rates_basic:1000, rates_supported:1000
AUTHEN adev->addr=00:C0:49:DB:34:05 a1=00:C0:49:DB:34:05 a2=00:12:0E:A4:2A:25 a3=00:12:0E:A4:2A:25 adev->bssid=00:12:0E:A4:2A:25
auth algorithm 0, auth sequence 2, status 0
acx_set_status(3):AUTHENTICATED
sending association request, awaiting response. NOT ASSOCIATED YET
association: requesting caps 0x0061, ESSID “Home”
wlan0: association FAILED: peer sent Status Code 18 (Assoc denied: requesting STA doesnt support all data rates in basic set)
BSS_Type = 2
JoinBSSID MAC:00:12:0E:A4:2A:25

And it never connects.

After letting it try to connect the output is

Linux-Laptop:~ # dmesg | tail
no matching station found in range yet
acx_set_status(1):SCANNING
starting radio scan
get_mask 0x00000000, set_mask 0x00000000
get_mask 0x00000000, set_mask 0x00000000 - after update
get_mask 0x00000000, set_mask 0x00000040
setting RXconfig to 2010:0FDD
get_mask 0x00000000, set_mask 0x00000000 - after update
acx_set_status(0):STOPPED
closed device

Well, I had it working, but it stopped. I had to set preamble in my router to always long, then if I try to connect using NetworkManager 3 times the NetworkManager stops running and I can connect with ifup wlan0. I tried to turn the network manager off, but when I tried ifup wlan0 it says that network manager is in charge of that and it will advie it to start it but it does not. Is there any way to make network manager to not runn so I can start it with ifup wlan0? It will always start after the task bar says that network manager is not running.

Solved, somewhat.
I have it working good now, what I had to do was reinstall ndiswrapper drivers, and kill networkmanagers. Now I need to see if I can find out how to disable networkmanager and networkmanagerd. It works great now, MAC filter, WEP keys and all. I never could get it working properly with the acx drivers.

clayb226 wrote:
> Solved, somewhat.
> I have it working good now, what I had to do was reinstall
> ndiswrapper drivers, and kill networkmanagers. Now I need to see if I
> can find out how to disable networkmanager and networkmanagerd. It works
> great now, MAC filter, WEP keys and all. I never could get it working
> properly with the acx drivers.

Do that with YaST => Network Devices => Network Settings under the Global
Options tab.

Thanks, that was any easy fix, I was looking all over everywhere else, but was looking in card specific places not global.
Works great now with ifup wlan0. SOLVED!!!