'/usr/lib/bootloader/grub2-efi/config' failed with exit code 1,?

After running the latest zypper dup and rebooting back into TW, I then ran “update-bootloader” as I do weekly to update grub to the other systems . . . TW is the master controller of grub, and usually now it runs through pretty quickly . . . today it brought back this error. Haven’t had time to look into any of it, to know if this is “normal” or whether one of the Debian or Ubuntu systems “revived” its own version of grub and is trying to subvert the established order???

Anything to do here?? I rotate through a different linux system each day, and back to TW on Mondays to run update-bootloader, etc.

sudo update-bootloader
[sudo] password for root: 
update-bootloader: 2023-07-17 08:22:02 <3> update-bootloader-5287 run_command.337: '/usr/lib/bootloader/grub2-efi/config' failed with exit code 1, output:
+ /usr/sbin/grub2-mkconfig -o /boot/grub2/grub.cfg
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-6.4.3-1-default
Found initrd image: /boot/initrd-6.4.3-1-default
Found linux image: /boot/vmlinuz-6.3.9-1-default
Found initrd image: /boot/initrd-6.3.9-1-default
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Debian GNU/Linux trixie/sid on /dev/sda6
Found openSUSE Leap 15.5 on /dev/sda8
Found Manjaro Linux (23.0.0) on /dev/sdb7
Found openSUSE Tumbleweed on /dev/sdb8
Found Mac OS X on /dev/sdc2
Found Debian GNU/Linux trixie/sid on /dev/sdc6
Found Ubuntu Mantic Minotaur (development branch) (23.10) on /dev/sdc7
cannot open `/boot/grub2/grub.cfg.new': No such file or directoryUsage: /usr/bin/grub2-script-check [OPTION...] [PATH]
Try '/usr/bin/grub2-script-check --help' or '/usr/bin/grub2-script-check
--usage' for more information.
Syntax errors are detected in generated GRUB config file.
Ensure that there are no errors in /etc/default/grub
and /etc/grub.d/* files or please file a bug report with
/boot/grub2/grub.cfg.new file attached.

to be honest, I don’t know the command update-bootloader as I just switched to openSUSE. Is that a custom openSUSE script or a bash-alias?

You could try and re-run sudo /usr/sbin/grub2-mkconfig -o /boot/grub2/grub.cfg

Did you do any changes to /etc/default/grub or one of the scripts in /etc/grub.d/?

Edit: never mind, I found it here: update-bootloader man page on OpenSuSE

according to that I think you could run sudo update-bootloader --reinit

1 Like

Thanks for the reply on it. Haven’t had time this morning to fiddle with any of it, look under the hood and so forth . . . .

But, yes, I could try the “mk-config” command and see if that returns an error. Did not myself make any edits to any of the grub files.

Thanks for the idea on the “–reinit” . . . I’m mostly a GUI user and just run a number of installs, seems like sometimes other systems “reach over” and mess with other people’s stuff . . . ???

If I understand the man page of update-bootloader correctly it would be enough to run sudo update-bootloader --reinit.
That should include the grub2-mkconfig command.

If that returns a syntax error in grub.cfg again, maybe you could post your grub.cfg here?

1 Like

OK . . . maybe we have squeezed around the problem, ran grub2-mkconfig -o /boot/grub2/grub.cfg and that went through the list of OS’s cleanly . . . . Then for humor I again ran “update-bootloader” and this time went through without error . . . .

I wasn’t familiar with the “reinit” option, but good to know that would include running the “mk-config” command with it.

Thanks for playing through on it.

Nice that it worked.

Technically I assume you could automize this process with a systemd path and the respective service unit. I just don’t know if it would be triggered after your next tumbleweed boot after you e.g. updated Manjaro.

In case you are interested and have the time to play around: systemd.path

1 Like

Other folks here have suggested using scripts to update the system, automatically . . . my “problem” is that I log in and out of systems . . . on a whim . . . responding to the vicissitudes of life . . . or shutting the machine down after checking social media and/or updating the days’ system . . . . Wouldn’t want some script interfering or being interfered with by that.

But, yes, I think I did recall seeing this week that Majaro ran “os-prober” while running a pacman update a few days back, even though grub was never installed on it, or was removed . . . somehow it zombied itself back into the mix. On one of my other machines I had a recent re-install of Debian Testing reach over and “adjust” the swap UUIDs of two other systems, messing with their /etc/fstab files . . . PITA to get that all readjusted just to have one more install going . . . . : - 0

1 Like

That indeed is weird. But you never know what custom scripts some distros might use…

That is relatable.

I can imagine. Multiboot can be… interesting :wink:

1 Like

Indeed. “The few, the proud . . . the multi-booter” . . . . It’s just for sh*ts and giggles or “variety is the spice of my linux life . . . jack of all trades . . . .” Sometimes it is hard to get all of the kids to play together, nicely, etc.

mrmazda has also pointed out the folly of my “multi-boot is the answer” thinking, saying, “for the most part they are all the same, so why waste time on it?” Very pragmatic guy . . . .

1 Like

Looking through the other posts, it doesn’t seem like there is any way in this new forum to “mark as solved” or add [solved] in the subject line as we were previously asked to do??

Not here.

The fact that you post that you are satisfied with answers is enough.

1 Like

Ah . . . OK, yes, satisfied customer . . . so this is all handled by “AI” or “ChatGPT” these days?? The server is processing the status of the thread and moving it around in the queue for maximum efficiency???


I have no idea why you are thinking that. It is simply humans that read that you have your solution. Nothing more, nothing less.

Homes, that was “dry humor” . . . not “thought based” . . . humor data, nothing to do with the way of thinking or deriving a conclusion based in fact.