Using virt-manager in Gnome asks for ssh-key password every host it connects to

I use Gnome as my desktop environment, and I use virt-manager to connect to some KVM/QEMU remote hosts. The connection auths from my ssh key, saved in ~/.ssh/id_rsa, I’ve noticed that if I launch virt-manager from the Gnome shortcut virt-manager comes up with a sshaskpass window asking me to put in my ssh key password (if I type it in for the first server, it then asks me again for the second server). However, if I launch virt-manager from terminal instead (where my ssh-key is already unlocked) it doesn’t ask me for my ssh key password.

I would rather not have to put my password in every time I want to connect to QEMU on a remote machine, I would like virt-manager to use my unlocked ssh key.

I have checked in seahorse, the key is listed under Secure Shell, I also tried importing the key in to my login keychain. But after trying to launch virt-manager from Gnome again it still asks me for my password again.

Is there any way to make sure that graphical applications are passed the unlocked ssh-key so I don’t have to put my password in every time I launch virt-manager from Gnome. I have had some issues with virt-manager in the past, so I have it from git locally. I tried pointing the desktop shortut to use that version instead, but it does the same. I can run either from terminal and neither then ask me for my password.

Did you install your virtualization using
YAST > Install Hypervisor and Tools
and <not> any oither tool like Software Manager?

When you see an inconsistency like that,
Your first move should always be to update your system with

zypper up

TSU

Honestly, I’m not sure how I installed it, I probably changed the version I used at some point by installing from software.opensuse.org and then went back to the main version using the same method when the bug I reported was fixed, using zypper dup to change installed version

I can try uninstalling and reinstalling and see if that fixes the issue.

I tried installing again via YaST and it seems to work fine now, thanks

Just launched virt-manager again and it’s asking for passwords again… I tried reinstalling from YaST again and that doesn’t fix it any more…

Hi
Maybe ssl on the remote hosts not up to date? Have you tried ssh(ing) to the hosts? On my remote system I added my keys, all works fine in gnome and virt-manager.