Using systemd - What are your impressions?

I recently installed systemd in openSUSE 11.4 Milestone 3. And, I was able to shave of 15-20 seconds during boot up to desktop.

And, the shutdown is very fast compared to SysV!!

What are your stats?

Just have fun.


I installed systemd also. I hit esc during the boot process to see what was going on and there’s only about a dozen lines of text before it switches to the graphical login. This is opposed to the more than full screen of text that happens when one uses sysv. One thing I noticed was that, when I opened my browser, it took about 20 seconds for the first web page to load. After that, everything worked normally. And like Romanator said, shut down is faster also.

What steps did you take to install systemd on openSUSE 11.3?


systemd is in the 11.4-ms3 and Factory oss rpositories. Use zypper or Yast to install. Try it out by adding:


to the kernel opyions in your default boot entry, and reboot.

There is more at:

SDB:Systemd - openSUSE

The steps in SDB:Systemd, specifically refer to openSUSE 11.4 only. In addition, the kernel that comes with openSUSE 11.3 has cgroups (control groups) disabled.

However, the openSUSE 11.4 kernel (2.6.36x) has cgroups enabled by default (cgroups=yes). This allows the user to use Systemd or SysV.

Systemd requires recent:

  • kernel (2.6.36x) (/sys/fs/cgroup/
    ) - udev (service files, interfaces)
  • dbus (interfaces)
  • mkinitrd (bug fixes)

It might need fixes/changes from:

  • aaa_base
  • screen
  • ConsoleKit

Systemd was not tested by the devs for 11.3, it might work to update all these packages in 11.3.
But, things more than likely will go serious wrong.

It makes more sense to create separate partitions for Factory or openSUSE 11.4 to experiment and submit any errors to Bugzilla.

Have a lot of fun!


I tried it in a virtual machine, and have never had anything boot so quickly. I’m really impressed. How it fares on my physical hardware has yet to be seen…

Agreed. By the time openSUSE 11.4 gets released, we should have systemd set up in the default installation. It’s much better and faster than Upstart.

I have it installed on a separate sandbox partition. Fast boot and fast shutdown!

Have a lot of fun!


I’m testing systemd in 11.4 M3, not 11.3.

Thanks pilotgi. Now it makes sense.

It certainly is a learning experience. :slight_smile:

Looks like a newer, improved release of “systemd” will be available next week for
openSUSE 11.4 Milestone 4 of 6.

The most recent version of “systemd” appears to stall at the console prompt when shutting down.
However, a patch has already been added to resolve the “shut down” signal problem.

Have fun testing!


A ctl alt delete finishes the shutdown/reboot process.
I don’t have any virtual consoles though

  • Romanator wrote, On 11/21/2010 12:36 AM:
    > The most recent version of “systemd” appears to stall at the console
    > prompt when shutting down.
    > However, a patch has already been added to resolve the “shut down”
    > signal problem.

I noticed that when I used the KDE means to shutdown the system. “init 0” works fine for me.


When I referred to console prompt, this is the prompt that the user will see when pressing the [ESC] key.

After installing systemd-12-2.1 and selecting “Shutdown” or “Restart”. The system switches from a “gui” shutdown/restart to console prompt.

The only alternative is to try “CNTRL+ALT+DEL” to restart. If you can find a way to log in as root “init 0” will work or “shutdown now” to shutdown the system.

Hopefully, we will get a better version than the one that is in Factory now.


On my system, I get the switch to the console prompt after shutting down from the gui, but the shutdown completes with no problem. Same with restart. I’m using kernel-desktop-2.6.36-18.2 and KDE 4.5.3-3.3.