Using snapper for first time question

I am trying to familiarise myself with snapper for the first time. I read that the default installation would have set up an initial root configuration so to check that this was the case I ran:-

alastair@ibmserv3:~> sudo snapper list-configs
[sudo] password for root: 
Config | Subvolume

I ran sudo thinking that I was working on the root system and may not have needed to run as root but whatever the case, I do not have any default configuration.

Do I need to start a daemon which was not started from my initial installation?
I shall be working through tutorial this weekend but I am puzzled that the default system is not running. How may I correct this for the future?

If you read the documentation you will find the answer in the first chapters how to create the default config…

As usual, it depends. In particular, it depends on the root partition size. You again do not show any information from your system so it is impossible to say why no snapper configuration is present.

All good here thanks. The docs tell me that taking snapshots is automatically enabled and I couldn’t recall disabling snapper when the system was installed. That was why I was asking.
My system is fine and docs are clear but thanks for the reply.

The document states clearly as also pointed out by arvidjar:

Taking snapshots is automatically enabled if the root partition (/ ) is big enough (more than approximately 16 GB). By default, snapshots are disabled on partitions other than / .

Note that on a Btrfs root file system, snapshots require a file system with subvolumes configured as proposed by the installer and a partition size of at least 16 GB.

As of openSUSE Leap 15.5 system rollbacks are only supported if the default subvolume configuration of the root partition has not been changed.

Your turn…

Getting a bit out of my comfort zone as usual. The whole nvme drive is set up with Btrfs and I do not know how the (/) partition size and sub-volumes are determined during the installation. Only that the installation system creates them. I had understood when reading the docs that the installation on a 1.82 TiB would have been sufficient. It is likely I disabled the default but it would have been more than a year ago and I had been working on several machines.