using older GCC++ (3.3 and 4.3) with 11.2M5

for various reasons I need to use
gcc 3.3 and 4.3
(actually I need 3.4 – but that’s not provided)

on my 64 bit 11.2M5 installation.

I installed those packages with Yast but C++ does not work there

gcc-4.3: error trying to exec ‘cc1plus’: execvp: No such file or directory

the same error is for 3.3

the preprocessors are installed, but they are named cpp-3.3 and cpp-3.4 (while gcc is looking for cc1plus)

I cannot resolve this myself, and therefore askign for advise.

Also, as side note, the /usr/lib64/ is reported as ‘bad symbolic link’ – as it is not linked to anything.

thank you in advance

you need to export the flags for the system to use/override the default
softlinks, for example;

export CC=/usr/bin/gcc-3.3
export CXX=/usr/bin/g++-3.3
export CCP=/usr/bin/cpp-3.3

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 Milestone 6 (i586) Kernel 2.6.31-rc6-3-desktop
up 0:17, 2 users, load average: 0.13, 0.14, 0.14
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

I tried that but still get

> $CXX Test.cpp
gcc-3.3: installation problem, cannot exec `cc1plus’: No such file
or directory

Since there is no g+±3.3 I had to modify the exports slightly

export CC=/usr/bin/gcc-3.3
export CXX=/usr/bin/gcc-3.3
export CCP=/usr/bin/cpp-3.3

But still it looksl like the compiler wants cc1plus

may be there is a ‘switchto’ script or other configuration I could try?

thank you

It may be lurking down in the /usr/lib… area. If you run
cnf cc1plus
Or use YaST to browse the gcc33 file list to see where it is.

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 5 days 4:06, 3 users, load average: 0.00, 0.04, 0.09
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

Hi, by itself gcc-3.3 does not install the CPP processor (or at least I do not see it)



35 files total

So I separately installed cpp-3.3
but the gcc-3.3 does not want to use cpp-3.3 for some reason

Grab the one from Factory Devel repository;

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 5 days 6:45, 3 users, load average: 0.27, 0.10, 0.02
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

Not sure if repo has changed or Missed them the first time
I found and installed additional two packages

once installed the 3.3 and 4.3 compilers worked

thank you