Using with Amarok?

I’m trying to use Amarok with
I am a member there but I haven’t played any music there yet.
I’ve tried signing in with Amarok, and it says that I signed in successfully but when I try to see my “stations” (My Recommendations; My Radio Station) I get this error message about having to be a paying subscriber to see or play my lists.
I’ve also tried signing in from the website and then trying it in Amarok (the website plays music just fine, btw) but that did not help.
KWallet keeps popping up too saying that there is no running wallet and do I want my info saved. At first, I kept saying “no” and canceling that but after trying a few times, I allowed KWallet to save my login info as text. I still can’t see any lists.

Are there any dependencies that Amarok uses for this service?
I have no idea what port number to check for as well. (We are behind a firewall and most of the ports are blocked).

Do the tracks you play show up on your (like →this)?

As far as I know, playing for free is pretty restricted to a few countries. However, while it does not work for me in Clementine, I can listen to them in the (package ‘’ from the “Multimedia:Apps”-repository).

I also think that will have to collect some info about your listening habits before creating radio programs for you.

No, they do not show up like that.
What is Clementine?
Have you ever tried it in Amarok?

When I went to the’s page, it now tells me, “There was an error connecting to your Library. A page refresh should fix this problem.” I didn’t have this problem yesterday. Page refreshes don’t help btw.
I did put a few songs in a playlist but only 30 seconds or so will play. That is stupid.