Using Knetworkmanager

Using KDE4 download CD ISO and upgrades from factory site.

The 11.0 system apparently comes up in ifup and does not give the installer the option to use Knetworkmanager as in 10.2. Also the icon in the tray which has changed its traditional form as in most distros, is a bit puzzling to this writer. The installation gave me a DHCP address which works on the Nvidia eth0 MB port OK. I don’t like to work in DHCP and prefer a static set of addresses.

Right-clicking the new green icon shows both eth0 and wlan0 in bold at the top. But, if I left-click ‘edit connections’ there are no connections shown. If I am bold and enter a new connection as a static, I then cannot get on-line. If again bolder, I enter a wireless address, it also hiccups.

I am not a stranger to setting up these connections in other distros on this HD. Why would Novell change connection philosophy in a distro?

If someone could point me in the right direction here, I’d appreciate it.


Hi there,

I’m puzzled too. Although I got kneworkmanager working as it should in my laptop after creating an specific wlan0 configuration, I still have stability issues in a desktop with a wireless PCI card using the “automatic” wlan0 config knetworkmanager makes - which I suppose is just a mirror of what you configure in Yast > Network devices. Connection sometimes start at boot as it should, sometimes only after going through Yast > Network devices configuration again. I’m still mustering forces to deal with this.

I think that knetworkmanager still have to stabilize, and you certainly should update it from the repo before trying anything.

I just replied so you won’t feel alone. :slight_smile:

Mine doesn’t start upon bootup :\ It sort of works otherwise, athough I find it strange that the Deactivate menu item is used for both deactivation and activation of connections.