Using IEEE 1394 Card to download from Camcorder

I have a Pinnacle IEEE 1394 card which according to Yast/Hardware Information seems to be installed and recognised correctly.
Trying to use Kino to download from a Camcorder via IEEE 1394 nothing happens and looking at Kino Preferences IEEE 1394 tab it tells me:

“The IEEE Subsystem is not responding.
The raw 1394 module must be loaded, and you must have read and write access to /dev/raw1394.”

I do not have an entry /dev/raw1394 on my system.
Files libraw1394 and libraw1394-8 were installed by default(SUSE 11.3 64bit), and I have since installed any others offered which were libraw1394-8-32bit, libraw1394-devel, libraw1394-devel-32bit but to no avail.
Can any one please tell me how to get things working? Please bare in mind I am a complete numpty with command line functions but I think I can manage to follow instructions!

merkland.

Judging by the lack of response it looks as if no one has an answer to my problem or have I not provided enough information? If this is the case please advise what additional information is required.

merkland.

Well this is a long shot because I don’t have an IEE1394 camcorder - but since no one has responded to this thread for some days, I guess something is better than nothing. From what I have read about Kino, you need both libraw1394 and libavc1394 installed. The latter is for controlling the camcorder and the former I think provides the 1394 device in /dev. There may be several other dependencies required.

If you had installed Kino from the Yast GUI (Yast -> Software Management -> Search for Kino and click) then it would have pulled all these dependencies in automatically. Is that what you did or were you trying to do it step by step from the command line?

I suppose there is a chance your 1394 card doesn’t work. What make you think the OS has recognized it?

Hope that helps.

Good morning Plodder,

I installed Kino through Yast and both the files you mentioned are installed.
The reason I think the card is recognised and should work is this copy of System information:

“41: PCI 306.0: 0c00 FireWire (IEEE 1394) (OHCI)
[Created at pci.318]
Unique ID: Kaa7.hTLMqoL2j07
Parent ID: qscc.ULOo3yhA66C
SysFS ID: /devices/pci0000:00/0000:00:14.4/0000:03:06.0
SysFS BusID: 0000:03:06.0
Hardware Class: firewire controller
Model: “Agere FW322/323”
Vendor: pci 0x11c1 “Agere Systems”
Device: pci 0x5811 “FW322/323”
SubVendor: pci 0x11bd “Pinnacle Systems Inc.”
SubDevice: pci 0x000e
Revision: 0x04
Driver: “ohci1394”
Driver Modules: “ohci1394”
Memory Range: 0xfebff000-0xfebfffff (rw,non-prefetchable)
IRQ: 21 (3 events)
Module Alias: “pci:v000011C1d00005811sv000011BDsd0000000Ebc0Csc00i10”
Driver Info #0:
Driver Status: ohci1394 is active
Driver Activation Cmd: “modprobe ohci1394”
Driver Info #1:
Driver Status: firewire_ohci is active
Driver Activation Cmd: “modprobe firewire_ohci”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #28 (PCI bridge)”

This suggests to me that things should be working unless there is something there which indicates otherwise!

merkland.

try the following

su
tail -f /var/adm/messages

Then plug in and unplug the camera. Do any messages appear ?

If you don’t get any messages, try providing the following information

  1. disconnect the device
  2. in a terminal, start udevadm in monitor mode and capture output

su
udevadm monitor -e | tee udev.log

  1. connect the device
  2. open a second Terminal and capture lshal, dmesg and ls the attached volumes

lshal > lshal.txt
dmesg > dmesg.txt
ls -l /dev/sd* > devices.txt

  1. Press Control-C in the first terminal with the “udevadm”.
  2. Attach lshal.txt, devices.txt, dmesg.txt and udev.log to the bug report
  3. Paste the output of ck-list-sessions into the bug report
  4. Paste the output of id haldaemon into the bug report
  5. Paste the output of uname -a into the bug report

In easy cases this is everything that is needed. However, you might be asked for a “hal debug output”; please do the following steps to get it:

  1. disconnect the device
  2. stop hald

su killall hald

  1. start hald while capturing its output (as superuser)

hald --daemon=no --verbose=yes 2>&1 | tee hal.log

  1. wait until the flood of messages settled
  2. connect the device
  3. wait again until no more messages appear
  4. press Control-C to stop the foreground hal
  5. restore the background hal:

sudo /etc/init.d/hal restart

  1. attach hal.log to the bug report
  2. restart your desktop session

Credits go to Ubuntu Forum however this information is generic and will work on suse

I may be able to help

1 For read and write access to the 1394 system, you need to be member of the group “video”, so go into Yast -> Security and Users -> User Management and add yourself to the group. Log out and back in to effect the change.

Try the software again. If not, then move on…

2 The module raw1394 may not load automatically. Initially, you can manually load the module from a command line:

su
modprobe raw1394
If the software then works for you, then you can have raw1394 load at boot time with a simple system configuration.

To check which 1394 modules are loaded, run this command:

lsmod | grep 1394
Hopefully this will get you closer to working video capture.

Paul

Actually, as I think on it, “video” group membership may not be sufficient. I created a udev rule to handle permissions:

Create a file called : 20-udev-firewire.rules in /etc/udev/rules.d (you’ll need root permission)

Add the following entries to this file:

allow video group to read/write /dev/raw1394

SUBSYSTEM==“firewire”, GROUP=“video”,MODE=“0660”
KERNEL==“raw1394”, GROUP=“video”, MODE=“0660”
I don’t think a reboot is required here. This udev rule provides for read and write permissions to the 1394 device for root and video group members.

I had to do this to enable access to my firewire sound interface, and it had the nice side-benefit of enabling video capture with my wife’s camcorder.

Paul