Using Gspca

Hello I’ve installed gspca through the opensuse build service and cant figure out how to use it… I run lsusb and my cam is detected (Bus 005 Device 004: ID 046d:0896 Logitech, Inc. OrbiCam)
so where do I go from here?

Hi. Just follow the instructions here HCL/Web Cameras - openSUSE. Good luck!

well this only really tells me how to install,which I have done…just not sure how to access it also in the article it gives you an alternative to install an use gqcam for this,which I did but cant find it anywhere after I’ve installed it (does the same thing with some games too). or is gqcam a kde3 only app? because I noticed if I tried to install the “black-box” game I couldn’t find it anywhere but, if I installed “kde4-kblackbox” there was no problem

Try starting gqcam from a console with ‘gqcam’. You can do ‘gqcam --help’ to get list of options.

Some other webcam apps:

camorama (Gnome app)
xawtv (TV tuner app that now works as a webcam app as well)

Use webpin to search for them.

alright it brought it up but there’s errors reading the image…but why would I have to bring it up in the terminal anyway why wouldn’t it just show up in the kicker…I’ve been having these problems with alot of software for some reason,(p7zip is nowhere to be found) but back to what we were talking about I don’t know why there was an error reading the image as I have gspca installed and it supports my cam fully…though do I have to install the gspca-kmp-debug?

alright I’ve uninstalled the base package and went for the tared one off the website. So I untar move to the gspca directory and run gspca_build but am given a long sting of error messages that I don’t even begin to understand so here they are maybe someone can give me some insight…

INSTALL gspca in the kernel binary tree
mkdir -p /lib/modules/uname -r/kernel/drivers/usb/media/
rm -f /lib/modules/uname -r/kernel/drivers/usb/media/spca5xx.ko
rm -f /lib/modules/uname -r/kernel/drivers/media/video/gspca.ko
install -c -m 0644 gspca.ko /lib/modules/uname -r/kernel/drivers/usb/media/
install: cannot stat `gspca.ko’: No such file or directory
make: *** [install] Error 1

LOAD gspca in memory
FATAL: Module gspca not found.

make -C /lib/modules/uname -r/build SUBDIRS=/home/kurt/gspcav1-20071224 CC=cc modules
make[1]: Entering directory /usr/src/linux-' make -C ../../../linux- O=/usr/src/linux- modules CC [M] /home/kurt/gspcav1-20071224/gspca_core.o /home/kurt/gspcav1-20071224/gspca_core.c:54:27: error: asm/semaphore.h: No such file or directory /home/kurt/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_ioctl’: /home/kurt/gspcav1-20071224/gspca_core.c:2463: error: implicit declaration of function ‘video_usercopy’ /home/kurt/gspcav1-20071224/gspca_core.c: At top level: /home/kurt/gspcav1-20071224/gspca_core.c:2609: error: unknown field ‘owner’ specified in initializer /home/kurt/gspcav1-20071224/gspca_core.c:2609: warning: initialization from incompatible pointer type /home/kurt/gspcav1-20071224/gspca_core.c:2611: error: unknown field ‘type’ specified in initializer /home/kurt/gspcav1-20071224/gspca_core.c: In function ‘spca50x_create_sysfs’: /home/kurt/gspcav1-20071224/gspca_core.c:2769: error: implicit declaration of function ‘video_device_create_file’ /home/kurt/gspcav1-20071224/gspca_core.c:2780: error: implicit declaration of function ‘video_device_remove_file’ /home/kurt/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_probe’: /home/kurt/gspcav1-20071224/gspca_core.c:4301: error: incompatible types in assignment make[4]: *** [/home/kurt/gspcav1-20071224/gspca_core.o] Error 1 make[3]: *** [_module_/home/kurt/gspcav1-20071224] Error 2 make[2]: *** [sub-make] Error 2 make[1]: *** [all] Error 2 make[1]: Leaving directory /usr/src/linux-’
make: *** [default] Error 2