Using gparted is confusing to me

openSuse 13.2

but I would have trouble no matter the version.

I am trying to simply format an SD card using gparted. It will be used as a boot disk for a Raspberry PI2
I dismount it, delete the old partitions, and try to create a new partition.
At that point when I press apply, I get a message about how I would have to reboot, something about the operating system needs to know about the device.
The message gives me *2 *choices, ignore or (I think cancel).
What’s with having to reboot ? That’s a pain.

So, is there an easier way to do a simple format of an SD or USB device using the max size, as FAT32, with a label ?

or could you point me to some reading material ?

thanks

On 2015-05-31 18:46, hextejas wrote:

> The message gives me -2 -choices, ignore or (I think cancel).
> What’s with having to reboot ? That’s a pain.

Ignore, then unplug and plug back the drive.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

The reboot would be to auto mount it I’d guess.

On 2015-05-31 19:26, gogalthorp wrote:
>
> The reboot would be to auto mount it I’d guess.

Not necessarily.

Sometimes, when you partition/format a disk, there is an error, and the
kernel still thinks that the disk did not change partition. There is a
command to try make the kernel read it again; if you use fdisk for the
operation, and it detects the error, it will tell you about that command.

If the disk is removable (sata or usb), removing it does the trick.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

Yes but this is gparted.

Actually, “fdisk” gives a similar warning.

Follow the advice from Carlos. Unplug the device (unmount first if it is mounted). Then plug it in again.

The issue is that the system keeps cached information about the device, and that cached information is now out of date.

On 2015-05-31 20:06, gogalthorp wrote:
>
> Yes but this is gparted.

I know, I know. But there is a command line that tells the kernel to
re-sync the partition table, and I don’t remember it. I know that fdisk,
on the same situation, tells the user to try that command, and if it
fails, reboot.

The underlying problem is the same, the kernel not knowing that the
partition table of a disk has changed; thus trying to further access it
can write sectors to the wrong locations, which is pretty dangerous.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Hi,

It is likely

partprobe

is what ya’ll looking for.

partprobe --help

and

man partprobe

are both very short, I promise. :wink:

On 2015-06-01 01:16, jetchisel wrote:

> is what ya’ll looking for.

Can be, yes. Partprobe. Worth a try.


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

There has to be an easier way to do this.
If you look at these partitions, when sdf5 is unmounted and I try and unmount sdf6, sdf5 gets re-mounted. When sdf6 is unmounted and I try and unmount sdf5, sdf6 gets remounted.
Arggggggggggg

isnt there a brute force way to format this device ?

http://i59.tinypic.com/2vd67mb.png

Well, erase the partition table (or even the whole disk).

dd if=/dev/zero of= /dev/sdX bs=512 count=1

(where X should of course be replaced with f or what it is, do NOT make an error here!) for the partition table.
Remove the last two parameters about bs and count when you want to zero the whole disk, but that will take some time.

Step 1: logout

Step 2: login to Icewm

Step 3: Click on the terminal icon in the panel, to open a terminal session

Step 4: su to root

Step 5:

# gparted

It is your desktop, not “gparted” that is causing those problems.

I remember trying to use “gparted” from the 13.2 rescue CD. The GUI menu entry didn’t work. So I opened a root terminal and typed “gparted”. Lots of partitions were automatically mounted, including partitions on the device where I wanted to change the partitioning.

I logged out, then logged into Icewm. And “gparted” worked smoothly there.

When I have tried “gparted” in KDE, it doesn’t mount partitions but the device notifier annoyingly pops up though that is less of a problem than the automatic mounting.

On 2015-06-01 16:46, hcvv wrote:
>
> Well, erase the partition table (or even the whole disk).

No, that will not work.

The problem is that as soon as you “format” the filesystem, the desktop
notices it and automatically mounts it. I’ve have this issue a lot with
the YaST partitioner.

What I often do then is work in text mode, which is a nuisance. nrickert
suggestion to use Icewm is interesting. A command to block or disable
automount would be nice.


Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)

On 2015-05-31, hextejas <hextejas@no-mx.forums.microfocus.com> wrote:
> So, is there an easier way to do a simple format of an SD or USB device
> using the max size, as FAT32, with a label ?

Yes. Don’t use gparted. Use parted. It’s easier, cleaner, and more powerful than any other partition program. Read the
manual and you’ll see why.

As an example to illustrate its power, here are some commands that will do 3 things to an empty USB drive (/dev/sdY):


sh-4.2 $ su -
sh-4.2 # parted /dev/sdY
(parted) mklabel gpt
(parted) mkpart ESI fat32 1MiB 512MiB
(parted) mkpart primary 512MiB -1MiB
(parted) set 1 boot on
(parted) quit
sh-4.2 # exit

The 3 things this will do are:

  1. Create a GPT label.
  2. Create an EFI-compatible 0.5 GiB FAT32 partition.
  3. Use the rest of the drive a create a second partition (which you can subsequently format, e.g. using FAT32).

With this power, parted really does make fdisk obsolete.

Confused?
Want a partitioning solution that works for <everything> no matter what you want to do, whatever formatting, whatever disk layout, whatever OS, whatever <anything>?

Use Gparted live, not the app.
It’ll modify your system and boot partitions directly (the app might require a reboot).
Since it’s a single function tool, you can’t get lost doing something else.
Only requirements are that you need to be able to boot to CDROM or USB where your Gparted live image is, and for the target disk to be accessible.

The current downloadable image (either burn to optical media or mount directly in a virtual CDROM on virtualization platforms)
http://downloads.sourceforge.net/gparted/gparted-live-0.22.0-2-i586.iso

The overall gparted Download page
http://gparted.org/download.php

There are plenty of other ways to partition, but IMO this is the only nearly brain-dead approach to every scenario.

TSU

Hi

I think there is enough help already listed.

However if you use dd then it wipes and installs all in one go.

#################################################################
Installing the openSUSE Tumbleweed Image

  1. Download the latest image at http://download.opensuse.org/repositories/devel:/ARM:/Factory:/Contrib:/RaspberryPi2/images/
  2. JeOS image for a minimal system openSUSE-Tumbleweed-ARM-JeOS-raspberrypi-*.raw.xz
  3. As root
    extract the image onto your SD-Card (replace sdX with the device name of your SD-Card). WARNING: all previous data on the SD-Card will be lost.

xzcat [image].raw.xz | dd bs=4M of=/dev/sdX; sync

######################

sometimes mine is /dev/sdf on my iMac it is /dev/sdb

then you can use the OS.

Wipe files etc and you are left with 4 empty partitions. Use Microsoft.

Generally use gparted and delete partitions.
Close gparted and use the yast2 partitioner.

OR remove the disk and redo gparted and create.

Be a little creative or imaginitive.

If you use gparted live which is a bootable CD (not gparted which is installed on a HDD)
and
your system BIOS supports a bootable USB stick,

Then,
It’s probably straightforward to simply
Configure boot to CDROM
Insert your USB stick
Reboot.

You should then boot directly to gparted live and see your USB stick for disk operations including formatting and marking as a bootable medium.

Just don’t make a mistake and perform operations on your HDD.

I suppose if you have any virtualization setup, you could do the same thing… Configure a Guest with a USB stick and boot to a gparted live iso…


As an aside, although you’re asking about using gparted, have you tried to also use the openSUSE partitioner?

TSU