Using external display and slide projector

One would think this would be a simple task. I’ve read all kinds of stuff online, seems fairly simple, all I want to do is clone my laptop screen to an external monitor (a slide projector). My laptop’s native res is 1400x900, and the external is 1024x768. I have used Yast to activate dual head mode, selected ‘clone’, I have also played around with nvidia-settings, ensured it is set to ‘separate x view’, etc etc. But the best I can do is to get my laptop’s display to appear on the slide projector, but not the laptop screen. I want the same display on both. I am using opensuse 11.0. Anyone have any ideas?

I’ve never had much luck with this either. Sometimes I was able to get it to work, other times it totally messed up my laptop’s xorg.conf file and stopped my PC from booting the GUI (until I restored a backup xorg.conf).

In all cases I was under major time pressure, with customers/clients/colleagues in the meeting room, with my having no time to try debug, …

What I need to so is stay late at the office some time and sort this.

But anyway, … here is a URL (somewhat dated) with some suggestions: Laptops and external VGA - openSUSE

If you have any success, please post here what works for you, as I too would like to learn (without my having to stay late at the office and spend much effort on my part)

Some of the “web” solutions are somewhat bizzare … here is a blog output of some sled users methodology. … I have no idea if this would work on openSUSE:
Selling Free Software for a Living: External Projector or Screens with SLED 11, nVidia and Thinkpad T61p

I took my laptop into the office today, and during my lunch hour I went to a free conference room and played a bit with the settings with one of the office projectors. I was under a bit of time pressure, as someone had the conference room booked just after lunch.

I note the WinXP PC in the conference room, is outputing 1024x768 to the projection system.

I followed the guidanance here Laptops and external VGA - openSUSE (on my Dell Studio 15 laptop, with a RadeonHD 3450 graphics, running a proprietary ATI graphic driver (v.9.7), on openSUSE-11.1 with KDE-3.5.10). My nominal resolution on my laptop display is 1440x900.

Since I anticipated lots of messing with sax2, I first ensured I had a backup of my laptop’s /etc/X11/xorg.conf file. :slight_smile:

So per the instructions quoted: Laptops and external VGA - openSUSE

  1. Start sax2 (or start yast2 and click on Hardware/Graphics Card).
  2. Enable Activate Dual Head Mode and click on Configure.
  3. Make sure that Cloned Multihead is checked.
  4. Select a monitor from the → VESA or → LCD vendor with 60Hz and the maximum resolution you want to drive the projector with (e.g. in my case 1024x768@60Hz).
  5. Select the same Second Monitor Resolution.
  6. Press OK in both dialogs to accept your changes and let sax2 save your configuration.
  7. Restart your Xserver (e.g. press Ctrl-Alt-Backspace)

I was back at the kdm login prompt. I noted the fonts were smaller now. I then logged in to my desktop. I then noted the projection partly worked, but there were problems:

  • the fonts on my laptop were significantly reduced to an ultra small size. Sharp. Readable. But ultra small. I don’t like ultra small. :slight_smile:
  • only a portion of my laptop’s 1440x900 display was shown on the projector. In fact, it looked like the upper left 1024x768 portion of the display
  • if I tried the YaST/sax2 test (after setting the monitor) the PC froze. That was unpleasant, and note to myself, when trying the Dual head Mode, do NOT use the YaST/sax2 test, but “just” save!!

So, this while the dual head on the laptop was projecting on the conference room “big screen”, it was not satisfactory.

I noted the wiki article suggested trying “krandr” (as an example) to get the right projector resolution. To my knowledge, on my laptop, there is no “krandr” executable. Still, that suggested to me more tuning was needed in some other step, that the wiki did not describe for the specifics of my setup.

So I then launched Kmenu > Configure Desktop > Hardware > Display and as soon as I did that, my laptop screen “jumped” to 1024x768 resolution, and the Projection screen suddenly illustrated the ENTIRE laptop displayed “real estate” area. i.e. it worked, and worked mostly very good (except I was reduced to using 1024x768 on my laptop). The fonts were also a bit fuzzy on my laptop screen at this 1024x768 (clearly NOT optimized) but the projection screen looked wonderfully focused.

So I succeeded … sort of.

Clearly I do not like this 1024x768 on my laptop. And I also do not like the 1440x900 ultra small size.

So, I think I will rename this /etc/X11/xorg.conf to /etc/X11/xorg.conf.projector and I’ll restore my original /etc/X11/xorg.conf. When I have a meeting, I’ll put the “projector” xorg.conf in place. and boot to it.

Its good to have a solution finally, even if it is not optimal.

Ok, a foot note to the above … I accidently ended up with a perfect output!

I typed the above post on my Dell (while connected to the projector) and after submitting the above post, while running KDE-3.5.10, I copied my original xorg.conf file, replacing the dual head version of the xorg.conf file (after backing up the dual head xorg.conf file). I then pressed <CTR><ALT><BACKSPACE> twice which put me back to the kdm login prompt, with my original fonts! I logged in and I had my 1440x900 display back with my nice nominal sized fonts.

Except … the projector was still connected, and it was projecting my laptops screen perfectly at 1440x900 resolution!!. :slight_smile:

I typed “xrandr” and confirmed my laptop was still outputing the dual head signal, even though it was NOT in the xorg.conf. My guess here is because I did not power down, that the signal was still being output by the radeon graphic hardware. And it was being output at 1440x900 resolution, which means the office projector can handle 1440x900 resolution.

What does that tell me?

Well, the xorg.conf file (for dual head) with its 1024x768 settings appears to be ignored by the radeon driver, and it outputs the same resolution as my laptop, no matter what is in the xorg.conf. At least the test results of mine suggest that.

It also tells me we have a GREAT conference room where I work, where I can give presentations at 1440 x 900 resolution in that conference room projector.

I suspect if I go to another conference room, where the projector only supports 1024x768, that I will have to change my laptop’s settings to 1024x768 in order to project the laptop screen.

I think I know enough now to do this quickly, that as long as I am at a meeting 5-minutes before the meeting starts, I have time to setup.

Excellent, I’ll try to follow these steps as closely as I can. Thanks very much. My thesis defense is in a day, so I was hoping to have it working by now, but I’m not sure I want to fiddle too extensively with graphics the day before. But after!!!
I’ll probably use windows tomorrow…ug. The ultimate victory for robots and defeat for mankind…

I note another thread that is also looking at this functionality, albeit from a different functional perspective: Laptop External Monitor Support - openSUSE Forums

A further note to this. … this thread referencing sax2 is HORRIBLY out of date. It is now MUCH MUCH easier to do this with KDE-4.3.2 on openSUSE-11.1 (and a proprietary ATI Radeon driver). I posted how to do this here, with sample pictures of the configuration menus:
Laptop External Monitor Support - openSUSE Forums