Using existing reiserfs

Just installed OpenSuSE 11.0 on top of a 10.3 system with the reiserfs on all the partitions. Now none of my partitions will mount! How can I fix this?

The second part of the question here is that now that the reiser fs is dead, how can I convert the reiser partitions to something like ext3 or JFS?

Reiserfs support hasn’t been removed from Linux. Something else is preventing your partitions from mounting. Maybe you might provide some other info?

When you installed, did you specify the mount points and types of the partitions (and not to format them)? If the installer doesn’t know that reiserfs partitions are involved, it may not include the module in the initrd.

What is in your /etc/fstab? Did you try mounting the partitions in the disk partitioner?

I would have been happy to had I known what to include.
I had the home directory in another partition. On boot I received the message “/dev/sdb3: no such file or directory” and so I went into fstab and commented out the entry for it.

Since the drive would not mount at boot time, I commented out the entry in fstab. Now that the system is booting, I uncommented the entry and changed the mount point to /home1. In doing a mount (mount -t reiserfs /dev/sdb3 /home1) I get a response from the mount command like I asked for the help from the mount command. If I did a mount all (mount -a) the response received is: mount point /home1 does not exist.

Now on another issue, I have a directory called /3x0-1 which does get mounted and is a reiserfs file system. This is on /dev/sda2 it shows only 1% used! It should be more like 90% used. Sure hope that the contents had not been harmed as I will switch to the most hated vendor’s product. What’s weird is that another line in the fstab points to the same device with all of the same attributes but has a directory entry of “/new”.

I did not specify that any partition was to be reformatted. During the install, I specified that it was to be an upgrade instead of a install.

Hold tight - there is a listed bug against Reiserfs for opensuse11.0. It causes system lock up on a clean install. Having 10.3 servers running on Reiser I have been waiting for a post like this to confirm my fears about the chances of upgrading.

Can you please try the following:
Add the option noatim,noacl to all the reiser partitions in /etc/fstab. So where is says “acl,user_xattr” change it to say “noatime,noacl”.

Reboot and post the results. Actually can you also please post your /etc/fstab in full so I can see it.

Hope it works out for you

PS I use Vista and believe me you don’t want to go there without a damned good reason i.e. a better reason than this.

Also if you want to check the partitions use the install cd to boot the rescue system. Then mount and query the partitions to see what is there.

I think you have a fair right to be annoyed given that the bug wasn’t marked as a show stopper for the 11.0 release and they didn’t state that reiser won’t work. I do think its a little naughty given that it was the default file system for suse up to 10.1 - so anyone who has done a couple of upgrades will hit probably this one.

BTW I have a partition that is reiserfs and it mounts and works fine on 11.0 from first install. It’s not a root partition though

Hi svetter88,

Sorry for coming in late but I think your 2nd question has not been answered yet.

I don’t believe Reiser can be “converted” in one shot to any other file system. It requires a reformat in the new FS, so this implies a copy of your files first.

There exist some tools to make the process easier though. Take a look at Convert Filesystem from reiserFS to ext3 « Bozzie Software

But if your partition isn’t the root partition, then using rsync to copy the data , symlinks, hidden files, etc. on another partition or disk will be fine.