Using a projector on OpenSuse

Boy, question…
As for beaming movies and presentation onto a wall, I certainly need a projector. And do I really need some sort of software?
Years ago (when I still used windows from time to time) a simple plug&play would work just fine. Apparently this doesn’t seem to work quite the same way on OpenSuse… please give me a hint on how to do this. Thanks.

Install the drivers for your videocard (nvidia or ATI) from the correspondig repository. For ATI, no idea, but for NVidia there is a tool nvidia-config (note sure, I’m not on my linux box right now) which you need to run as root and it will detect other screens connected to the laptop and it will allow you to set up dual monitor or extended desktop.

That is what you need.

Thanks, nvidia drivers already installed. I’ll test your suggestion on my next presentation.

Hello. Is the problem that the presentation or video shows on your laptop’s screen but it’s not showing on the wall?


Exactly. [20 chars]

OK, here’s how I got a projector to work with my SuSE laptop.

If you use KMplayer then click Settings (at top) > configure KMPlayer > general options > output > x11shm.

Selecting x11shm should send the laptop’s video output to the projector. You can verify this by connecting a monitor to the laptop. If the laptop’s picture shows up on the monitor then it will also work with a projector.

If you use Kaffeine then click Settings (at top) > xine Engine Parameters > video > Beginner options > and then on the drop-down menu select xshm. Again, that should then send the video output of the laptop to a projector (or a monitor if you want to verify).

If you use another player such as VLC Media Player there likely is a similar setting in that player.

Please try this out on a monitor (first without making the changes I suggest to confirm that the video output is not working) and then with the settings to confirm that it does go to the external monitor.

Good luck. :wink:

Thanks for your hints, but it’s not only about the media player. Its aboutr the whole screen.
Please take this issue as “solved” until I tested the change of the nvidia settings configuration next time I`m doing a presentation in our university.

SOLVED. Configuring the Screen through the NVIDIA manager works perfectly. :slight_smile: