Using a Microsoft Wireless keyboard in Linux

I just dug out my old MS Wireless Keyboard. I’m running short on USB ports, so I figured I could save at least one by using a wifi mouse and keyboard (though currently I can’t find the wireless mouse, so I’m not really saving anything. But the keyboard is nice).

I plugged in the USB wireless “thingy”, hit the green buttons, and presto! I was typing wirelessly. t works pretty good, with one exception; the F# row of keys are all combined with MS’s own “Help”, “Undo,” “Redo”, “Reply”, “Send”, “Fwd”, etc buttons. I don’t expect these to work under linux, but what is frustrating is they don’t work as regular F# keys either. They just sit there looking at me (metaphorically speaking…). I am guessing that the keys are sending non-standard keycodes.

Anyways, I was wondering if anyone else has had this problem (and found a solution) before? Is it possible to manually map these keys to another keycode?

I already tried manually setting my keyboard shortcuts in the KDE4 Keyboard configuration module, but it didn’t seem to recognize the F# keys, either.


you could try hitting the blue Fn key to get them to work. I had a similar problem with my Logitech wireless keyboard for my desktop computer. It wouldn’t recognize any of my F# input. Then I thought to test out if the other functions worked, pressed Fn and presto! They worked. Kind of strange actually. But worth a shot if you haven’t already tried that yet.

Good Luck,


Every key pressed generates a scancode, or something like that. These codes are translated into keycodes and, if matching the keycode table in use, will result in X recognizing the key.

You could take a look at: :: Customize your laptop keyboard with X and KDE


Keyboard layout reconfiguration - openSUSE Forums

Thanks guys! I’ll give those a try.