Ushare + Firewall

I have installed and configured ushare on OpenSUSE11. I tinkered with it for a while and could not get the share to show up on my xbox360.

In the configuration I set the default port to 49200. I then opened up port 49200 in the firewall threw YAST. But still the share would not show up on the xbox. I went to router and used port forwarding just to make sure that wasnt the issue, still no share

I found that when i disable the firewall completly ushare pops up instantly on the 360 and i connect and stream video with no problem.

Unfortunatly I could not find anything on google or a ushare forum at all. I know the problem is with my firewall so i am hopeing someone here may help me.

My question is other than going to Allowed Services, then advanced and setting 49200 in both TCP and UDP options (not sure what it uses)what else is there to do to allow this connection?

Also, since were on topic of ushare. I also would like to share my music. I enable it by adding folder music is in for ushare to scan. When start ushare it conferms that it looked and found. But if i go to Music on my 360 it only shows videos… anyone use ushare that had this problem

UGH! I posted and then remembered back to windows, when in doubt…restart… and now that it came back up works with the firewall settings i enabled. Sorry for the wasted thread guys. But i was frustraded as anything else i setup on this server I just enabled in firewall same as i did ushare and had no problems. Thought maybe there is a different or better way to enable things that i dont know about (maybe there still is)

But if anyone has any comments or solutions about why when i go to music on my xbox it is only showing videos there im all ears as ushare does not seem to have good support


Spoke to soon… Did work for about 2 min then video got all garbled then video stoped and xbox gave unable to connect to computer. Firewall may be blocking… So i guess i still have issues (again, just to reinstate- if i turn of firewall i have no issues with connection or stream)

Your firewall must allow multicasting. Ensure that any filtering of multicast messages is disabled. Your UPNP client and server establish their communication via multicast messages. Therefore it worked when you disabled the whole firewall.

Good luck.

im having the same problem on 11.3 but using a ps3 and what is multicasting? i cant find any mention in yast firewall my sharing works with somethings on this but not others