User account refuses keyboard input

openSuse v11.1
Linux 2.6.27.39-0.2-default x86_64
VirtualBox v3.1.0

This is just weird.

One user account completely ignores all keyboard input. No other account demonstrates this bizarre behavior. The faulty account has had occasional keyboard difficulty but it has always been related to the Virtual Machines (VirtualBox); the hosting account always functioned correctly.

Then the ban on keyboard input. Poof! “Keyboard? What keyboard? I don’t see no stinking keyboard!”

It is not the physical keyboard. Three different hardware exhibit the same fault. It is not the motherboard; two mb’s show the same fault. It is only that one account. And I even took the Windows route of re-installing the OS (what a waste of time that was).

If something changed, I am not aware of it (although something must have).

Any ideas where to look? (Remember: I cannot type anything in that account.)

When you boot, try the failsafe option see if it’s better / different.

No change at all.

Am I understanding you correctly. You are taking about a Virtual Machine?

openSuse v11.1
Linux 2.6.27.39-0.2-default x86_64
VirtualBox v3.1.0

openSUSE 11.1 in Virtual Box

What is the Host OS?
Have you installed Guest additions?

No. Linux is the host machine. The behavior exhibits as soon as I am logged in to the faulty account. Obviously the keyboard input is accepted until the account is loaded.

I only mentioned VBox since I do not know what would be relevant. VBox has been running VMs (winxp and os/2) for several months now, although the latest version was put in about 2 or 3 weeks ago.

OK, so do you mean this:

When you run Virtual Box the Host OS keyboard acts up?
But this behaviour is not the same in every user account in the Host?

No. The keyboard problem has only arisen in the one account that uses VMs regularly.

I do not even know that VBox is in any way related to the issue.

But the keyboard issue is in the Host? Not the VM

That is the where the issue exists the keyboard doesn’t work in the Host as opposed to It works in the Host but not in the VM.

And are you saying it only happens when a VM is being used

Yes, the linux host. Forget I ever mentioned VBox or VMs. Proceed from there.

If it is that you have an installation that has more than one user account, one of which has this issue, but the others are fine.

We can assume from this that the problem must be in the user settings and be from the system settings. Therefore, you would do well to look at those settings.
But is it that you can Never use the keyboard or just sometimes?

Please tell me if you use kde4 or gnome?

Which settings in particular? There are a number of places where settings are made.

The keyboard is used heavily.

KDE4.

First make sure you have auto-login disabled:
Disable Auto-Login - openSUSE Forums

At the login screen there should be a Menu at the bottom that offers a Console Login. Go to it and login with your username and password. Hopefully you will be able to use the keyboard to do that and beyond.

I’m about to give you a command to rename a folder, it will start a new kde4 settings/config folder, you can get some settings you may need from the old re-named folder if necessary. Assuming you are logged in under this troublesome username

So here is what to do now - type at the prompt:
mv .kde4 .kde4-old

Now type: startx

Okay, that worked. Of course, all of the settings were gone but it was not hard to recreate the desktop as I had it.

The only question remaining: What setting could possibly disable keyboard input?

Thanks!

It worked! Great. At least that confirms my idea.

Cause? - Well, I don’t know but sometimes something just gets screwed up. It might have neen possible to just do some deleting inside .kde4 but I thought this would be easier.

If you have any settings you REALLY need let me know and I can assist.