Use of setfacl not working as expected

I used setfacl to set permissions as follows:

~/scripts/lib # getfacl files/

file: files/

owner: root

group: root

flags: -s-


As you can see all settings lead to permissions 777 but that’s not what happens. What happens if I say, touch a file, I get: 666 as this shows:

:~/scripts/lib # l files/
total 8
drwxrwsrwx+ 2 root root 4096 2010-06-04 02:28 ./
drwxr-xr-x 3 root root 4096 2010-06-04 02:25 …/
-rw-rw-rw-+ 1 root root 0 2010-06-04 02:23

Same for files that are not obviously scripts such as just a.txt.

My umask is 0022.

Does anyone know why this is? Is it changeable for specific directories?

This is a special world viewed directory required by a piece of software… in other words, no, I am not in a habit of setting file permissions to 777 so please no comments about you shouldn’t be using such permissions.

Truthfully, I can probably get away with permissions 666 and will if I can but right now I just want to know why it’s happening this way and how to control it.

Some of the permissions that result from setfacl are extended permissions and are not visible to ls. They have to be viewed with getfacl.

Sorry to seem to take forever to reply. I got sidetracked in a big way, again, sorry!

That makes sense but I figured that either “user::rwx” or “default:user::rwx” since neither specifies a specific user/group/etc. would map directly to the normal permissions. I wonder if any of these settings then map to the normal permissions that ls reads?

chmod/ls work on the standard Unix permission bits, and setfacl works on the ACLs and the twain will not meet.

I think transfer files from iPod to Mac need iMacsoft iPod to Mac Transfer.
Well,copy files from iPod to PC is easy for me with best software.
And, if you are looking for the best dvd converter, here it is.
Have a good day!

Got it, loud and clear, thanks.