Use non-default screen resolution without KMS

I’m installing OpenSuse 12.2 on some older hardware with an integrated Intel Graphics card which doesn’t support KMS, so I’ve added “nomodeset” in grub. This works OK as long as I use the default resolution of the attached screen (1280x1024).
The problem appears when I want to use an alternative resolution, let’s say 1024x768, how do I do this?
I’ve tried creating a xorg.conf file but then Xorg doesn’t start at all.
I’ve tried editing the 50-screen.conf file in /etc/X11/xorg.conf.d/ but it still loads as 1280x1024
Any other alternatives?

Thanks in advance.

With nomodeset, you should be getting the very basic (limited resolution, 2D only) driver called “fbdev”, by default. You can try the “intellegacy” driver separately packaged, as an alternative.

Or have you already tried it?

The fbdev driver is also a relatively poor performer. more noticeable on old hardware. Intellegacy is just an older version of the “intel” driver packaged by openSUSE. For 12.2 the package name is “xorg-x11-driver-video-intel-legacy”, and the driver version is 2.9.1 with 32bit [and 64bit] available. It should be installed by default, and was so on my 12.2, even though I don’t need it.

You will need to add a driver statement to /etc/X11/xorg.conf.d/50-device.conf, for example:

       Driver "intellegacy"
   After saving the file, you must restart/reboot.

You can inspect the driver’s progress in loading at /var/log/Xorg.0.log (recreated on every boot), and to note any serious errors marked “EE” in the log.

Thanks for this suggestion, I tried this before and it didn’t work. The legacy drivers seem to dump core at some point, I pasted the log file here: SUSE Paste

It’s not a core dump, but a segmentation fault (please excuse my poor choice of words), and it seems to be a know bug:

If only you had mentioned you tried it, in your first post. The english is pretty good. :slight_smile:

Hmm, that bug is from May last year, and still not fixed! If it won’t build, that looks like the end of that driver version on openSUSE at least. I remember the seg fault from an old post, IIRC I got the same result then, but hoped it was fixed by now. I’ve checked Package Search and it just shows the same official source, and 12.2 build results are a mess. It’s not there for 12.3 release.

You may need to consider installing a previous release of openSUSE e.g. 12.1 or 11.4 Evergreen.

How does it fail with the latest (updated) “intel” driver?

Unfortunately that’s not an option, we are trying to “standarise” on only one distribution for all hardware (right now it’s becoming too expensive to maintain 4 versions). The problem is with older hardware (5 or 6 years old).

My current version had xf86-video-intel-2.20.0, I just updated with xf86-video-intel-2.20.3 but it throws the same error:

  4484.103] (EE) No devices detected.
Fatal server error:
  4484.103] no screens found

That’s a shame. I guess that’s old considering the advances in Intel onboard graphics. Is the chipset mentioned in the “intel” driver’s support list (the one visible in the Xorg.0.log, once the driver is loaded?

The only other driver I can think of is the one called “vesa”, again it’s limited but some with graphics hardware better than “fbdev”. It would require a driver statement to replace the other, and check the log to see what you get. It might do better on screen resolutions.

I guess I’ll keep on trying different things. Thank you for all the suggestions and your time.

You are welcome and good luck. If I find anything, it will be posted back here. :slight_smile: