use my modem

i want to set up a dialer on suse 11 kde4 with my dial up modem, my ISP uses PPP (Point-to-Point Protocol) with CHAP (Challenge Handshake Authentication Protocol. what do i need to do>? what packages are on suse 11 for that??

You could use kinternet (kdenetwork3-dialup package) or gnome-ppp. There is also a kde4-kppp dialer package available as well. If you install via yast software magement tool, it will take care of other required dependencies including ppp and smpppd packages.

yeap, kinternet and ppp and smpppd are installed… i just downloaded the xp drivers to my ambit modem… do i need to add the drivers or does suse 11kde4 have linux drivers i can use, where are they and how to install? also adding these modem packages arent going to conflict with my wireless setup?


nothing connects, just one lightning bolt from kinternet icon…
all installed. kinternet, smpppd, ppp… smpppd is on in Runlevel 3 and 5

i didnt add any drivers was hoping suse 11 kde4 did that…

kiniternet log
suse meta pppd (smpppd-ifcfg)version 1.59_svn16 on linux-hthn
status is: disconnected
trying to connect to smpppd
connect to smpppd
status is: disconnected
status is: connected
status is: disconnected
pppd(0) died: pppd option error (exit code 2)

here is my modem
Laptop 56 Kpbs Ambit modem
Vendor ESS technology
Internal PCI bus
ES2828/2839 SuperLink Modem
device identifier (spec) 65568
device identifier 75832
can i use a madwifi driver if so which one, how to install

Your modem device is almost certainly a soft modem, requiring a proprietary driver to be installed first. In many cases, a linux driver does not exist, so often they are unusable. However, if you want to check out if a driver is available, this scanModem utility is worth a shot. Read this Ubuntu howto first. Good luck.

i cant find the modem folder, where does it usually get place? cant find modemdata .txt?
im new to suse 11 so i cant figure out how to find the files, the system tree is too new?
i tried the gedit command but wrong command for suse
here is what i got doing the gunzip scanModem
os@linux-hthn:~/Desktop/RPM> gunzip scanModem.gz
os@linux-hthn:~/Desktop/RPM> chmod +x scanModem
os@linux-hthn:~/Desktop/RPM> ./scanModem
Continuing as this update is only 2 weeks old,
but the current Update is always at: A Linmodems support page
For more details, read ALSA-Configuration.txt.
Identifying PCI bus slots with candidate modems.
Running PCIbus cases
Analysing card in PCI bus 00:09.0, writing to scanout.00:09.0
Using scanout.00:09.0 data, and writing guidance to ModemData.txt
Writing residual guidance customized to your System.
A subfolder Modem/ has been written, containing these files with more detailed Information:

1stRead.txt DOCs ModemData.txt scanout.00:09.0
and in the DOCs subfolder:
DriverCompiling.txt InfoGeneral.txt Rational.txt SoftModem.txt
Testing.txt UNSUBSCRIBE.txt wvdial.txt YourSystem.txt

   Please read 1stRead.txt first for Guidance.

os@linux-hthn:~/Desktop/RPM> gedit Modem/ModemData.txt
bash: gedit: command not found
os@linux-hthn:~/Desktop/RPM> su
linux-hthn:/home/os/Desktop/RPM # gedit Modem/ModemData.txt
bash: gedit: command not found
linux-hthn:/home/os/Desktop/RPM # exit


scanmodem.gz worked but too much info for my new suse user brain

if this helps i found my chipset, 00:09.0 125d:2838 103c:0020 Communication controller: ESS Technology ES2838/2839 SuperLink Modem
Chip Description: Maestro-2 PCI audio accelerator
class =0780
pci dev= 125d:2838
subsys 103c:0020
irq 11
if a proprietary driver, you mean xp drivers i have those for the modem , downloaded them from hp, laptop is hp pavillion zt 1000 ic


if a proprietary driver, you mean xp drivers i have those for the modem , downloaded them from hp, laptop is hp pavillion zt 1000 ic

Unfortunately, you need linux drivers. In many cases they don’t exist. You’re better off purchasing an external (usb) modem, making sure it is on the opensuse hcl first.

If it is a so called winmodem check
if you,re modem better yet the chipset is mentioned there

dobby9 brings me here
doesnt look like a modem site

Give in pretty sure you’ll never get it to work on linux.

linux ESS Technology ES2838/2839 SuperLink Modem - Google Search

Lots of links like this…

ESS Tech ES2838/2839 modem driver -

i know you experts know best
dont want to waste anymore time on it


Sorry miss one s it should be
I am uncertain but speaking out of my memory suse do support some winmodems , can not remember the driver,s name


He meant:

That is where scanModem tool is downloaded from. But, I doubt very much that your modem is supported by any linux driver. I stand by my previous post.