USBBT100 bluetooth adapter in opensuse 11.1

anyone gotten one of these to work in opensuse 11.1? It seems to recognize it fine but no matter what i try i get

hercules:~ # hcitool inq
Inquiring …
Inquiry failed.: Connection timed out

and a corresponding log entry

Mar 12 18:17:05 hercules kernel: hci_cmd_task: hci0 command tx timeout

my system sees it fine

hercules:~ # hciconfig
hci0: Type: USB
BD Address: 00:1A:70:90:DD:DE ACL MTU: 377:10 SCO MTU: 64:8
RX bytes:685 acl:0 sco:0 events:21 errors:0
TX bytes:391 acl:0 sco:0 commands:33 errors:0

I have tried doing

hciconfig hci0 reset
hciconfig hci0 down ; hciconfig hci0 up

nothing seems to get this badboy working. I have an internal bluetooth on the laptop that works fine. We actually got 2 of these in and I’ve tried both on this laptop which is running a rather recent install of 11.1 as well as on another laptop with the opensuse 11.1 livecd.

I tried upgrading bluez package from the latest factory and nogo too.

may have found more information, a review at Linksys USBBT100 Bluetooth USB Adapter : Product Reviews - Review, Compare Prices at says

There are two versions of this device. Version 1 uses the CSR chipset which is fully supported in Linux. The version being sold here is Version 2, which, unfortunately, uses the Broadcom chipset. This Linux drivers for the Broadcom chipset will, apparently, perform all tasks well, except for one: it cannot i…