USB Yast2 Installer freezing while installing packages

Other people were having this same issue, anyone submit it to bugzilla?
Edit: It just seems like a long timeout, don’t know what is causing it though… wifi driver bug?

Now it is stuck at installing bash-doc4.4-102.1noarch.rpm at 100%, 26% of the way through and nothing seems to work.

If others have the same it would be good to post a link to where that is reported.

If you do “zypper ref; zypper verify; zypper dup” I am pretty sure you can interrupt the install process using Ctrl-C.

Updated today and the same issue.

I just made a bug report.

How did you update? Tumbleweed normally cannot have updates applied; it requires a “distribution upgrade” to avoid software incompatibilities.

Your attached log suggests that you were not trying to use YaST > Software Management, but instead a “One-Click” install. In either case you have not to explained what the uninstallable package was.

In the other thread:
you declined to answer my question – whether you were trying to “update” a Live-Snapshot iso image, which could explain the symptoms you have described.

When an OpenSUSE Live USB flash memory device is created the first (approximately) Gigabyte is used make a bootable system with a (read-only) compressed (squashfs) root filesystem. The remainder of the device space is formatted as Ext4 and used by an overlayfs. The overlay is applied to the virtual (RAM) rootfs after the system is running and is useful for /home, /var, /usr/local and some of /etc, etc. Generally applying an overlay to (changing the contents of) /usr/bin, /lib64 and /usr/lib64 etc will generate “zypper ps” warnings. Attempts to change Grub, the kernel and static kernel modules will have no useful effect, as they will not be applied to the /boot files (including Grub configuration) until after the system is running. To update a removable “Live” device you should download and apply a new snapshot.

If my guess (as there has been a lack of clarification so far) is correct, then perhaps Ryan could advise the Bugzilla team?

I was using “xdg-su -c “/usr/bin/”” *aka. “Installation” on the live cd. I had to use the one click install one to install a proprietary blob for wifi network card.

Updated the log file. It gets stuck on rpm install now. This should be a more useful log.

Same bug when I install from DVD image.

Same issue as of today.

You still haven’t answered the question on how you upgrade. Nothing but, repeat nothing but, ‘zypper dup’ is the method to upgrade Tw. As per documentation. The bugreport holds nothing devs could use to fix something.

Just did a zypper dup and rebooted, and yast installation does not work. I have tried thus far:
A new iso for a usb stick
A full dvd to a usb stick
zypper dup to the latest

All are freeze when going into install of the packages in yast2 install. It should not do this, this is a bug.

Try to download a new iso, different from what you have.
I had the same problem and this was the way I solved it.

It works with the snapshot iso, the current iso is broken for the installer under yast2 it gets stuck installing packages.