USB WiFi & Ndiswrapper (11.1)

I’m trying to add a D-Link DWA-120 USB wireless stick to my system. I’ve downloaded ndiswrapper and installed the windows driver through ndisgtk.
ndiswrapper -l finds the device and reports neta5agu : driver installed device (07D1:3A0D) present.

I think that I’ve configured the wireless network through Yast correctly. I’ve dropped the ethernet connection with ifdown eth0 but I can’t get the USB stick to work. iwconfig reports
lo no wireless extensions.

eth0 no wireless extensions.

Any ideas as to what I’ve missed.

Regards

Hi Gilbert,

I think I have the same problem as you, and I think it might be a YaST bug. In order to confirm and make a bugreport, could paste the output of this command (as root) here?
grep ndiswrapper /var/log/YaST2/y2log

I get this:
2009-01-13 08:53:40 <1> kirk(4741) [YCP] LanItems.ycp:229 write udev rules: $]
2009-01-13 08:53:40 <3> kirk(4741) [Interpreter] LanItems.ycp:260 Couldn’t find an agent to handle ‘.mod
probe.network.options.“ndiswrapper”’
2009-01-13 08:53:40 <3> kirk(4741) [Interpreter] LanItems.ycp:260 SCR::Write() failed
2009-01-13 08:53:40 <3> kirk(4741) [Interpreter] LanItems.ycp:262 Couldn’t find an agent to handle ‘.mod
probe.network’
2009-01-13 08:53:40 <3> kirk(4741) [Interpreter] LanItems.ycp:262 SCR::Write() failed
2009-01-13 08:53:40 <1> kirk(4741) [YCP] NetworkInterfaces.ycp:666 Writing configuration

Something similar happening on your machine?

quart wrote:

>
> Hi Gilbert,
>
> I think I have the same problem as you, and I think it might be a YaST
> bug. In order to confirm and make a bugreport, could paste the output of
> this command (as root) here?
> grep ndiswrapper /var/log/YaST2/y2log
>
> I get this:
> 2009-01-13 08:53:40 <1> kirk(4741) [YCP] LanItems.ycp:229 write udev
> rules: $]
> 2009-01-13 08:53:40 <3> kirk(4741) [Interpreter] LanItems.ycp:260
> Couldn’t find an agent to handle ‘.mod
> probe.network.options.“ndiswrapper”’
> 2009-01-13 08:53:40 <3> kirk(4741) [Interpreter] LanItems.ycp:260
> SCR::Write() failed
> 2009-01-13 08:53:40 <3> kirk(4741) [Interpreter] LanItems.ycp:262
> Couldn’t find an agent to handle ‘.mod
> probe.network’
> 2009-01-13 08:53:40 <3> kirk(4741) [Interpreter] LanItems.ycp:262
> SCR::Write() failed
> 2009-01-13 08:53:40 <1> kirk(4741) [YCP] NetworkInterfaces.ycp:666
> Writing configuration
>
> Something similar happening on your machine?
> >
Not exactly - I get
2009-01-11 22:46:26 <1> babylon2(7981) [PoolQuery++] PoolQuery.cc(compile):273 strings: ndiswrapper
2009-01-11 22:46:26 <1> babylon2(7981) [PoolQuery++] PoolQuery.cc(compile):273 compiled strings: ndiswrapper
2009-01-11 23:26:13 <1> babylon2(5306) [YCP] Lan.ycp:220 ndiswrapper: installed
2009-01-11 23:26:13 <1> babylon2(5306) [YCP] Lan.ycp:222 ndiswrapper: configuration found
2009-01-11 23:28:09 <1> babylon2(6673) [YCP] Lan.ycp:220 ndiswrapper: installed
2009-01-11 23:28:09 <1> babylon2(6673) [YCP] Lan.ycp:222 ndiswrapper: configuration found
2009-01-11 23:29:01 <1> babylon2(6810) [YCP] Lan.ycp:220 ndiswrapper: installed
2009-01-11 23:29:01 <1> babylon2(6810) [YCP] Lan.ycp:222 ndiswrapper: configuration found
2009-01-11 23:35:32 <1> babylon2(6810) [YCP] LanItems.ycp:1564 driver ndiswrapper,
2009-01-11 23:35:36 <1> babylon2(6810) [YCP] network/lan/complex.ycp:263 LanItems $[0:$[“hwinfo”:$[“active”:true, “bus”:“pci”, “busid”:“0000:00:0a.0”, “dev_name”:“eth0”, “drivers”:[$[“active”:true, “modprobe”:true, “modules”:[[“natsemi”, “”]]]], “link”:true, “mac”:“00:0f:b5:07:fa:90”, “modalias”:“pci:v0000100Bd00000020sv00001385sd0000F311bc02sc00i00”, “module”:“natsemi”, “name”:“DP83815 (MacPhyter) Ethernet Controller”, “num”:0, “options”:"", “requires”:], “sysfs_id”:"/devices/pci0000:00/0000:00:0a.0", “type”:“eth”, “udi”:"/org/freedesktop/Hal/devices/pci_100b_20", “wl_auth_modes”:nil, “wl_bitrates”:nil, “wl_channels”:nil, “wl_enc_modes”:nil], “ifcfg”:“eth0”, “table_descr”:$“rich_descr”:"<b>DP83815 (MacPhyter) Ethernet Controller</b> <b></b><br><b>MAC : </b>00:0f:b5:07:fa:90<br><ul><li>Device Name: eth0</li><li>Started automatically at boot</li><li>IP address assigned using DHCP</li></ul>", “table_descr”:“DP83815 (MacPhyter) Ethernet Controller”, “DHCP”]], “udev”:$“driver”:"", “net”:“SUBSYSTEM==“net””, “ACTION==“add””, “DRIVERS==”?"", "ATTR{address}==“00:0f:b5:07:fa:90"”, "ATTR{type}==“1"”, "KERNEL=="eth"", “NAME=“eth0"”]]], 1:$“commited”:false, “ifcfg”:“wlanbus-usb”, “table_descr”:$“rich_descr”:”<b>wlanbus</b> <b>(No hwinfo)</b><br><ul><li>Device Name: wlanbus-usb</li><li>Started automatically at boot</li><li>IP address assigned using DHCP</li></ul>", “table_descr”:“wlanbus”, “DHCP”]], “udev”:$“driver”:“ndiswrapper”]]]
2009-01-11 23:35:42 <1> babylon2(6810) [YCP] LanItems.ycp:229 write udev rules: $“ndiswrapper”:“ENV{MODALIAS}==”"", “ENV{MODALIAS}=“ndiswrapper””]]
2009-01-11 23:35:42 <3> babylon2(6810) [Interpreter] LanItems.ycp:260 Couldn’t find an agent to handle ‘.modprobe.network.options.“ndiswrapper”’
2009-01-11 23:37:42 <1> babylon2(8246) [YCP] Lan.ycp:220 ndiswrapper: installed
2009-01-11 23:37:43 <1> babylon2(8246) [YCP] Lan.ycp:222 ndiswrapper: configuration found
2009-01-11 23:37:45 <1> babylon2(8271) [YCP] Lan.ycp:220 ndiswrapper: installed
2009-01-11 23:37:45 <1> babylon2(8271) [YCP] Lan.ycp:222 ndiswrapper: configuration found
2009-01-11 23:38:57 <1> babylon2(8271) [YCP] LanItems.ycp:1564 driver ndiswrapper,
2009-01-11 23:39:33 <1> babylon2(8271) [YCP] LanItems.ycp:1564 driver ndiswrapper,
2009-01-11 23:39:33 <1> babylon2(8271) [YCP] network/lan/complex.ycp:263 LanItems $[0:$[“hwinfo”:$[“active”:true, “bus”:“pci”, “busid”:“0000:00:0a.0”, “dev_name”:“eth0”, “drivers”:[$[“active”:true, “modprobe”:true, “modules”:[[“natsemi”, “”]]]], “link”:true, “mac”:“00:0f:b5:07:fa:90”, “modalias”:“pci:v0000100Bd00000020sv00001385sd0000F311bc02sc00i00”, “module”:“natsemi”, “name”:“DP83815 (MacPhyter) Ethernet Controller”, “num”:0, “options”:"", “requires”:], “sysfs_id”:"/devices/pci0000:00/0000:00:0a.0", “type”:“eth”, “udi”:"/org/freedesktop/Hal/devices/pci_100b_20", “wl_auth_modes”:nil, “wl_bitrates”:nil, “wl_channels”:nil, “wl_enc_modes”:nil], “ifcfg”:“eth0”, “table_descr”:$“rich_descr”:"<b>DP83815 (MacPhyter) Ethernet Controller</b> <b></b><br><b>MAC : </b>00:0f:b5:07:fa:90<br><ul><li>Device Name: eth0</li><li>Started automatically at boot</li><li>IP address assigned using DHCP</li></ul>", “table_descr”:“DP83815 (MacPhyter) Ethernet Controller”, “DHCP”]], “udev”:$“driver”:"", “net”:“SUBSYSTEM==“net””, “ACTION==“add””, “DRIVERS==”?"", "ATTR{address}==“00:0f:b5:07:fa:90"”, "ATTR{type}==“1"”, "KERNEL=="eth"", “NAME=“eth0"”]]], 1:$“commited”:false, “ifcfg”:“wlanbus-usb”, “table_descr”:$“rich_descr”:”<b>wlanbus</b> <b>(No hwinfo)</b><br><ul><li>Device Name: wlanbus-usb</li><li>Started automatically at boot</li><li>IP address assigned using DHCP</li></ul>", “table_descr”:“wlanbus”, “DHCP”]], “udev”:$“driver”:“ndiswrapper”]]]
2009-01-11 23:39:40 <1> babylon2(8271) [YCP] network/lan/complex.ycp:263 LanItems $[0:$[“hwinfo”:$[“active”:true, “bus”:“pci”, “busid”:“0000:00:0a.0”, “dev_name”:“eth0”, “drivers”:[$[“active”:true, “modprobe”:true, “modules”:[[“natsemi”, “”]]]], “link”:true, “mac”:“00:0f:b5:07:fa:90”, “modalias”:“pci:v0000100Bd00000020sv00001385sd0000F311bc02sc00i00”, “module”:“natsemi”, “name”:“DP83815 (MacPhyter) Ethernet Controller”, “num”:0, “options”:"", “requires”:], “sysfs_id”:"/devices/pci0000:00/0000:00:0a.0", “type”:“eth”, “udi”:"/org/freedesktop/Hal/devices/pci_100b_20", “wl_auth_modes”:nil, “wl_bitrates”:nil, “wl_channels”:nil, “wl_enc_modes”:nil], “ifcfg”:“eth0”, “table_descr”:$“rich_descr”:"<b>DP83815 (MacPhyter) Ethernet Controller</b> <b></b><br><b>MAC : </b>00:0f:b5:07:fa:90<br><ul><li>Device Name: eth0</li><li>Started automatically at boot</li><li>IP address assigned using DHCP</li></ul>", “table_descr”:“DP83815 (MacPhyter) Ethernet Controller”, “DHCP”]], “udev”:$“driver”:"", “net”:“SUBSYSTEM==“net””, “ACTION==“add””, “DRIVERS==”?"", "ATTR{address}==“00:0f:b5:07:fa:90"”, "ATTR{type}==“1"”, "KERNEL=="eth"", “NAME=“eth0"”]]], 1:$“commited”:false, “ifcfg”:“wlanbus-usb”, “table_descr”:$“rich_descr”:”<b>wlanbus</b> <b>(No hwinfo)</b><br><ul><li>Device Name: wlanbus-usb</li><li>Started automatically at boot</li><li>IP address assigned using DHCP</li></ul>", “table_descr”:“wlanbus”, “DHCP”]], “udev”:$“driver”:“ndiswrapper”]]]
2009-01-11 23:39:49 <1> babylon2(8271) [YCP] network/lan/complex.ycp:263 LanItems $[0:$[“hwinfo”:$[“active”:true, “bus”:“pci”, “busid”:“0000:00:0a.0”, “dev_name”:“eth0”, “drivers”:[$[“active”:true, “modprobe”:true, “modules”:[[“natsemi”, “”]]]], “link”:true, “mac”:“00:0f:b5:07:fa:90”, “modalias”:“pci:v0000100Bd00000020sv00001385sd0000F311bc02sc00i00”, “module”:“natsemi”, “name”:“DP83815 (MacPhyter) Ethernet Controller”, “num”:0, “options”:"", “requires”:], “sysfs_id”:"/devices/pci0000:00/0000:00:0a.0", “type”:“eth”, “udi”:"/org/freedesktop/Hal/devices/pci_100b_20", “wl_auth_modes”:nil, “wl_bitrates”:nil, “wl_channels”:nil, “wl_enc_modes”:nil], “ifcfg”:“eth0”, “table_descr”:$“rich_descr”:"<b>DP83815 (MacPhyter) Ethernet Controller</b> <b></b><br><b>MAC : </b>00:0f:b5:07:fa:90<br><ul><li>Device Name: eth0</li><li>Started automatically at boot</li><li>IP address assigned using DHCP</li></ul>", “table_descr”:“DP83815 (MacPhyter) Ethernet Controller”, “DHCP”]], “udev”:$“driver”:"", “net”:“SUBSYSTEM==“net””, “ACTION==“add””, “DRIVERS==”?"", "ATTR{address}==“00:0f:b5:07:fa:90"”, "ATTR{type}==“1"”, "KERNEL=="eth"", “NAME=“eth0"”]]], 1:$“commited”:false, “ifcfg”:“wlanbus-usb”, “table_descr”:$“rich_descr”:”<b>wlanbus</b> <b>(No hwinfo)</b><br><ul><li>Device Name: wlanbus-usb</li><li>Started automatically at boot</li><li>IP address assigned using DHCP</li></ul>", “table_descr”:“wlanbus”, “DHCP”]], “udev”:$“driver”:“ndiswrapper”]]]
2009-01-11 23:41:23 <1> babylon2(8271) [YCP] LanItems.ycp:1564 driver ndiswrapper,
2009-01-11 23:41:27 <1> babylon2(8271) [YCP] network/lan/complex.ycp:263 LanItems $[0:$[“hwinfo”:$[“active”:true, “bus”:“pci”, “busid”:“0000:00:0a.0”, “dev_name”:“eth0”, “drivers”:[$[“active”:true, “modprobe”:true, “modules”:[[“natsemi”, “”]]]], “link”:true, “mac”:“00:0f:b5:07:fa:90”, “modalias”:“pci:v0000100Bd00000020sv00001385sd0000F311bc02sc00i00”, “module”:“natsemi”, “name”:“DP83815 (MacPhyter) Ethernet Controller”, “num”:0, “options”:"", “requires”:], “sysfs_id”:"/devices/pci0000:00/0000:00:0a.0", “type”:“eth”, “udi”:"/org/freedesktop/Hal/devices/pci_100b_20", “wl_auth_modes”:nil, “wl_bitrates”:nil, “wl_channels”:nil, “wl_enc_modes”:nil], “ifcfg”:“eth0”, “table_descr”:$“rich_descr”:"<b>DP83815 (MacPhyter) Ethernet Controller</b> <b></b><br><b>MAC : </b>00:0f:b5:07:fa:90<br><ul><li>Device Name: eth0</li><li>Started automatically at boot</li><li>IP address assigned using DHCP</li></ul>", “table_descr”:“DP83815 (MacPhyter) Ethernet Controller”, “DHCP”]], “udev”:$“driver”:"", “net”:“SUBSYSTEM==“net””, “ACTION==“add””, “DRIVERS==”?"", "ATTR{address}==“00:0f:b5:07:fa:90"”, "ATTR{type}==“1"”, "KERNEL=="eth"", “NAME=“eth0"”]]], 1:$“commited”:false, “ifcfg”:“wlanbus-usb”, “table_descr”:$“rich_descr”:”<b>wlanbus</b> <b>(No hwinfo)</b><br><ul><li>Device Name: wlanbus-usb</li><li>Started automatically at boot</li><li>IP address assigned using DHCP</li></ul>", “table_descr”:“wlanbus”, “DHCP”]], “udev”:$“driver”:“ndiswrapper”]]]
2009-01-11 23:44:02 <1> babylon2(8246) [YCP] LanItems.ycp:1564 driver ndiswrapper,
2009-01-11 23:44:06 <1> babylon2(8246) [YCP] network/lan/complex.ycp:263 LanItems $[0:$[“hwinfo”:$[“active”:true, “bus”:“pci”, “busid”:“0000:00:0a.0”, “dev_name”:“eth0”, “drivers”:[$[“active”:true, “modprobe”:true, “modules”:[[“natsemi”, “”]]]], “link”:true, “mac”:“00:0f:b5:07:fa:90”, “modalias”:“pci:v0000100Bd00000020sv00001385sd0000F311bc02sc00i00”, “module”:“natsemi”, “name”:“DP83815 (MacPhyter) Ethernet Controller”, “num”:0, “options”:"", “requires”:], “sysfs_id”:"/devices/pci0000:00/0000:00:0a.0", “type”:“eth”, “udi”:"/org/freedesktop/Hal/devices/pci_100b_20", “wl_auth_modes”:nil, “wl_bitrates”:nil, “wl_channels”:nil, “wl_enc_modes”:nil], “ifcfg”:“eth0”, “table_descr”:$“rich_descr”:"<b>DP83815 (MacPhyter) Ethernet Controller</b> <b></b><br><b>MAC : </b>00:0f:b5:07:fa:90<br><ul><li>Device Name: eth0</li><li>Started automatically at boot</li><li>IP address assigned using DHCP</li></ul>", “table_descr”:“DP83815 (MacPhyter) Ethernet Controller”, “DHCP”]], “udev”:$“driver”:"", “net”:“SUBSYSTEM==“net””, “ACTION==“add””, “DRIVERS==”?"", "ATTR{address}==“00:0f:b5:07:fa:90"”, "ATTR{type}==“1"”, "KERNEL=="eth"", “NAME=“eth0"”]]], 1:$“commited”:false, “ifcfg”:“wlanbus-usb”, “table_descr”:$“rich_descr”:”<b>wlanbus</b> <b>(No hwinfo)</b><br><ul><li>Device Name: wlanbus-usb</li><li>Started automatically at boot</li><li>IP address assigned using DHCP</li></ul>", “table_descr”:“wlanbus”, “DHCP”]], “udev”:$“driver”:“ndiswrapper”]]]
2009-01-11 23:44:08 <1> babylon2(8246) [YCP] LanItems.ycp:229 write udev rules: $“ndiswrapper”:“ENV{MODALIAS}==”"", “ENV{MODALIAS}=“ndiswrapper””]]
2009-01-11 23:44:08 <3> babylon2(8246) [Interpreter] LanItems.ycp:260 Couldn’t find an agent to handle ‘.modprobe.network.options.“ndiswrapper”’
2009-01-11 23:45:11 <1> babylon2(9962) [YCP] Lan.ycp:220 ndiswrapper: installed
2009-01-11 23:45:11 <1> babylon2(9962) [YCP] Lan.ycp:222 ndiswrapper: configuration found
2009-01-11 23:52:54 <1> babylon2(5491) [YCP] Lan.ycp:220 ndiswrapper: installed
2009-01-11 23:52:54 <1> babylon2(5491) [YCP] Lan.ycp:222 ndiswrapper: configuration found
2009-01-11 23:52:56 <1> babylon2(5527) [YCP] Lan.ycp:220 ndiswrapper: installed
2009-01-11 23:52:56 <1> babylon2(5527) [YCP] Lan.ycp:222 ndiswrapper: configuration found
2009-01-11 23:53:46 <1> babylon2(5491) [YCP] LanItems.ycp:1564 driver ndiswrapper,
2009-01-11 23:56:07 <1> babylon2(5491) [YCP] network/lan/complex.ycp:263 LanItems $[0:$[“hwinfo”:$[“active”:true, “bus”:“pci”, “busid”:“0000:00:0a.0”, “dev_name”:“eth0”, “drivers”:[$[“active”:true, “modprobe”:true, “modules”:[[“natsemi”, “”]]]], “link”:true, “mac”:“00:0f:b5:07:fa:90”, “modalias”:“pci:v0000100Bd00000020sv00001385sd0000F311bc02sc00i00”, “module”:“natsemi”, “name”:“DP83815 (MacPhyter) Ethernet Controller”, “num”:0, “options”:"", “requires”:], “sysfs_id”:"/devices/pci0000:00/0000:00:0a.0", “type”:“eth”, “udi”:"/org/freedesktop/Hal/devices/pci_100b_20", “wl_auth_modes”:nil, “wl_bitrates”:nil, “wl_channels”:nil, “wl_enc_modes”:nil], “ifcfg”:“eth0”, “table_descr”:$“rich_descr”:"<b>DP83815 (MacPhyter) Ethernet Controller</b> <b></b><br><b>MAC : </b>00:0f:b5:07:fa:90<br><ul><li>Device Name: eth0</li><li>Started automatically at boot</li><li>IP address assigned using DHCP</li></ul>", “table_descr”:“DP83815 (MacPhyter) Ethernet Controller”, “DHCP”]], “udev”:$“driver”:"", “net”:“SUBSYSTEM==“net””, “ACTION==“add””, “DRIVERS==”?"", "ATTR{address}==“00:0f:b5:07:fa:90"”, "ATTR{type}==“1"”, "KERNEL=="eth"", “NAME=“eth0"”]]], 1:$“commited”:false, “ifcfg”:“wlan0”, “table_descr”:$“rich_descr”:”<b>Wireless Network Card</b> <b>(No hwinfo)</b><br><ul><li>Device Name: wlan0</li><li>Started automatically at boot</li><li>IP address assigned using DHCP</li></ul>", “table_descr”:“Wireless Network Card”, “DHCP”]], “udev”:$“driver”:“ndiswrapper”]]]
2009-01-11 23:56:14 <1> babylon2(5491) [YCP] LanItems.ycp:229 write udev rules: $“ndiswrapper”:“ENV{MODALIAS}==”"", “ENV{MODALIAS}=“ndiswrapper””]]
2009-01-11 23:56:15 <3> babylon2(5491) [Interpreter] LanItems.ycp:260 Couldn’t find an agent to handle ‘.modprobe.network.options.“ndiswrapper”’
2009-01-11 23:57:54 <1> babylon2(8138) [YCP] Lan.ycp:220 ndiswrapper: installed
2009-01-11 23:57:54 <1> babylon2(8138) [YCP] Lan.ycp:222 ndiswrapper: configuration found
2009-01-12 00:07:23 <1> babylon2(11572) [YCP] Lan.ycp:220 ndiswrapper: installed
2009-01-12 00:07:23 <1> babylon2(11572) [YCP] Lan.ycp:222 ndiswrapper: configuration found

2009-01-11 23:56:15 <3> babylon2(5491) [Interpreter] LanItems.ycp:260 Couldn’t find an agent to handle ‘.modprobe.network.options.“ndiswrapper”’

Same message there as in my logs. I have filed a bugreport for it here:
https://bugzilla.novell.com/show_bug.cgi?id=465931

I will report back on it once the bug has been closed in the bugtracker.

Use the Driver from the CD in the Vista Folder, modprobe it and it should go smoothly

“Courage is the Magic that turns Dreams into Reality”