USB storage problems

Hi guys,

New to OpenSuse. Running 13.2…

I have 400+ GB of pics on a USB hard drive. I also have a backup hard drive with a copy of those files. The drive is mounted and accessible…and both worked as I have bounced between Ubuntu derivatives.

My problem. Digikam will read the drive and will create a collection. I can see my photos…the next time I start digikam it immediately tells me that it can’t find my collection.

I deleted the database file so that digikam will rebuild it. I changed the collection from a removable collection to a local collection. I also have tried to use the other backup drive as the home of the collection. I have managed to get the collection back, but this problem manifests again after restart.

Today I got fed up and installed Picasa through Wine…same exact issue popped up. Picasa read my HD and displayed my pics. After restart no pics were available. I went into folder manager and neither USB HD was displayed even though they were displayed right after install. Both drives were mounted and accessible.

I have used both programs successfully in the past. Advice?

Shawn

Sounds like mount issue of you don’t see them in the File Manager. USBs when first entered do not auto mount you will get a desktop hardware notification and you can open in a FIle Manager or other program this then mounts it. You can of course change the default behavior but need to know which desktop???

As gogalthorp says, it is a mount issue.

Before you launch digiKam, launch your file manager and make sure the drive with the photos and albums is mounted. After it is mounted, then launch digiKam. It needs the disk mounted before it launches in order to verify your last configuration.

I’m sorry that I wasn’t clear. They are mounted and accessible in Dolphin. It is only within the two photo managment programs am I having trouble.

After you see them in dolphin do the program then work. Note these are two completely different programs one being a Windows based one. So both having a problem points to a misunderstanding on how mount works. Removable drives are not mounted until you access them via some system method ie the browser or Device notifier.

Before doing anything first see if the drives you are using for the pics are really mounted in a konsole type mount this will list the mounted entities. Then browse the files via Dolphin look again at mount. You will now see that they are mounted and you should be able to get the pic program to work.

Ok…please explain this. I can see and access the files in Dolphin, but both Digikam & Picasa are having similar issues. While in XXXbuntu It has always just worked… How does mount work differently here?

I mounted the HD in Konsole as instructed…and my collection is restored…which brings me back to your first point…I am clearly ignorant here…

Thanks for taking the time…

Shawn

By default USB devices are NOT mounted on insertion in openSUSE.

Assuming KDE go to Configure Desktop - Removable devices and check box **enable automatic mounting
**
This is a security measure so if you want to bypass it is your choice.

If the usb is always plugged in then maybe you want to add it to the /etc/fstab If so use the nofail option to keep form failing if not plugged