USB stick's 3 "undeletable" directories.

You can use the dd ‘status=progress’ option to get some feedback while it is active.

After another couple of hours when i checked Konsole again, i discovered this:

gooeygirl@linux-Tower:/media/veracrypt2> **sudo blkid**
[sudo] password for root: 

/dev/sdc1: LABEL=“SanDisk_ExtremePro” UUID=“3690848A13C24128” TYPE=“ntfs” PARTUUID=“0008e9e6-01”
/dev/mapper/veracrypt2: UUID=“389896A298965DE6” TYPE=“ntfs”

gooeygirl@linux-Tower:/media/veracrypt2> sudo dd if=/dev/zero of=/dev/mapper/veracrypt2
[sudo] password for root:
dd: writing to ‘/dev/mapper/veracrypt2’: No space left on device
209714689+0 records in
209714688+0 records out
107373920256 bytes (107 GB, 100 GiB) copied, 12813.3 s, 8.4 MB/s

So, still in the spirit of idle curiosity, i’m tossing up now whether to repeat the command on the actual stick itself [ie, [i]/dev/sdc1], or alternatively try to format it, then inspect the wreckage afterwards to see what is left. I also acknowledge that i don’t understand the proper interpretation of that command output above. Is the fact of the records count differing by [only?] 1 evidence of a catastrophically damaged device, or instead of a device that still is in fair condition?

That output looks okay to me. Why not format it and put to the test again?

Thanks deano [btw, this arrangement of you living just over the ditch from me works great during daytimes wrt you kindly giving me timely replies].

Cool command – thanks, i look fwd to trying it.

By “format it and put to the test again”, do you mean that post-format i should simply begin using it as normal for my backups [ie, a “real life test”], or do you mean instead to do the dd bizzo on it? I suspect you mean the latter. If so, & if i get similar output again, does that mean the stick IS serviceable without further to-do [if so, do i then need to reformat again post-dd before creating a new VC volume?]? I did read the dd man page, but it speaks at the micro scale whereas i don’t grasp the big-picture of that command.

Yes, I wish we had more members from this side of the equator! :slight_smile:

By “format it and put to the test again”, do you mean that post-format i should simply begin using it as normal for my backups [ie, a “real life test”], or do you mean instead to do the dd bizzo on it? I suspect you mean the latter.

The ‘dd’ command was used to wipe the device at a low-level. I actually meant install a file system on it again.

I think this would have been a better idea - zero the device itself rather than the encrypted partition.

Got it. Now done:

gooeygirl@linux-Tower:/run/media/gooeygirl> **sudo blkid**
[sudo] password for root: 

/dev/sdc1: LABEL="SanDisk_ExtremePro" UUID="3690848A13C24128" TYPE="ntfs" PARTUUID="0008e9e6-01"

gooeygirl@linux-Tower:/run/media/gooeygirl> **sudo dd 'status=progress' if=/dev/zero of=/dev/sdc1**
128025813504 bytes (128 GB, 119 GiB) copied, 13822 s, 9.3 MB/s
dd: writing to '/dev/sdc1': No space left on device
250064562+0 records in
250064561+0 records out
128033055232 bytes (128 GB, 119 GiB) copied, 13822.9 s, 9.3 MB/s

Opinions, pls?

Opinions don’t count in ICT :D, we love booleans.

I would have dd’t the actual device, not a partition. So

dd if=/dev/zero of=/dev/sdc bs=1M count=100

where I add the bs= option to set the block size of writing ( 1 MB ) and count= to set the number of blocks to write. This combo makes sure the partition table is destroyed completely and allows the stick to be repartitioned and have filesystems on the new partitions.
From the other side of the equator, but timely I hope :slight_smile:

Yeh… but… I always thought an opinion was analogous to the high impedance state in tri-state logic; effectively disconnected :stuck_out_tongue:

Yes, but even then your ‘opinions’ can be ‘biased’ with a pull-up or pull-down resister lol!

+1 to Knurpht’s advice.

Whoohah …

Thanks for this. It’s now my Wed mid-morning, but i did actually see your reply very late last night. I immediately tried it, & was so upset at what i discovered [NOT upset at your advice, but at what my naughty stick has now done], but too tired to think clearly, so i decided to look again after some sleep.

gooeygirl@linux-Tower:~> **sudo blkid**[sudo] password for root: 

/dev/sdc1: PARTUUID="0008e9e6-01"

gooeygirl@linux-Tower:~> **sudo dd 'status=progress' if=/dev/zero of=/dev/sdc bs=1M count=100**
100+0 records in
100+0 records out
104857600 bytes (105 MB, 100 MiB) copied, 0.026515 s, 4.0 GB/s

This is what Dolphin showed me after earlier running “deano’s” command, & continued to show me after “your” command [ie, the now-obliterated 100 GB VeraCrypt volume on the stick seems never to have “given back” its space; my 128 GB stick became a 17 GB stick. But wait, it gets even worse, read on…]:

Now this morning, having unmounted & removed the stick from Tower, upon reinserting it Tower no longer even detects it. Sigh. I booted up Lappy & tried it there… also nothing at all. Expletives.

PS - I hope my thanks to deano for fast replies was not accidentally construed by any other Mods as insulting them. Everyone here is wonderful re help & i did not intend to imply otherwise. It’s just that i was kinda sharing some antipodean wry humour about us being in an apparent latitudinal minority here. :slight_smile:

Those commands will wipe the file system and the partition table if successful so you must re partition and establish a new file system. That assumes that the device still works :open_mouth:

Yes i knew/know that, thanks… but possibly what i failed to understand is that a consequence of that is that neither pc now even knows that the stick is inserted in a(ny) USB port. If the stick is not detected by the OS, how can i proceed to do those important next steps you described?

EDIT: Ah, more coffee needed. Answer = GParted. I’m a dope.

Yay, thanks so much all, in each timezone!]. Post-gparted, with creating msdos partition table then new ext4 partition, Dolphin [of course] now sees the stick. It claims it has “110.8 GB free of 116.9 GB (5% used)”. Is it right for me to conclude that the “missing” space [it is / was notionally a 128 GB stick, once] is the result of the unserviceable blocks gogalthorp previously described?

Yes, if it doesn’t have a filesystem on it then you won’t get notified, but low-level utilities should still enumerate it eg

fdisk -l

and it will be reported by the kernel (as a block device) when first attached…