USB Soundcard - Seems to be recognized but not getting sound

As my laptop only supports stereo analog output and HDMI for the surround stuff… but which is really expensive to find a converter for that hooks up to my audio set… I’ve bought an external soundcard (a Sweex SC004v2, yeah I know… sweex).

Anyways… it seems to be recognized as it’s showing up under the KDE4 mixer as USB sound device, however I didn’t get any sound out of it yet. With my desktop where I’ve 2 soundcards as well (PCI and onboard) I could at least test if they worked via Yast control Center > Hardware > Sound
This USB one however fails to show up there.](
Sorry about the huge screenshot, just there to show more info… but I’m working dual monitor atm and am too lazy to cut the irrelevant part off… or to make two screenshots, one of each window.

sigh So much for being lazy…
If I unfold “Drivers” it shows
Active: Yes
modprobe: Yes

and if I unfold modules (under Drivers)
modprobe snd_usb_audio

Resources unfold shows:
speed: 12000000

Does that mean it works now?

If it does not work, please install “alsa-firmware” if it is not installed yet, and then reboot. Then after the reboot, when your USB sound device is plugged in, if running openSUSE-11.1, please run the script (and post here the URL it provides when run) from a gnome-terminal or a konsole with your PC connected to the Internet:

if using 11.0 or older, please copy and paste the following script (and post here the URL it provides when run) from a gnome-terminal or a konsole with your PC connected to the Internet:

wget -O && bash

Next time, also, please specify what openSUSE version you are using. It would save me have to type twice as much. Thankyou. :slight_smile:

No it doesn’t, just noticed it was missing in the screenshot as they’re folded up

I really oughta know better by now as I’m spamming like mad the last 2 days.
Better late than never, openSUSE 11.1 x86_64 / KDE 4.1.

Something is definitively working as I’m getting a lot of static noise which is gone when I mute “Speaker” or “Speaker 2” in kmixer

Guess alsa was only to create the report url thingy? As I’d like to uninstall it when I’m done, seems to have killed off the sound under Amarok 2… and smplayer fails as an audioplayer :slight_smile:

I note an alsa bug report on this sound device:

Guess it’s being worked on then, can’t view the page and I don’t feel like signing up for yet another site just to be able to.

Okay old thread… but update!

The soundcard is now working, in smplayer I can select
Options > Preferences > General > Audio
Output driver: alsa(1.0 - USB Sound Device).

And I’m getting sound out of it, hooray.
Now I just got the problem of having to find my optical spdif cable… buying a new one is kinda pricey.

I’ll update the HCL after I toyed around with a bit more.

It’s doing some awfully strange things…

Mp3 and WMA play fine with my receiver set to “Fourpoint” as I hooked it up via normal analog cables.
Any other settings like ‘stereo’ is completely silent… normally that just sends the signal only to the frontspeakers.

Anything with a video included sounds like it’s voiced by chipmunks, don’t know if smplayer is too blame or the soundcard.

Can’t find any other application which allows me to select the sound thing it uses, and everything defaults to my onboard.
Can’t change the default device either, both alsaconf and YaST > Sound don’t show the USB card… kmix does show it.

Is there any to start an application in a way it’s forced to use
“alsa(1.0 - USB Sound Device )”?

Mmmh also got a sound out of it using “Analog in / line” on the receiver, very very weak though… have to max out the receivers volume to barely hear anything.
(Normally with the volume up this high I’d have an argument with the neighbours)

Might be of help to know my soundset is an ancient Cambridge Soundworks DTT3500, manual can be obtained from Cambridge Soundsworks Manuals (bottom of the page)

Mmmh after some more testing I noticed not ALL of my mp3s are without problems…

So I compared files that are working, to those that don’t… and it seems that those with a rate of 48000Hz gain all kinds of funky effects.
44100Hz ones are fine.

Okay noticed the bug report has a view as guest option… and that pretty much described the 48KHz problem :slight_smile: and a fix… that should have hit in kernel2.6.27.3?
I’m on and still have the bug…

As of 11.2 Milestone 7 (perhaps earlier, had given up already) this card is functional! At least via the analog connectors. Can’t test the spdif yet.

Thanks for the update!