USB Sound cards anyone got one working?


I’m in the market to buy a USB sound card for my SUSE 10.3 installation. I’m trying to go through the list of support ones on the ALSA website and then trying to find one I can buy.

To help me out has anyone already got a USB sound card working (easily) on SUSE 10.3 and if so what make and model was it?

Some openSUSE have their USB sound cards working … but unfortunately, not one of them has updated the openSUSE hardware compatibility list:
HCL/Sound Cards - openSUSE

I have a Xitel HiFi-Link Xitel Precision Audio Technology and I got it working without much problems (most problems arose when I wanted to tell multimedia programs to use the Xitel and not the build-in soundcard).

When you decide to by this one you can ask me for more information. When you decide to bye another on, you can do likewise (maybe my Xitel expirience can help you with another brand).

Ahum, I am afraid you mean me (among others).

But that is something new to be learned. There isn’t even an USB table there. Not easy for me to do that quickly I am afraid.

I managed to login there. I now see an (empty) USB list. Something wrong with my eyes???

In case anyone is willing to share their USB sound card experience on the openSUSE hardware sound wiki, I updated that page, created a “USB” sound card blank table, … and I also added a column for PCI, motherboard, and USB for openSUSE-11.0.
HCL/Sound Cards - openSUSE

If anyone is struggling with the wiki syntax, but is still willing to pass on some small details on their success (per the table in the HCL/Sound Cards - openSUSE page), you can send your USB sound card details to me by PM, and I’ll update the wiki page for you.

No, … I’m GUILTY!! :eek: As charged!! :smiley:

I forgive you. I also wondered about the 11.0. That is sweating when you try this for the first time and somebody is changing the rules under your very eyes/fingers. :confused:

But I succeeded :smiley: Now i will try to recap what I did installing it so I can add some details tomorrow.

You are never to old to learn something aren’t you :slight_smile:

Thank you for doing the update!! You just made the FIRST ENTRY in the openSUSE wiki sound page for USB. Well Done!!

Apologies for the rule change. … them’s one of the risk of wiki edits. :rolleyes: … But wait until all the 11.0 users (hopefully) start updating the wiki pages. :eek: There should be some “rule changes” then. :smiley:

Thanks for the heads up on the HiFi-Link hcw. Can you plug Pc speakers directly into this, or do you have to go via a HiFi.

Has anyone else got any success stories for USB sound cards on SUSE 10.3? Remember to fill in the list at:

HCL/Sound Cards - openSUSE


Not into the speakers. It has a high quality audio cord that goes to your stereo. We listen to internet radio through the Xitel to our normal stereo. Even having the PC in another room (the cable is about 10m and the USB cable adds to this, but you need a secure place to put the Xitel ‘halfway’, so nobody steps on it).
I think their website tells it all (did you see I put a link in my first post?).

ahhh I see. I’m really after a bog standard sound card. But due to limitations of my hardware (i.e. its a Proliant server ML110 with none standard PCI slots) I have to find a USB sound card/device that i can get working with SUSE 10.3 - my search continues…:eek:

I thought I’d try a Creative Blaster Connect (USB sound device) this also does not work :confused::confused:

I had to look on the ALSA site and they do list the “Creative Blaster Connect” but there are no details under “Driver”. Does this means its supported or not? Other unsupport devices are noted in the Notes.

My SUSE box does pick up the device if I run lsusb but when going into YaST - HARDWARE - SOUND it says “No card found”.

The other thing I noticed is that ALSA is on 1.0.16 according to the web site, but my TaST repository shows the latest version as 1.0.14 - Is there any way to fix this? Or how to I manually install the latest ALSA?

I do not know if yoy did with YaST as I suggested for the Xitel in the HCL, so I will repeat that here.

If YaST > Hardware > Sound does not recognise it, so click Add and then choose Generic in the first column, That will give you but one optione in the second: USB Audio, select and cary on.

Scratch that last post. I noticed in the HCL list that the xitel USB sound card worked by “Add in YaST with “Sound card vendor: Generic” and “Sound card model: USB Audio”. Driver used: snd-usb-audio.”.

I did this to my Creative Blaster Connect and it works!! :):slight_smile:

I’ve updated the HCL with this info.

CONGRATULATIONS on getting this to work, and thankyou for sharing your solution!

Many thanks for updating the HCL!

I the old forum I happened to help one guy with the same solution (don’t which sound-card). He said: “how stupid, it is so easy”. But it is only easy as you know where to look. I think this might work for many USB sound-cards, but how should one tell the world!

Anyhow concrats and enjoy the music :cool: .

O, and please scrib, before we forget, could you please add the hex codes for vendor and card-type to the HCL in the same way as I did it, between ()?

This are the numbers you get with **lsusb **like 0bda:0111. Before the : is the vendor enad after it the card.

OK done - I wondered what they were. Are they some sort of unique code for the card? :confused:

Yes they are. And even when people do not exactly know what they have (after all the box may be thrown away, the vendor may have a newer type selling it the same as the earlier one being internaly different, etc) the lsusb tells it all. Well it should when vendors do this coorectly.