usb problem on sony vaio/suse 11.1

I installed suse 11.1 on my vgn fs715 w and am resolving display and sound issues. Now i’ve discovered that when i connected my external harddrive (pics, music) via usb, i get an error that the drive cannot be mounted (or read).

Any suggestions would be much appreciated. Thanks to this forum, i’ve solved my display issue, am getting to the bottom of my sound issue, and hoping to cure this one!

This should not happen.

What desktop are you using? KDE-3.5.10 ? KDE-4.1.3 ? KDE-4.2.x ? KDE-4.3 ? Gnome? Xfce ? Other ?

When the drive is NOT connected, type in a konsole/terminal:
**df -Th
su -c ‘fdisk -l’ **#note that is a lower case “L”
and then plug in your drive and send the same 2 commands again.

Is there a difference? If so, post here the output of the second time you ran those commands.

Note if the external drive is formatted as NTFS, which is very common, it is important that it is removed properly from MS-Windows. If that is not done, openSUSE Linux will not properly access the drive. So restart to MS-Windows (or take the drive to an MS-Windows PC), plug the drive in, and then using the icons in the lower right corner of MS-Windows, unmount the drive properly in Windoze. Then physically remove the drive. Its also possible the drive needs to have the MS-Windows program “chkdsk /f” (or something like that - I am pathetic with Windoze) run from MS-Windows, to clean up errors n the drive.

hey, that was easy! i wasn’t sure what ‘unmount’ from windoze meant, but i hooked to an xp machine, and i could either ‘safely remove hardware’ or ‘disable’. i tried disable first, then hooked to my suse laptop and i can access the file.

ok, i notice i have no file associated with mp3 files. probably in disabling/removing pulseaudio, i disabled/removed a media player. any advice on one that won’t mess up my audio config since we just got that working?

I’m puzzling over what you mean here.

Do you mean no “application” associated with mp3 files?

I typically play mp3 files with amarok, although on occasion I’ll play them with smplayer, xine, or vlc (or even xmms).

yes, exactly. i could find no application installed that would play an mp3 file. i looked around and tried aqualung, and it’s working. i’m sure there are others i may like better, but i’ll start with having everything WORK first, then learn more and find applications that better match my needs.

speaking of vlc, that is what i used with my xp (and liked it). i found and installed it on here, and when it was done installing, it asked if i wanted it to autostart, then gave me an error saying the autostart part can’t be found. not sure if the install failed. not working

If you mix videolan and packman repositories you will quite possibly end up with all sorts of multimedia problems and things not working.

IMHO is best to install only libdvdcss from videolan and NOTHING else. AFter installing libdvdcss from videolan, REMOVE the videolan repository, and only use the Packman repository (and also OSS, Non-OSS, Update and Packman repositories). If you have already installed more repositories and installed a mix of apps from various repositories, it could be an up hill battle to sort things out.

I’ve tried to warn new users of this in post#5 in our stickie: NEWBIES - Suse-11.1 Pre-installation – PLEASE READ - openSUSE Forums