USB Mouse Issues

Hi all! I’m on OpenSUSE 12.3 and I have a minor problem with my USB mouse. Every time I start up, the USB mouse won’t work unless I unplug and replug it into my laptop again, then it works perfectly. However, I have no problems with the laptop touchpad. The mouse issue doesn’t seem to be a problem with OpenSUSE 13.1. Does anyone know a fix for this? My mouse is a Logitech M325. Thanks!

I’m using an M325 on my laptop, and I do not have that problem. I did not have a problem with 12.3, and I do not have one with 13.1

That doesn’t help you, of course. But perhaps it helps narrow things down. A pure guess is that the USB drivers in 12.3 are not handling your hardware (perhaps the USB host adapter) as well as they should.

Hi, I use openSUSE 12.3 also and I have an issue with my touch pad. I found something during my troubleshooting that may help you. First, I have a question, Have you tried to locate your mouse in the list? (On KDE) Kickoff > Computer > YaST Control Center > [passwd] > Mouse: Scroll the list of Mouse Configs, yours may be listed. I think you can figure the rest from here. If you are not sure of which configuration fits yours, do the same steps up to passwd but select Hardware Information.

If there is anyone that can help us: My issue is the track pad. I cannot scroll manually without holding down left-click and moving the scroll bar location. Basically, I want to use my track pad slider instead of the task mentioned above.


Keyboard (according to openSUSE 12.3) = AT Translated Set 2 keyboard /dev/input/event0 / Hwcfg Bus: ps2
Mouse (according to openSUSE 12.3) = SynPS/2 Synaptics TouchPad (/dev/input/mice)

dajmcd@linux-fqxq:/dev/input> ls by-path
**platform-i8042-serio-0-event-kbd ** platform-i8042-serio-1-mouse
platform-i8042-serio-1-event-mouse platform-pcspkr-event-spkr

If I understand you correctly, you want to enable vertical scrolling.

Have you tried configuring via the KDE desktop utility?

System Settings >> Input Devices >> Touchpad, navigate to ‘Scrolling’ and configure as you like.

Hi, Thank you for the feedback and assistance. However, my setup is a bit different from the description you suggested. I was able to fix the issue with the following:

[Kstart >> Applications >> System >> Configuration >> Touchpad Management: in Tab [Touchpad configuration] choose [scrolling] and then configure the settings as wanted.

This applied to: openSUSE 12.3.11 (Dartmouth) KDE Platform Version 4.10.5 “release 1”

Yep, effectively the same tool (same confgi layout). Either way works.