USB mouse is not working normally


Recently I found my mouse on my laptop hp520 with opensuse 11.1 installed is not working normally, that’s, it’s super slow when moving the cursor on the desktop, but the touch pad works well.

I tried the mouse on the other computers, it’s fine; and I tried a nice mouse on this laptop, same problem could be found.

If the laptop is started the first time each day and with the mouse inserted into the usb port, it could be very slow for the booting. It seems that taking a lot of time detecting usb device, and decreases the fast usb to slow one, based on the booting log. but with the second reboot, it could be very fast, though the mouse is still not working well, very slow, it looks.

It seems my laptop is also very slow to render the GUI since the rotating icon stays even more than 3 minutes. The browser firefox is also taking long time to be started.

Frankly speaking, I don’t known when it started to do bad work, but it’s not working after I have a hard turn off (pressed the turn off button more than 1 minute).

So is there any quick solutions for me to find the problem? hardware or software?

hp520, opensuse 11.5