usb mouse freeze

I’m pretty convinced that my recently installed Logitech lx3 usb mouse is freezing periodically. At first thought it was an entire system freeze but noticed disk activity last time, and recalled a forum post of a long time ago that I cannot locate now where someone replaced the usb mouse with the standard ps/2 version and was good to go afterwards.

I’m using an old ps/2 mouse now and have not had a hangup yet.

Do I have a defective mouse or is this a known problem with usb mice ?

No known issues that I know of.

Process of elimination = try different mouse, wait, observe, report:)

Yes, in that phase now (different mouse - ‘old’ ps/2).

Will do this for a week or two then report… and if no known issues exist then I must have a defective mouse.

Just realized that I have an identical mouse on another pc… so swapped them. This system exhibited the lock up right away… so not a defective mouse.

Am I missing something here with the usb mouse support ? The old ps/2 model is working fine.

Please post this:

cat /etc/X11/xorg.conf

I will say that since my last post I have been experimenting with Yast, trying to find the right model for Logitech. I have a LX3, but it isn’t listed, so am hoping there is an equivalent.

Thank you for your assistance…


SaX generated X11 config file

Created on: 2009-09-18T19:14:38-0700.

Version: 8.1

Contact: Marcus Schaefer <>, 2005

Contact: SaX-User list <>

Automatically generated by [ISaX] (8.1)


Section “Files”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/local”
FontPath “/usr/share/fonts/75dpi:unscaled”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/Type1”
FontPath “/usr/share/fonts/URW”
FontPath “/usr/share/fonts/Speedo”
FontPath “/usr/share/fonts/PEX”
FontPath “/usr/share/fonts/cyrillic”
FontPath “/usr/share/fonts/latin2/misc:unscaled”
FontPath “/usr/share/fonts/latin2/75dpi:unscaled”
FontPath “/usr/share/fonts/latin2/100dpi:unscaled”
FontPath “/usr/share/fonts/latin2/Type1”
FontPath “/usr/share/fonts/latin7/75dpi:unscaled”
FontPath “/usr/share/fonts/baekmuk:unscaled”
FontPath “/usr/share/fonts/japanese:unscaled”
FontPath “/usr/share/fonts/kwintv”
FontPath “/usr/share/fonts/truetype”
FontPath “/usr/share/fonts/uni:unscaled”
FontPath “/usr/share/fonts/CID”
FontPath “/usr/share/fonts/ucs/misc:unscaled”
FontPath “/usr/share/fonts/ucs/75dpi:unscaled”
FontPath “/usr/share/fonts/ucs/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/misc:unscaled”
FontPath “/usr/share/fonts/hellas/75dpi:unscaled”
FontPath “/usr/share/fonts/hellas/100dpi:unscaled”
FontPath “/usr/share/fonts/hellas/Type1”
FontPath “/usr/share/fonts/misc/sgi:unscaled”
FontPath “/usr/share/fonts/xtest”
FontPath “/opt/kde3/share/fonts”
InputDevices “/dev/gpmdata”
InputDevices “/dev/input/mice”

Section “ServerFlags”
Option “AllowMouseOpenFail” “on”
Option “ZapWarning” “on”

Section “Module”
Load “freetype”
Load “dbe”
Load “dri”
Load “glx”
Load “extmod”

Section “InputDevice”
Driver “kbd”
Identifier “Keyboard[0]”
Option “Protocol” “Standard”
Option “XkbLayout” “us”
Option “XkbModel” “microsoftpro”
Option “XkbRules” “xfree86”

Section “InputDevice”
Driver “mouse”
Identifier “Mouse[1]”
Option “Buttons” “8”
Option “Device” “/dev/input/mice”
Option “Name” “TrackMan Optical”
Option “Protocol” “ExplorerPS/2”
Option “Vendor” “Logitech”
Option “ZAxisMapping” “4 5”

Section “Monitor”
Option “CalcAlgorithm” “XServerPool”
DisplaySize 470 300
HorizSync 30-80
Identifier “Monitor[0]”
ModelName “AOC 2217”
Option “DPMS”
Option “PreferredMode” “1680x1050”
VendorName “AOC”
VertRefresh 43-75
UseModes “Modes[0]”

Section “Modes”
Identifier “Modes[0]”
Modeline “1680x1050” 146.00 1680 1784 1960 2240 1050 1053 1059 1089

Section “Screen”
DefaultDepth 24
SubSection “Display”
Depth 15
Modes “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 16
Modes “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 24
Modes “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
SubSection “Display”
Depth 8
Modes “1680x1050” “1600x1024” “1600x1000” “1400x1050” “1600x900” “1280x1024” “1440x900” “1280x960” “1366x768” “1360x768” “1280x800” “1152x864” “1280x768” “1280x720” “1024x768” “1280x600” “1024x600” “800x600” “768x576” “640x480”
Device “Device[0]”
Identifier “Screen[0]”
Monitor “Monitor[0]”

Section “Device”
BoardName “GeForce 7600 GT”
Driver “nv”
Identifier “Device[0]”
Screen 0
VendorName “NVidia”

Section “ServerLayout”
Identifier “Layout[all]”
InputDevice “Keyboard[0]” “CoreKeyboard”
InputDevice “Mouse[1]” “CorePointer”
Option “Clone” “off”
Option “Xinerama” “off”
Screen “Screen[0]”

Section “DRI”
Group “video”
Mode 0660

Section “Extensions”
Option “Composite” “off”

Is this on a laptop? Not saying that matters.

I did find this via google
View topic - [HOW TO] Enable Logitech LX3 Horizontal Scrolling :: Parsix GNU/Linux :: A Gift From Ancient Persia

I use a Logitech mouse on a Laptop with no issue, it’s a very bog standard mouse mind you.

This is a clone.

A few weeks ago I swapped out the old ps/2 mouse for this one, never really paid much attention to having done so and started noticing the pointer lockups but never attributed it to the mouse swap. I had the ps/2-to-usb adapter in place so never felt that any sort of configuration was required since it worked right away.

Thanks for the reference… but my center wheel does work, as do left and right buttons.

I think mis-configuration is the right direction to pursue…just made three attempts to boot and finally plugged the ps/2 mouse back in.

Funny how that is working so reliably.

Also perhaps relevant: the LED beneath the mouse is not on - and the LSUSB command hangs. Cannot even ctl-c. Here’s the output of hwinfo --mouse

linux-3jev:/home/stan # hwinfo --mouse
44: USB 00.0: 10503 USB Mouse
[Created at usb.122]
UDI: /org/freedesktop/Hal/devices/usb_device_46d_c044_noserial_if0
Unique ID: 7bWa.USZARCNg_59
Parent ID: pBe4.Uu0aCsrHYoB
SysFS ID: /devices/pci0000:00/0000:00:0b.0/usb2/2-3/2-3:1.0
SysFS BusID: 2-3:1.0
Hardware Class: mouse
Model: “Logitech USB-PS/2 Optical Mouse”
Hotplug: USB
Vendor: usb 0x046d “Logitech, Inc.”
Device: usb 0xc044 “USB-PS/2 Optical Mouse”
Revision: “27.20”
Compatible to: int 0x0210 0x0028
Driver: “usbhid”
Driver Modules: “usbhid”
Device File: /dev/input/mice (/dev/input/mouse0)
Device Files: /dev/input/mice, /dev/input/mouse0, /dev/input/event0, /dev/input/by-id/usb-Logitech_USB-PS.2_Optical_Mouse-event-mouse, /dev/input/by-path/pci-0000:00:0b.0-usb-0:3:1.0-event-mouse, /dev/input/by-id/usb-Logitech_USB-PS.2_Optical_Mouse-mouse, /dev/input/by-path/pci-0000:00:0b.0-usb-0:3:1.0-mouse
Device Number: char 13:63 (char 13:32)
Speed: 1.5 Mbps
Module Alias: “usb:v046DpC044d2720dc00dsc00dp00ic03isc01ip02”
Driver Info #0:
Buttons: 8
Wheels: 2
XFree86 Protocol: explorerps/2
GPM Protocol: exps2
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #43 (Hub)

46: PS/2 00.0: 10500 PS/2 Mouse
[Created at input.183]
UDI: /org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input
Unique ID: AH6Q.oV6xZUCQFf1
Hardware Class: mouse
Model: “ImPS/2 Generic Wheel Mouse”
Vendor: 0x0002
Device: 0x0005 “ImPS/2 Generic Wheel Mouse”
Compatible to: int 0x0210 0x0013
Device File: /dev/input/mice (/dev/input/mouse1)
Device Files: /dev/input/mice, /dev/input/mouse1, /dev/input/event5, /dev/input/by-path/platform-i8042-serio-1-event-mouse, /dev/input/by-path/platform-i8042-serio-1-mouse
Device Number: char 13:63 (char 13:33)
Driver Info #0:
Buttons: 3
Wheels: 1
XFree86 Protocol: explorerps/2
GPM Protocol: exps2
Config Status: cfg=no, avail=yes, need=no, active=unknown

I had a usb mouse freeze using an AMD Athlon. The problem appeared if I was using the mouse when the system turned on/off a cooling fan. The system would just lose any response from the mouse. I didn’t want to fool with thermal control settings, so I went with a ps/2 converter and have not had any freezes in half a year.

That’s what I started with, the converter plug. Crashed. Plugged directly into USB, still crashes.

Interesting timing though on your system…

I thought you were testing a different mouse?

Sorry for the confusion.

The mouse in question is a Logitech LX3. It came with a ps/2 converter plug. There are lockups using the converter, or plugged into a USB port directly. No difference.

I am now testing with an old ps/2 roller ball mouse and have had no mouse lockups.

Interestingly enough, the LX3 is plugged into a USB port (no converter plug), sitting off to the side. It does control the pointer, I just don’t use it.

I had a problem with my mouse before when I was using Ubuntu. It would freeze randomly within 20 seconds up to 10 minutes some times.

This may be a dumb question, but it worked for me, did you try plugging it into different USB ports? I just switched the port to the one next to where my mouse was originally plugged in and I never had a problem with it afterwards.

also post lsusb

Yes, tried different usb ports. Where I am now is the ps/2 mouse port using the converter plug that came with the mouse - AND having told Yast that it is a ‘usb mouse ps/2 on usb’ and haven’t had a lockup yet… but of course this needs to run for a few days. One problem is the mouse wheel not working. If I can get past that all will truly be well.

Is there a generic specification that will all me to use a usb port and hopefully enable the roller wheel ?

Update: just had a mouse lockup. Using the ps/2 port with the usb-to-ps/2 adapter.

So - it isn’t the mouse, and it isn’t the usb port.

It’s either a config mismatch, or driver problem.