USB mouse and keyboard not working in 12.2

Hi,

i just upgraded to 12.2 x64 from 12.1 and now my USB mouse and keyboard dont work anymore in X (KDE 4.9.1). Both are connected to a USB hub and this hub is connected to the dockingstation of my hp compaq 8510p. This used to work fine in suse 12.1.
When looking at the dmesg output i can see that both devices are beeing recognozed just fine. When i switch to a console via ctrl+alt+f1 the keyboard works. So its just not working in X. When i connect the keyboard and mouse directly to my notebook (without the usb hub) then the devices work fine.
What could be the problem of this? Should i post any logs or config files?

Thanks
pepe

So I see KDE 4.8.4 as the default with openSUSE 12.2 after the initial YaST update is complete. How did you end up with KDE 4.9.1 by chance? As for your hub, its is kind of strange, but what if you plug the hub into a different root hub on the PC and try your keyboard again? I don’t know if it would help, but if you updated KDE to see if it would help, I guess you could try a new kernel version as well. I am running kernel 3.5.3 with openSUSE 12.2 with no problems. Have a look here:

S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.76 - Blogs - openSUSE Forums

Make sure to read through the whole blog and get the required stuff before installing a new kernel. Let me know what you are thinking.

Thank You,

It’s probably unrelated, but I had an issue with my keyboard and mouse not working in X after upgrading that was caused by the graphics driver. Running Xorg -configure displayed an error like “the number of screens does not match the number of detected devices,” but after uninstalling xorg-x11-driver-radeonhd, it worked fine. The graphics driver still works, though, so I guess they just moved it somewhere else.

kde 4.9.1, opensuse 12.2 wont start either -sometimes with no keyboard and no mouse- but mostly with no mouse. It works with a fail-save start during booting.
Everything was working fine with 12.1.

Rene

I’m also having problems with a new installation of OpenSUSE 12.2 x64 (DVD) and external keyboard USB-HUB.

Keyboard Clone 9201 MULTIMIDIA ABNT2 SCISSOR TYPE C/HUB USB.

http://img1.carrefour.net.br/gm/teclado-multim-dia-scissor-tyoe-com-hub-usb-9201-clone_1958600_41348.jpg

The USB external keyboard works correctly with OpenSUSE 11.4 and OpenSUSE 12.1 and Windows 7.

The keyboard of the Vaio notebook works properly.

Vaio notebook has no option USB (USB Legacy Support, USB Functions) in the BIOS.

Check installation DVD media OpenSUSE 12.2: No errors found.
DVD is OK.

Ctrl + Alt + F1 … F5 → usb keyboard works.
Ctrl + Alt + F7 → kdm, gdm, KDE, Gnome → usb keyboard does not work.

I tried the 3 USB ports on the notebook and it did not work with the USB keyboard in the graphical environment.

The USB mouse works on any USB port in the graphical environment…

When load the graphic environment in OpenSUSE 12.2 installation the usb keyboard stop working.

The same problem happens after the system is installed.

I tried “Xorg -configure” but also did not work with the new xorg.conf.

I saw during the “Check installation media” are loaded Initrd Extra Modules: input, usbhid and keybdev.

Once installed the system these Extras Initrd Modules are not in the system: input and keybdev.
sudo /sbin/modprobe usbhid -> load but does not appear in lsmod.
sudo /sbin/modprobe input -> FATAL: Module input not found.
sudo /sbin/modprobe keybdev -> FATAL: Module keybdev not found.

I tried kernel-desktop-2.10.1-3.4.6, kernel-default-3.4.6-2.10.1, kernel-vanilla-3.4.6-2.10.1 and none solved the problem.

When the mkinitrd was run after installation of the new kernel the following message appears:
modprobe: Module hid_generic not found.
WARNING: no dependencies for kernel module ‘hid-generic’ found.

I tried to compile the kernel-source-3.4.6-2.10.1 to compile also the HID Devices (HID_SUPPORT) but stops with this error:

In /usr/src/linux :
sudo make rpm

MKDIR /usr/src/packages/BUILDROOT/kernel-3.4.6_2.10_desktop_teste-1.x86_64/lib/firmware/3.4.6-2.10-desktop-teste/acenic/
make[3]: *** No rule to make target /usr/src/packages/BUILDROOT/kernel-3.4.6_2.10_desktop_teste-1.x86_64/lib/firmware/3.4.6-2.10-desktop-teste/./', needed by /usr/src/packages/BUILDROOT/kernel-3.4.6_2.10_desktop_teste-1.x86_64/lib/firmware/3.4.6-2.10-desktop-teste/atmsar11.fw’. Stop.
make[3]: *** Waiting for unfinished jobs…
MKDIR /usr/src/packages/BUILDROOT/kernel-3.4.6_2.10_desktop_teste-1.x86_64/lib/firmware/3.4.6-2.10-desktop-teste/adaptec/
make[2]: *** [_modinst_post] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.LvrFj1 (%install)

RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.LvrFj1 (%install)
make[1]: *** [rpm] Error 1
make: *** [rpm] Error 2

Yast2 -> Hardware Information:

  • Notebook Vaio VPCEB13EB
  • Intel Core i3 - 4 GB RAM
  • Intel Arrandale Integrated Graphics Controller - Driver i915
  • External USB keyboard with integrated HUB.
  • Unclassified Device:
    Device Names:
    /dev/input/event7
    /dev/input/by-id/usb-0b38_0010-event-if01
    /dev/input/by-path/pci-0000:00:1d.0-usb-0:1:6:4:1.1-event
    Driver: usbhid
    Model: Unclassified device
    Vendor Identifier: 199480
    hotplug:usb

I: Bus=0003 Vendor=0b38 Product=0010 Version=0110
N: Name=“HID 0b38:0010”
P: Phys=usb-0000:00:1d.0-1.6.4/input0
S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6.4/2-1.6.4:1.0/input/input6
U: Uniq=
H: Handlers=kbd event6
B: PROP=0
B: EV=120013
B: KEY=1000000000007 ff800000000007ff febeffdff3cfffff fffffffffffffffe
B: MSC=10
B: LED=7

I: Bus=0003 Vendor=0b38 Product=0010 Version=0110
N: Name=“HID 0b38:0010”
P: Phys=usb-0000:00:1d.0-1.6.4/input1
S: Sysfs=/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6/2-1.6.4/2-1.6.4:1.1/input/input7
U: Uniq=
H: Handlers=kbd event7
B: PROP=0
B: EV=1f
B: KEY=4837fff072ff32d bf54444600000000 1 20c100b17c000 267bfad941dfed 9e168000004400 10000002
B: REL=40
B: ABS=100000000
B: MSC=10

USB keyboard conflicting with Xorg or kernel without HID support or other situation?

Finally I did a new fresh install and kept the home folder separate. It works fine now, perhaps there was something wrong with GRUB or plymouth ???

Rene

So it does sound like something is different the second time around, but using the same media? What would that mean I wonder?

Thank You,

I solved the problem temporarily using the xorg.conf with the following options:

Section “ServerFlags”
Option “AutoAddDevices” "false "
EndSection

If Xorg use xorg.conf looks like settings /etc/X11/xorg.conf.d/ are ignored.

I have to see how to make it work using the settings /etc/X11/xorg.conf.d/ . It seems that xorg.conf is deprecated.

Console login without the graphical environment (X) running.
I had a problem trying to create the xorg.conf which appeared the following error message.

sudo Xorg -configure
Number of created screens does not match number of detected devices. Configuration failed.

I saw also that the keyboard and mouse were disabled by hotplug.

cat /var/log/Xorg.0.log

** 581.623] (WW) Hotplugging is on, devices using drivers ‘kbd’, ‘mouse’ or ‘vmmouse’ will be disabled.
581.623] (WW) Disabling Mouse0
581.623] (WW) Disabling Keyboard0
**

Using a safe xorg.conf.

cd /etc/X11/

sudo cp -v xorg.conf.install xorg.conf

Using a file editor, add at the end of the file:

sudo nano /etc/X11/xorg.conf

Section “ServerFlags”
Option “AutoAddDevices” "false "
EndSection

Save and exit.

Logout KDE and login again.

If anyone has this same problem and can test to see if partially solves the problem please post the result here.

I’ll install OpenSUSE 12.1 for see the configuration files in /etc/X11/xorg.conf.d and see if I can use some information on OpenSUSE 12.2.

Links where I got the information:

1 - mouse and keyboard are dead on X: Debian testing

mouse and keyboard are dead on X: Debian testing - Page 2

2 - Xorg server and HAL

X.Org Wiki - XorgHAL

3 - Disabling the use of HAL

Input device configuration - FedoraProject

In Fedora 17 the problem was with the package systemd.

The problem is with the ID 058f: 6254 Alcor Micro Corp… USB Hub.

This HUB Alcor is integrated into my USB keyboard.

https://bugzilla.redhat.com/show_bug.cgi?id=823815

[Solved] Problem with Fedora 17 and devices connected to USB HUB - Ask Fedora: Community Knowledge Base and Support Forum](http://ask.fedoraproject.org/question/1819/solved-problem-with-fedora-17-and-devices)

I tested with Fedora 17 KDE Live CD and when I updated the package systemd the USB keyboard is working again without rebooting.

I do not know if this problem systemd Fedora 17 is equal to OpenSUSE 12.2.
I’ll do more tests.

lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 064e:a213 Suyin Corp.
Bus 002 Device 009: ID 058f:6254 Alcor Micro Corp. USB Hub
Bus 002 Device 006: ID 093a:2521 Pixart Imaging, Inc.
Bus 002 Device 010: ID 0b38:0010 Gear Head 107-Key Keyboard

I tried an update to systemd but it did not work:
systemd-44-10.1.1.x86_64.rpm -> systemd-44-277.1.x86_64.rpm
systemd-sysvinit-44-10.1.1.x86_64.rpm -> systemd-sysvinit-44-277.1.x86_64.rpm

**
Following this tip, ****keyboard **HUB USB and mouse connected to the HUB keyboard are working properly.

[Solved] Problem with Fedora 17 and devices connected to USB HUB - Ask Fedora: Community Knowledge Base and Support Forum](http://ask.fedoraproject.org/question/1819/solved-problem-with-fedora-17-and-devices)

I did a fresh install of OpenSUSE 12.2 to be sure that only by changing the file /lib/udev/rules.d/71-seat.rules work.

The system is working without the /etc/X11/xorg.conf.

The graphical environment settings are being used by the directory /etc/X11/xorg.conf.d/.

Comment (#) the line for Device 003: ID 058f: 6254 Alcor Micro Corp… USB Hub (lsusb command).

sudo nano /lib/udev/rules.d/71-seat.rules

Mimo 720, with integrated USB hub, displaylink graphics, and e2i touchscreen

# SUBSYSTEM==“usb”, ATTR{idVendor}==“058f”, ATTR{idProduct}==“6254”, ENV{ID_AUTOSEAT}="1"

Save and Exit.
Unplug and re-plug the keyboard USB HUB.
No need to reboot the system.

That did it for me, too! Thank you!

Hi I’ve installed openSUSE 12.2 64 bit on a laptop Dell XPS M1530. While the power is switched off I can not use a USB mouse, working only pad. Any ideas? It looks like a turn on power saving profile but there is no such option in the settings. Somebody understending this: #4746805 - Pastie](http://pastie.org/4746805) ?

First check the BIOS settings of your Dell.

This link says:

Diagnosing USB Power Management Problems

Some systems cannot wake up a system from S3 (deep sleep) power management mode unless this option is enabled in the system BIOS. If you are unable to wake up your system by tapping on a USB keyboard or moving the mouse, make sure this option is enabled in the system BIOS.

How to Guide On Troubleshooting USB Problems

This link says:

**Turn off power to USB port? **

/sys/bus/usb/devices/

Turn off power to USB port?

USB power management

Powersaving - openSUSE

**
Is it possible to turn on/off power supplies from USB manually with linux?**

# disable external wake-up; do this only once echo disabled > /sys/bus/usb/devices/usb1/power/wakeup echo on > /sys/bus/usb/devices/usb1/power/level # turn on echo suspend > /sys/bus/usb/devices/usb1/power/level # turn off

Controlling a USB power supply (on/off) with linux - Stack Overflow

Power Management for USB

http://www.kernel.org/doc/Documentation/usb/power-management.txt

Cannot resume using USB keyboard/mouse

[linux-pm] cannot resume using USB keyboard/mouse](http://lists.linux-foundation.org/pipermail/linux-pm/2007-November/015553.html)

I confirm that this actually happens in openSUSE 12.2. Today I have made a fresh install of oS 12.2 and while running X no device plugged to USB hub works - tested on USB All-in-One printer PSC 1510 (the printer and the scanner are reported but do not work) and USB mouse+keyboard set. Usage of

Section “ServerFlags”
Option “AutoAddDevices” "false "
EndSection

in xorg.conf made the mouse and keyboard work, but did not help with the printer. First appearance of this effect was after finishing the install and booting into LXDE.

Hardware: MB Gigabyte E350N-USB3, USB hub SPEED LINK Nobile 4

I hope this bug should be reported … did anyone do this?

I am sorry, I was reading too fast and I skipped the right solution. Commenting

Mimo 720, with integrated USB hub, displaylink graphics, and e2i touchscreen

#SUBSYSTEM==“usb”, ATTR{idVendor}==“058f”, ATTR{idProduct}==“6254”, ENV{ID_AUTOSEAT}=“1”

in /lib/udev/rules.d/71-seat.rules fixed the problem.

Thank you all,
P.

Hope I am posting in correct place. I do not appear to b able to change my keyboard style re system settings/keyboard/layout settings/English (uk). I get stuck with the US version # instead of a pound sign. Re-looking whilst typing this system settings/keyboard/layout settings/ the 4 choices have now disappeared with only the US English shown. The buttons at lower position have no description and only faint shade difference (no colour). With the earlier 4 choice view could move up and down but no select button. Is it stupid me or is there a problem. Have the latest Opensuse 64 bit version installed and accept all the latests updates. Everything else seems fine. Hope someone can answer my query.

cheers Omhie42

Which desktop?

Did you check in softwaremangement and see if you hae the English versions installed?

Well, I haven’t read the whole thread now, but your problem seems to be completely different… So maybe you should have better started a new thread.
But anyway.

You can try to set the keyboard layout system-wide in YaST->Hardware->System Keyboard Layout.
But this will be overridden by the desktop settings for your user.

I suppose you’re talking about KDE. Since I haven’t used KDE 4.8.5 as included in openSUSE 12.2 for over a year, I’m not sure anymore how much has changed since then. Could you maybe post a screenshot of your keyboard settings?

Seems a recent update has restored this functionality. For those interested have Gnome desktop. thanks for replies