USB Mice won't work on Tumbleweed if plugged directly in

So, odd issue that I just can’t figure out. I have 2 systems running Tumbleweed (Lenovo Thinkpad T14s Gen3 AMD & Lenovo K14 Gen1 AMD), both running Plasma desktops. They both work absolutely perfectly. I often use them on a USB-C dock, they work perfectly there. However, if I try to plug a USB mouse (wired or wireless) DIRECTLY into the laptop, it doesn’t work. Off the dock or on the dock, doesn’t matter. If I take that same USB mouse and plug it into the USB-C dock so it’s connected through a hub…works just fine. These mice all work with all my other laptops just fine (I have more laptops than I need by a lot).
The USB ports work fine directly connected to other things like USB headsets, USB thumb drives, USB SSD’s, but not mice.
It definitely SEES that the device has been plugged in, but absolutely won’t work with it.
Plugged directly in:

[  774.056984] usb 3-1: new full-speed USB device number 7 using xhci_hcd
[  774.229480] usb 3-1: New USB device found, idVendor=3151, idProduct=3020, bcdDevice= 0.02
[  774.229492] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  774.229495] usb 3-1: Product: Wireless Device
[  774.229497] usb 3-1: Manufacturer: YICHIP
[  774.249369] input: YICHIP Wireless Device as /devices/pci0000:00/0000:00:08.1/0000:33:00.4/usb3/3-1/3-1:1.0/0003:3151:3020.000E/input/input41
[  774.304275] hid-generic 0003:3151:3020.000E: input,hidraw6: USB HID v2.00 Keyboard [YICHIP Wireless Device] on usb-0000:33:00.4-1/input0
[  799.883728] usbhid 3-1:1.1: can't add hid device: -110
[  799.950596] usbhid: probe of 3-1:1.1 failed with error -110

Plugged into a hub:

[  915.060896] usb 9- new full-speed USB device number 11 using xhci_hcd
[  915.180577] usb 9- New USB device found, idVendor=3151, idProduct=3020, bcdDevice= 0.02
[  915.180590] usb 9- New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  915.180593] usb 9- Product: Wireless Device
[  915.180595] usb 9- Manufacturer: YICHIP
[  915.279517] input: YICHIP Wireless Device as /devices/pci0000:00/0000:00:08.3/0000:34:00.4/usb9/9-1/9-1.1/9-1.1.4/9-
[  915.334573] hid-generic 0003:3151:3020.000F: input,hidraw6: USB HID v2.00 Keyboard [YICHIP Wireless Device] on usb-0000:34:00.4-
[  915.350070] input: YICHIP Wireless Device Mouse as /devices/pci0000:00/0000:00:08.3/0000:34:00.4/usb9/9-1/9-1.1/9-1.1.4/9-
[  915.350550] input: YICHIP Wireless Device System Control as /devices/pci0000:00/0000:00:08.3/0000:34:00.4/usb9/9-1/9-1.1/9-1.1.4/9-
[  915.407702] input: YICHIP Wireless Device Consumer Control as /devices/pci0000:00/0000:00:08.3/0000:34:00.4/usb9/9-1/9-1.1/9-1.1.4/9-
[  915.408277] hid-generic 0003:3151:3020.0010: input,hiddev99,hidraw7: USB HID v2.00 Mouse [YICHIP Wireless Device] on usb-0000:34:00.4-

Anyone have any ideas what’s going on and how to fix it? This is the exact same mouse just plugged from a hub vs. directly in, doesn’t make sense that it can’t probe it when directly plugged in but can when it’s plugged in via a hub to me.

Something I would try: if any mouse-specific drivers are installed, uninstall. If not, try installing xf86-input-mouse.

# rpm -qa | egrep 'mouse|binp'

Error -110 == ETIMEDOUT, so it sounds like some compatibility issues between your device and USB HCI. Problems with low-speed devices in high-speed USB ports are not unheard of.

This would involve debugging interaction between USB HCI and your device and depending on the results may require changing the kernel, writing special driver etc. Which rather exceeds the format of this forum.

You could try forcing useage of low speed HCI for this device. See as example

How to downgrade selected USB port to v1 [SOLVED] / Kernel & Hardware / Arch Linux Forums

How X11 driver can be related to failure of kernel to probe the device?

So is there a different USB driver I can force the system to use? As I mentioned, if I run ANY other OS (Debian SID kernel, Debian Liquorix kernel, Arch, KDE Neon Liquorix kernel), it works fine plugged in directly to the port, so it’s not the hardware, it’s the OS that’s causing the issue.

Did you try any of the suggestions suggested?


I had actually booted up the laptop to test the idea of ardvidjaar for setting the port to low speed to test (this wouldn’t work long term, but for verification purposes was a great idea) after doing updates last night right before powering off for bed. I had gotten a new kernel (6.4.8-1) with the updates.

Guess what’s all working again?

Looks like this was a kernel issue with 6.4.6-1 that I had prior to today. I tested and rebooted into it just to check, and sure enough, 6.4.6-1 no USB mice work plugged directly in. 6.4.8-1 EVERY SINGLE ONE does.

1 Like

I have some bad experiences with “cheap” mouses, mine would hand the USB bus after a few hours.

Is this indeed a wireless mouse?

It is more that high speed USB is actually two devices - high and low speed - and you can somewhat influence which of them will actually control a given USB device.

This particular mouse was indeed wireless, however I was having the issue even with a nice wired gaming mouse I hadn’t put away and had lying out.