USB live session won't boot up on the new laptop


I have this new laptop Lenovo Y510p

  • CPU model Intel Core i7 4700MQ
  • Processor speed 2.4 GHz
  • System RAM 12 GB
  • Hard drive(s)1 TB (8GB SSHD)
  • Graphics (discrete) NVIDIA GT755M
  • OS Windows 8.1 pre-installed.

I made a Live USB opensuse 13.1 x64 KDE and tried to install opensuse 13.1 on my laptop (I have already made hard disk partition for the dual boot).

So far I tried

  1. Either UEFI or legacy mode in BIOS setting,
  1. when I choose live session at grub menu at boot up, my screen would go black after flashing something I don’t even have time to read

  2. when I choose fail-safe live session, the machine will boot up until the last line “OK, reached LSB graphic…” Normally, a login screen should appear after this line if I remember right for my other opensuse system. But it just gets stuck there.

  1. I set “use integrated graphic card only” mode at BIOS and tried again, it changed nothing and I get into exactly the same situation as described above.

  2. I have an opensuse os installed on a portable hard disk (13.1 x64 KDE), it can boot without problem in legacy boot mode on this new laptop.

  3. I tried the live usb on other computer to make sure the installation media is ok, and it seems it’s working well on the other computer.

What could be the cause?

NVIDIA graphics.

I recommend that you use UEFI, particularly if Windows is already installed and using UEFI.

When you see the grub boot menu, hit the “e” key to edit the boot command.

Scroll down until you find a line with the “linuxefi” command.

Add “nomodeset” to the end of that command line. Then continue booting (I think that may be F10, but there will be help notation at the bottom of the screen telling you how to proceed.

You should then get a usable install screen, though with crappy graphics.

Once you have everything working, look into installing the NVIDIA drivers, so that you can get full use of your system’s graphic capabilities.

Thank you very much nrickert! Worked immediately. I wonder why in BIOS I set to use only the integrated graphic card it still didn’t work.

Is his a multi- graphics machine ie Intel+NVIDIA?

You should use bumblebee to manage the two

The Intel may not have worked because the th Intel driver that shipped was broken an update fixed it.