USB Live CD

I tried using two different methods of writing the openSuSE 11.1 live cd iso file to a flash drive, in order to allow me to boot from the flashdrive (i hope to eventually put my favorite distro’s on sd cards i can swap in my laptop). One, a linux python script wrote the iso file fine, but for some reason, when i tried to boot from it, it could not locate a boot partition. the second one puts in its own boot partition, so i got it to boot, but when it was loading, it was unable to locate the live cd config file, and halted. Is there a reason i cannot get it to boot from a usb drive correctly? And if there is, can it be fixed in 11.2?

If it can’t locate the config file, might be worth renaming ‘config.kde.isoclient’ or ‘config.gnome.isoclient’ (depending on whether it’s kde or gnome) to ‘config.isoclient’ in the root of the stick.

I have no idea if that’ll help - but it sometimes does in other circumstances.

If no joy, try using unetbootin - it’s free and runs on PC or linux. If that doesn’t boot, try the above again.

PC or linux. Bah. You know what I meant.

(it’s those bloody adverts ;))

I did try unetbootin. I didn’t download the ISO file via unet though, I didn’t know if it was the live cd, so I downloaded it myself. I shall try using it again. If it fails, I will let unet download the ISO file.

See how it goes. I have it on good authority that you can just dd the images of 11.2, so if you get stuck that’s an option (although it’s still pre-release, so officially not for production use yet).