USB keyboard not working during boot

I have a Dell Latitude E6400 laptop with an encrypted hard drive that’s connected to a docking station and I recently upgraded it to Leap 42.3 from 42.2. Following the upgrade, everything has functioned normally, but I can no longer use the USB keyboard to enter the encryption password during boot; I have to open the laptop and type on the integrated keyboard. The USB keyboard works in grub and also once the laptop has booted, though. Any suggestions on how to resolve this?

I’ve never tried doing that with my laptop. I just use the integrated keyboard. Maybe I should try.

In any case, the most likely explanation is that a USB keyboard requires a kernel module which is not included in the “initrd” and therefor not available until after the root file system is decrypted and mounted.

Here’s my suggestion.

Use the “lsmod” command to get a list of all loaded modules. Best to redirect that to a file.

Then use “lsinitrd” to list the content of the “initrd”.

The idea is to find which kernel modules you need, that are not in the “initrd”. And then try to narrow it down to the ones that are USB related. If you are able to identify the missing module, then you can force it into the initrd with the dracut configuration.

I tried what you suggested, but I didn’t see anything obvious. However…it appears an update from last week fixed the problem. It works now.