usb internet huawei e1750

hi is it possible to make this running? is there a howto?
Best regards claus

A quick search reveals this openSUSE Forums - Search Results


Bus 001 Device 002: ID 12d1:1446 Huawei Technologies Co., Ltd.
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x12d1 Huawei Technologies Co., Ltd.
idProduct 0x1446
bcdDevice 0.00
iManufacturer 3 HUAWEI Technology
iProduct 2 HUAWEI Mobile
iSerial 0
bNumConfigurations 1

are we supposed to GUESS what your question or problem is?
have you checked with your ISP and see if they have any hints?
did none of the previous threads here provide enough direction?


well claus111;

how it is coming along out there?


  1. plug your huawei into a USB port
  2. right-click on Network Manager (2 TV screens at bottom right);
  3. select third option down: Edit Connections …
  4. select mobile broadband
  5. select “Add”
  6. select country, select network; click
  7. close this edit function
  8. left-click now on Network Manager; (with Huawei still plugged in)
  9. howzat?

it is working now like a charm rotfl!
you can find the solution here: Ubuntu Sverige • Visa tråd - Mobilt bredband HUAWEI E1750

so it was the old draisberghof usb_modeswitch trick?

Draisberghof - Software - USB_ModeSwitch

Liam Green-Hughes talked about it for the Huawei 169 modem with ASUS eee variants:

Huawei E169G - the easy way |

My Swedish isn’t that great :slight_smile: but in this guide:

Ubuntu Sverige • Visa tråd - Mobilt bredband HUAWEI E1750

the udev part is for the automatic execution of the modeswitch?

Because I did the same thing but it’s not automatically switching the device when I connect it.

Also when I do it manually the NetworkManager applet sees the GSM device but I when I click it nothing happens.

Anything I can try here?

I don’t think there is anyone here on this forum who considers themself an expert on the usbmodeswitch;

why not go to the source

Draisberghof - Software - USB_ModeSwitch

join their forum there;

get your problem fixed;

and come back here and tell us the adventures you went through?

I will, but I think the NetworkManager and possibly the udev problem could be distro related. I’ll check their forum anyway. Thanks

you may well be very right about distro specific; I find the Ubuntu variants are great to use for the Huawei modems: the country, and the network, are already configured in; you just click; try a live CD of Ubuntu; or one of its variants; (various linux magazines give away such liveCD distros): eg I tested our Huawei E220 last night by booting a desktop on live Mint CD 7 and it is so easy to configure on our Vodafone E220; I have also loaded a Vodafone simcard into a Huawei E160 and it worked just as well. OpenSuse 11.2 has no such intuitive menu but I don’t seem to be able to make that point to OpenSuse enthusiasts; similarly, the latest beta Mandriva has a couple of European networks; and is very limited to try to configure the Huawei modems on

Yeah… But I don’t like Ubuntu. Thanks anyway.

Also, there is nothing wrong with the way SuSE handles UMTS cards. If I try another brand of card I just get a popup for the GSM pincode and I got internet. So that’s working perfectly.

There is just something going wrong with this one. I rather get it fixed then move to another distro.

Essentially, for it to be controlled via NetworkManager, it needs to be recognised by hal. The key file is


If your modem has similar supported models present in this config file, then often it can be edited to include the relevant vendor and model ID, and will then work (as with many Huawei models).

However, I tried hard to get my new Sierra Compass 597 working this way, but failed. NetworkManager tries to connect, but seems to fail to parse the username and password info correctly. I had to resort to using KInternet to control this device for now.

pdc_2 is correct that Ubuntu seems to support a lot more of these type of usb modem devices, but only because the latest distro version uses a recent NetworkManager release. Lets wait and see what openSUSE 11.2 brings.

thanks very much for a very helpful post; and directing us to the …10-modem.fdi file; I downloaded a liveCD of the latest 11.2 OpenSuse and it was very sad with a Huawei 220; it essentially demanded a manual configuration; (as opposed to any of the latest Ubuntu variants): I tried posting this as a comment on the development forum; it did not seem to be understood; not sure to say this to OpenSuse developers

I downloaded a liveCD of the latest 11.2 OpenSuse and it was very sad with a Huawei 220; it essentially demanded a manual configuration; (as opposed to any of the latest Ubuntu variants):

Thats strange. I was using a Vodafone E800 device with same vendor ID (0x12d1) and product ID (0x1003) as the E220 with openSUSE 11 (KDE4) with very little network manager configuration required. It was detected automatically and only required editing the connection with correct dialout string from memory. It is explicitly listed in 10-modem.fdi (xml file) described previously. (I wonder if the problem is specific to the liveCD).

thanks deano; just booted our other desktop without eth0 plugged in; using the KDE 11.2 OpenSuse variant; with the Huawei E220 plugged in;

it doesn’t recognise it; (ie it doesn’t prompt me to install it)

rightclicking on the KDE network Management: Control Module; the mobile wireless section is greyed out; I can’t get it to react at all; what I have is: build 0180 -i686; I downloaded it on Tues 25th Aug

on lsusb it sees the Huawei …

Thats disappointing, especially since kernel support for it has existed since 2.6.20. However, for NetworkManager to work, hal needs to know how to handle the device as well. I would have thought that openSUSE 11.2 would be utilising the latest hal and NM versions, comparable to Ubuntu.

I guess many of these devices will have to be controlled via a dialing utility for the immediate future…

Edit: Another important consideration I didn’t factor in, (maybe), as outlined here. I live in NZ so maybe my Vodafone device had different firmware, causing it to behave better with NM. Just a guess.

this too was on Vodafone nz

it works atraight forward for me. my connection is right now huwei e1750 on opensuse milestone 8 on a netbook.
i go with xcfe . If you have trouble i think i has something to do with kde4.

Best regards

Why doesn’t this just work - how long have these devices been around, how long has Linux been around. As you probably can tell I’m frustrated.

I have a DELL Inspiron 1750 laptop, Turion 64 CPU, 4GB Ram, ATi Radeon x1270 VGA (this is a world of pain on its own), Wireless (b43 yadda yadda), etc etc & a USB e1750 3G Adapter (3internet). In Windows (xp/vista/win7), I plug in the adapter and away I go! In Linux (Suse 11.3) I plug it in, a little phone icon apperas instead of Network Manager, I enter the same connection info in the mobile broadband setting as found via the utility I use in Windows (no username/password just APN & 99**1# for the number) and guess what, nothing - it just says Activating and nothing. I have tried following mode_switch instructions, because the USB 3G Adpater shows up as a CD drive (why does that happen, it is a USB storage device & modem not a CD) - ANYWAY, usb_modeswitch just says :

Looking for target devices …
Found devices in target mode or class (1)
Looking for default devices …
No devices in default mode or class found. Nothing to do. Bye

Could someone who knows how to get the e1750 working with Suse 11.3 (64bit) please make a simple step by step instruction for those who have no clue (i.e. Me) - Better still, can’t someone write a mobile broadband utility that allows you to select the device you intend using, and then configures it for you (you know something one might expect within Yast/KDE Network Manager).

I love Novell products generally, and I don’t want to use another distro, because I think SuSE is very important (especially as I want to get to grips with life after Netware), and also other distros have their issues. Somebody needs to pull these annoying loose ends together and make Linux more than a product with potential, it needs to work as well as or better than the competition.

Moaning Over, now, can anyone help - if you need more info gimme basic insructions (I’m a DOS/Windows techie, very unfamiliar with Linux) and I will supply what you ask.