USB Installer not working - get_second_stage() failed


I have gotten a new Fujitsu Lifebook U7411 for testing purposes and want to create a proof of concept regarding the system compatibility. I have been trying to install Leap 15.3 and Tumbleweed here. But after choosing the boot medium USB, I get the following weird message and 3 sec. later, the system turns off.

Instead of GRUB, I get the following console message:

get_second_stage() failed: Invalid Parameter
Something has gone seriously wrong: shim_init() failed: Invalid Parameter

I have never seen that before with other devices.

I have been trying:

  • Secure boot - on/off
  • TPM on/off
  • Different USB pens
  • Tumbleweed and 15.3 NET installer image
  • Tumbleweed and 15.3 DVD installer image
  • Verified installation media and iso checksum
  • “dd” to creating the USB pen
  • openSUSE “imagewriter” to creating the USB pen
  • Ubuntu and ArchLinux → can boot from the same USB pen
  • 15.3 DVD installer pen can boot onto another device

Hopefully there exists one more idea/chance. :slight_smile:

Best and thanks a lot!

I have done most of my installs with a USB, and without problems. However, I see that there is a newer DVD installer, and I have not tried that. Is that the one you used (with a May 26th date, and no Build number)?

Have you tried disabling secure-boot in your BIOS?

thanks for your response.
Yes, I tried the latest images from yesterday.

For example this one:
Last modified: Wed, 26 May 2021 13:36:24 GMT (Unix time: 1622036184)
SHA-256 Hash: 54fb3a488e0fececf45cdaeefaccfb64437745da4b1ca444662e3aac20cf37b5

But I tried also a Tumbleweed installation and got the same error message. Whereas those usb pens could be used on another (Dell) Notebook. On the other hand, an Ubuntu installation stick shows me the GRUB menu as expected on both devices.
Yes, my first reaction was disabling secure boot. Nothing has changed.

This drives me crazy… lol!

I’ll try later today with the latest installer.

From your description, I think it’s a problem with your system (really, with the UEFI firmware). And it probably needs a bug report.

There have been changes to “shim” lately, and maybe your firmware doesn’t like those changes. And yes, both Tumbleweed and Leap 15.3 have seen those changes. The DVD installer for Leap 15.2 should still be using the older “shim”.

You’re absolutely right!
I didn’t try the 15.2 image before because I thought some drivers from 15.2 are a bit to old for this device.
But it works, at least I can do an installation and maybe an upgrade afterwards.

I will file an official bug report later. Maybe it is interesting for the developers.

I’m currently doing a USB install of Leap 15.3, and it is working fine. But that’s on my hardware.

Checking, I see that “shim” has not changed since the previous release (around May 12), so I won’t expect any problems here.

Yes, that bug report will be needed.

It is possible that you could install Leap 15.3 by modifying the install media. In the small EFI partition, replace “bootx64.efi” with the version from the Leap 15.2 installer (it is really just a renamed “shim.efi”). You would need secure-boot disabled for this to work. And your newly installed system would probably have the same problem, so you would need the Leap 15.2 shim there also – at least until this bug is fixed.

Sorry for my late feedback. I had a curious weekend.
I’ve found a quite similar bug and attached my feedback there:

So, the current state:
I have successfully performed a 15.2 installation and then a migration to 15.3 (incl. secure boot after migration).

I will try your suggestion (bootx64.efi replacement) later these day. Thanks for your help!

Same problem here, with a Fujitsu Lifebook U759. Was installed with 15.1, upgraded to 15.2. Now trying to upgrade to 15.3 via installation media.

I downloaded the installation image for the official release on June 11. Booting displays ""get_second_stage() failed() and “something went seriously wrong, shim_init(): wrong parameter”

Will try to replace the efi boot stage in the install media from the 15.2 version later

I replaced bootx64.efi on the media by shim.efi from the running 15.2 installation /boot/efi/EFI/opensuse/shim.efi, but that did not help. secure boot is disabled

Hello user,

Could you please tell if the device works OK with linux. Due to ‘contracts’ our University recommends this laptop (Uni freiburg). And they are not sure about Linux.

  1. is audio mic + webcam OK
  2. U7410 had serious problems with keyboard? Is this OK with 7411?


have the same problem as the thread creator on a Fujitsu lifebook U939

none of the proposals worked for me either.

is there a solution for this problem in the meantime?