usb install/upgrade/rescue does shutdown while booting

Hi,

On my Dell XPS the upgrade from Leap 15.0 to 15.1 fails during the boot sequence. When booting from USB stick the menu to select Install, Upgrade, Rescue etc. appears normally. After selecting either of these options the booting continues (green bars appear). The messages on the screen report: loading basic drivers. scanning hardware …
However, after reporting “Activiting USB devices” the system suddenly powers down, without warning.

I tried several BIOS settings. BIOS is allowing USB boot so it seems. The USB stick also seems OK. I installed and upgraded other systems without problems using it.
For the record: the filesystem containing Leap 15.0 is encrypted.( can’t see how this can be related though)

Any help is welcome!

This is probably not very helpful – but …

I once had a computer (a Dell Dimension) which behaved in that way. When booting Leap 42.3, it would just shutdown, but booting 42.1 was okay. But I was persistent, and after a few tries I could get it to boot. Then it began to shutdown the same way when booting 42.1. And then it started behaving that way with Windows. It was a 10 year old computer, so I just replaced it. I’m pretty sure that it was a hardware problem – perhaps with the power supply. In retrospect, I should have looked closely at the power supply to see if there were any swollen electrolytic capacitors.

As said above, this probably doesn’t help you. But maybe consider whether there might be a problem of failing hardware.

The machine is pretty new. Normal boot from SSD works without issues. USB port works as expected also. So I think hardware problem is not likely.
But thanks anyway, you can never know…

Exactly which XPS model do you have? Maybe giving us output from ‘inxi -b’ would be enough information about your hardware to make other suggestions. I’d give one of the acpi= parameters on https://www.kernel.org/doc/Documentation/admin-guide/kernel-parameters.txt a try. Another might be adding ‘plymouth.enable=0’ or noplymouth as a command line parameter, and removal of quiet, would help either with clues or better. Appending nomodeset is another option that may be worth trying.

Inxi -b gives:

~>inxi -b
System:    Host: linux-p5i6 Kernel: 4.12.14-lp150.12.64-default x86_64 bits: 64 Desktop: KDE Plasma 5.12.8
           Distro: openSUSE Leap 15.0
Machine:   Device: laptop System: Dell product: XPS 15 9560 serial: N/A
           Mobo: Dell model: 05FFDN v: A00 serial: N/A UEFI: Dell v: 1.9.4 date: 04/23/2018
Battery    BAT0: charge: 85.9 Wh 100.0% condition: 85.9/97.0 Wh (89%)
CPU:       Quad core Intel Core i7-7700HQ (-HT-MCP-) speed/max: 2800/3800 MHz
Graphics:  Card-1: Intel Device 591b
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile]
           Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x1080@59.93hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) version: 4.5 Mesa 18.0.2
Network:   Card-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter driver: ath10k_pci
           Card-2: Qualcomm Atheros
Drives:    HDD Total Size: 512.1GB (43.5% used)
Info:      Processes: 281 Uptime: 1 day  4:22 Memory: 3272.7/15884.9MB Client: Shell (bash) inxi: 2.3.40 

If this is a notebook it appears to be a Optimus (Intel+NVIDIA GPU) this requires special handling.

Try starting install with nomodeset.

At grub menu press e and find line starting linux or linuxefi. add nomodeset to end of line (note it is long and may rap)

After install you need to install either suse-prime or bumblbee

nomodeset did the trick. Setting this in the boot parameters (using Edit Entry in the menu) made the boot sequence to complete normally.

Thanks!!

Question:
wouldn’t it be an idea to set nomodeset by default, at least for the Rescue option? Rescue is often a last resort to get things going again. You always want to have that one booting, I imagine…

Indeed, nomodeset was the solution. Strange thing that it wasn’t needed for the initial install of Leap 15.0.

I’ve tried to use suse-prime on Leap 15.0, but couldn’t get it working (could have been my mistake). Is it considered reliable?
Then I could give it another go on Leap 15.1.

Suse-prime was improved for 15.1 via 1121246 – Enable support for Optimus systems (Intel/NVIDIA GPU combo) on our products.

Did you read any of the nomodeset link I provided?

Yes. It explains a lot. It says also:

Once the installation is complete and you’ve booted it the first time, examine /etc/default/grub. Likely nomodeset will be included on the GRUB_CMDLINE_LINUX_DEFAULT= line. It will severely handicap performance of whichever desktop or window manager you use, as it is intended to be a troubleshooting parameter.

I’m just wondering because Rescue is a troubleshooting tool, wouldn’t nomodeset as a troubleshooting parameter, be appropriate? Probably there is a good reason it’s not default. But it’s not obvious to me. Is it maybe because on some hardware nomodeset would cause Rescue to fail?

Rescuing isn’t just for video trouble. Putting video into crippled mode can unnecessarily impede or block other troubleshooting procedures.